Support Alerts

Tableau Online 升级

Tableau Online 即将升级至 2020.4。如需了解具体升级时间的更多信息,敬请访问 Trust 站点

升级到 Tableau Prep Builder 2020.3.3

升级到 Tableau Prep Builder 2020.3.3 时需要了解的事项

概述

Tableau Prep Builder 简介

Tableau Prep Builder 是 Tableau 推出的一款产品,旨在让人人都可以快速、放心地合并、调整和清理数据,以便于分析。

如何获取 Tableau Prep Builder

Tableau Prep Builder 与 Tableau Desktop 共同包含在 Tableau Creator 授权方式中。

开始使用 Tableau Prep Builder:

Tableau Prep Builder 2020.3.3 中的新增功能

首先请阅读 Tableau 高级产品经理 Anushka Anand 博士撰写的这篇博文:

Tableau Prep 再添新功能:步骤分组、自定义会计日期等

注:从 2019.1.2 版本起,Tableau Prep 更名为 Tableau Prep Builder。之所以进行这次更名,是为了与新推出的 Tableau Prep Conductor 区分开来。Conductor 以插件的形式在 Tableau Server 上运行。随着 Conductor 的推出,您在 Tableau Desktop 上运行的 Prep Builder 中所做的工作就可以保存到一个集中化、可扩展且可靠的服务器环境中运行,这样可以确保您的数据始终是最新的且易于共享。


安装和部署 Tableau Prep Builder

崩溃后自动恢复流程


万一出现崩溃,Tableau Prep Builder 会自动保存您的流程,这与 Tableau Desktop 一样。下次您打开该应用程序时,它会显示一个对话框,其中列出了已恢复的流程供您选择。您可以打开某个已恢复的流程,然后从上次中断的位置继续;如果不需要该流程,也可以删除已恢复的流程文件。已恢复的流程保存在我的 Tableau Prep 存储库已恢复的流程文件夹内。如果已恢复的流程文件夹中存有草稿流程,那么每次您打开 Tableau Prep Builder 时,此对话框都会显示。

此自动恢复功能默认处于启用状态,不过管理员可以在安装过程中或安装后将其禁用。有关更多信息,请参阅保存流程

构建和组织流程

新用户可更快上手


现在,当您连接到一个数据源并将其拖动到工作区中时,Tableau Prep Builder 会在您的输入步骤旁显示一个虚构的清理步骤,以此说明您的下一个清理步骤可以添加到什么位置。只需点击建议的清理步骤,即可一键添加它,这有助于您查看数据的详细信息,以便您可以立即开始检查和清理自己的数据。

有关更多信息,请参阅构建和组织流程

将步骤分组


在组织流程时,可以使用新的分组选项来选择一系列相互关联的步骤,将它们收纳到一个文件夹中。得益于这项新功能,大型复杂的流程变得更易于浏览、检查和与他人共享。其他用户不用再了解整个流程,可以只专注于跟自己相关的那组步骤。

您可以更改组的颜色,为其添加说明,将该组步骤复制并粘贴到流程中的其他区域,或者将分成组的步骤保存到文件或服务器中以供在其他流程中重复使用。只需选择要分成组的一系列步骤,再从菜单中选择分组即可。

所选的步骤随即会被收纳到一个文件夹中,您可以为该文件夹命名。您随时可以向该组中添加更多步骤或从中移除步骤,不过,只有通过流程线彼此直接关联的步骤才能添加到同一组中。您可以随时点击双箭头图标 展开或收起该组。

有关更多信息,请参阅构建和组织流程

清理并调整数据

在转换日期字段时使用自定义财年。

如果您的财年不是从 1 月份开始,现在您可以设置一个自定义月份;这样,Tableau Prep Builder 在将您的“日期”或“日期和时间”字段中的值转换成不同的日期部分时,就会使用该起始月份。只需从相应字段的更多选项菜单中选择自定义财年,然后设置自定义的财年起始月份以及要将字段值转换成的日期部分即可,整个过程一步就可轻松完成。

有关更多信息,请参阅应用清理操作

通过顶部菜单在全局范围内配置 Rserve 和 TabPy


在以前的版本中,如果您希望在流程中加入脚本步骤,则对于每一个包含脚本步骤的流程,都需要在每个脚本步骤中配置与 R 或 TabPy 的连接。现在,您只需通过顶部的“帮助”菜单为这些分析扩展程序进行一次配置,就像在 Tableau Desktop 中那样,所做的配置即可应用于您使用的任何流程。

只需选择帮助 > 设置和性能 > 管理分析扩展程序连接,然后从下拉列表中选择 Rserve 或 Tableau Python (TabPy) 并输入连接信息即可。如果您同时使用这两个分析扩展程序,则可以使用该对话框分别输入每个服务器的连接信息。

注:对于包含脚本步骤的较旧流程,您将需要使用这个新对话框重新配置服务器连接。

有关如何在流程中使用 Rserve 和 Tableau Python (TabPy) 的更多信息,请参阅在流程中使用 R 和 Python 脚本

保存和共享工作成果

保存和重复使用您的增量刷新配置


现在,当您为增量刷新功能配置输入和输出步骤时,如果您复制并粘贴这些步骤或者将它们保存下来以供今后重复使用,那么增量刷新配置信息就会保留下来,这样您无需从头设置它们即可重用这些配置。

有关设置和使用增量刷新功能的更多信息,请参阅使用增量刷新功能刷新流程数据

Tableau Prep Builder 过往版本中的新增功能

您可能想知道过往月份发布的 Prep Builder 中分别有哪些新增功能。以下为摘要信息,附有产品帮助链接。

Tableau Prep Builder 2020.3.2 中的新增功能


Tableau Prep Builder 在此版本中没有新增任何功能,但提供了一些重要的安全更新。

Tableau Prep Builder 2020.3.1 中的新增功能

保存和共享工作成果

将流程输出数据保存到外部数据库

现在,您可以将全部流程结果或其中的增量部分输出到支持的数据库中,并用准备好的整洁流程数据创建或替换表数据,或者在表数据后追加这些流程数据。Tableau Prep Builder 支持将流程数据保存到以下数据库:

  • Amazon Redshift
  • Microsoft SQL Server
  • MySQL
  • Oracle
  • PostgreSQL
  • Snowflake
  • Teradata

具体操作步骤如下:在输出这一步,从 将输出保存到 下拉菜单中选择 数据库表。然后,选择要将流程输出保存到的数据库及表。您也可以输入一个表名称,以在该数据库中创建一个新表。在字段对比预览画面中,会显示流程中的字段与表中的字段之间的匹配状态。状态字段中会显示与不匹配的字段有关的详细信息。

您还可以添加可在数据加载到数据库表中之前或之后运行的 SQL 脚本。可以使用这些脚本在运行流程前创建表数据的副本、添加索引、为数据库表添加数据库约束等。

有关将流程输出保存到表中的更多信息,请参阅 将流程输出数据保存到外部数据库(2020.3.1 及更高版本)

Tableau 数据提取逐渐淡出

Tableau 数据提取 (.tde) 文件不再受支持
从 2020.3.1 版开始,不再支持使用 Tableau 数据提取 (.tde) 文件进行流程输出。凡发布到 2020.3 及更高版 Server 的流程,只要是输出到 Tableau 数据提取 (.tde) 格式的文件,都必须转换成 Hyper 数据提取 (.hyper) 文件;否则,流程在运行时将失败。目前仍支持使用 Tableau 数据提取 (.tde) 文件进行流程输入。

有关创建和发布数据提取的更多信息,请参阅 创建和发布数据提取及数据源

从命令行使用 .json 运行流程

从命令行创建用于运行流程的 .json 凭据文件变得更加轻松

如果您使用命令行运行流程,并连接或输出到 Sever 或数据库,那么在创建 .json 凭据文件时现在可以采用进一步简化的语法。

有关更多信息,请参阅 通过命令行刷新流程输出文件

Tableau Prep Builder 2020.2.3 中的新增功能

连接到数据

通过 Snowflake 连接到数据时,使用 OAuth 认证。

现在,当使用 Snowflake 连接到您的数据时,可使用以下任何一种验证方法,就像在 Tableau Desktop 中一样:

  1. 用户名和密码
  2. SAML IdP
  3. OAuth

如需详细了解如何使用此连接器连接到您的数据源,请参阅 Tableau Desktop 帮助中的 Snowflake

Tableau Prep Builder 2020.2.2 中的新增功能

连接到数据

使用 Tableau Server 或 Tableau Online 连接到数据

在之前的版本中,您可以连接到存储在 Tableau Server 或 Tableau Online 上的已发布数据源。现在,如果您启用了 Tableau Catalog 随附的 Data Management Add-on, 您可以搜索并连接到存储在 Tableau Server 或 Tableau Online 中的数据库和表。

只需在“连接”窗格中新增的“搜索数据”部分下选择“Tableau Server”,然后登录 Server。“搜索数据”对话框随即打开,您可以从精心挑选的数据源中进行搜索和选择。

通过参考数据源描述、数据质量警告和认证等其他元数据,您无需离开 Tableau Prep Builder 便可以找到所需的数据源。您还可以使用右上角的筛选器选项,按连接类型、数据质量警告和认证对结果进行筛选。
如果您没有启用 Tableau Catalog 随附的 Data Management Add-on,则只会显示已发布的数据源,您无法查看元数据。

要详细了解如何连接到数据,请参阅 连接到已发布数据源 (2019.3.1 及更高版本)

使用 Alibaba MaxCompute 连接到数据

如果您的数据存储在数据仓库中,您现在可以使用 Alibaba MaxCompute 连接到此数据源。如需详细了解如何使用此连接器连接到您的数据源,请参阅 Tableau Desktop 帮助中的 Alibaba MaxCompute

Tableau Prep Builder 2020.2.1 中的新增功能

连接到数据

连接到您的 Salesforce.com 数据

Tableau Prep Builder 现在可以连接到您的 Salesforce 数据,因此您可以清理和准备这类数据以便在 Tableau 中进行分析。目前尚不支持使用自定义 SOQL 和创建标准连接。

有关更多信息,请参阅 连接到 Salesforce 数据(2020.2.1 及更高版本)

确保流程数据保持最新

使用增量刷新功能,仅处理您的最新数据

如果您的流程数据不断变化,您现在可以使用增量刷新功能仅返回和处理自流程上次运行以来添加的最新数据行,从而节省时间和资源。为此,只需为您的流程配置增量刷新参数,来告诉 Tableau Prep Builder 如何从您的输入数据中检测和返回新行,以及您希望在该流程运行时输出如何更新您的表。

现在,您可以选择将新数据附加到现有表,或者使用 Tableau Prep Builder 的现有功能将表中的数据替换为新数据。

设置好流程后,可以使用 Tableau Prep Conductor 按计划运行流程,也可以在 Tableau Prep Builder 中或者通过命令行界面以增量方式运行各个流程。
注:要想使用增量刷新功能来按计划运行流程,必须使用 Tableau Server 2020.2 及更高版本(启用了 Tableau Prep Conductor)。

有关使用增量刷新功能设置和运行流程的更多信息,请参阅使用增量刷新功能刷新流程数据

Tableau Prep Builder 2020.1.5 中的新增功能


Tableau Prep Builder 产品团队致力于测试并纠正由用户报告,或者会导致客户在使用该产品时不能获得最佳体验的一切问题。在版本说明页面上,我们每月都会发布客户面临的产品缺陷的解决公告。

有关更多信息,请参阅 Tableau 支持网站上版本说明页面中的 Tableau Prep Builder 2020.1.5 版本说明

Tableau Prep Builder 2020.1.4 中的新增功能

连接到数据

使用 Cloudera Impala 连接到数据

与在 Tableau Desktop 中一样,您现在可以使用 Cloudera Impala 轻松连接到较大的数据集。

如需详细了解如何使用 Cloudera Impala 连接到数据源,请参阅 Tableau Desktop 帮助中的 Cloudera Hadoop

清理并调整数据

通过一键式操作转换数据值

为了进一步简化数据清理操作,Tableau Prep Builder 为日期数据添加了另一个快速清理菜单选项。如果需要通过转换日期值来显示某个日期部分(例如年、月或日),您可以从新的 转换日期 菜单中选择以下菜单选项之一,而不必编写复杂的字段计算。

要详细了解如何对您的日期应用清理操作,请参阅 应用清理操作

保存和共享工作成果

保持与服务器的连接

每次打开 Tableau Prep Builder 时,您不再需要登录 Tableau Server 或 Tableau Online。现在,Tableau Prep Builder 可以在您关闭该应用程序后记住您的服务器名称和登录信息,因此在下次打开该应用程序时,您会发现自己已经登录到服务器。

该选项可以节省时间,帮助您实现无缝连接,您无需先进行服务器登录即可连接到已发布的数据源或插入已保存的流程步骤,系统还可以根据您的需要即时显示兼容性警告,帮助您了解某项功能是否与您的 Server 版本兼容。

有关更多信息,请参阅 创建和发布数据提取及数据源

Tableau Prep Builder 2020.1.3 中的新增功能

安装和部署 Tableau Prep Builder

支持基于登录的许可证管理 (LBLM)

基于登录的许可证管理可帮助您在 Tableau Server 和 Tableau Online 上为具有 Creator 角色的用户管理许可。具有 Explorer 或 Viewer 角色的用户不能使用此功能。如果您在 Tableau Server 或 Tableau Online 中使用基于角色的订阅,则可以使用基于登录的许可证管理功能来简化许可证管理,这样就无需为 Tableau Desktop 和 Tableau Prep Builder 单独分配产品密钥。您只需要管理本地 Tableau Server 的一个或多个产品密钥,如果是 Tableau Online,则根本不需要管理任何产品密钥。

有关更多信息,请参阅 基于登录的许可证管理

连接到数据

使用初始 SQL 将参数传递到数据源

现在,您可以使用初始 SQL 将参数传递到数据源,以提供有关 Tableau Prep 应用程序、版本和流程名称的更多详细信息。Tableau Prep Builder 支持以下参数:
TableauApp - 返回用于访问数据源的应用程序 - Prep Builder 或 Prep Conductor。
TableauVersion - 返回应用程序版本号。对于 Tableau Prep Builder,它将返回确切的版本号,例如 2020.1.1。对于 Tableau Prep Conductor,它将返回启用 Tableau Prep Conductor 的主服务器版本,例如 2020.1。
FlowName - 返回 .tfl 文件的名称。

要详细了解如何在通过 Initial SQL 连接到数据源时使用参数,请参阅 在初始 SQL 语句中包含参数(2020.1.3 及更高版本)

清理并调整数据

使用详细级别 (LOD)、Rank 和 Row Number 计算来清理数据

如果您不想在数据的聚合级别进行分析,或者您需要执行跨行组的计算,您现在可以使用 FIXED 详细级别 (LOD) 以及 RANK 和 ROW_NUMBER 分析函数计算来为您的数据集创建您需要的数据。
例如,添加一个 FIXED LOD 计算来更改表中字段的粒度。使用新的 ROW_NUMBER () 分析函数快速查找重复的行,或使用某个新的 RANK () 函数在包含相似数据的一系列行中找出最前面 N 个或最后面 N 个值。

如果在构建这些类型的表达式时希望获得更多指导,可以使用新的可视化计算编辑器。

要详细了解如何使用这些计算字段来清理数据,请参阅 创建详细级别和排名计算

Tableau Prep Builder 2020.1.2 中的新增功能


Tableau Prep Builder 2020.1.2 中的新增功能:第三方库更新:OpenSSL、postgresql、postgres jdbc。

Tableau Prep Builder 2020.1.1 中的新增功能

连接到数据

找到流程输入所源自的连接

如果您的流程是使用多项输入构建的,那么当您后续需要做出更新或调出某个连接时,如何才能找到您用来提供不同输入的具体表或数据源呢?有时候,这并不是显而易见的事情。为了让您更容易找到流程输入和表,我们增添了一项新功能;该功能可以在“连接”窗格中突出显示选定输入所对应的连接器及表。只需在“流程”窗格中选择一个或多个输入步骤,“连接”窗格中就会突出显示相关的连接器及表。

如需详细了解如何连接到数据来构建流程,请参阅 连接到数据

清理并调整数据

暂停数据更新以提升性能

每当您对数据应用清理操作时,Tableau Prep Builder 都会刷新视图,以便您可以即时看到所做的更改产生的结果。在构建新流程时,这种持续的反馈有助于您快速判断接下来该采取哪些步骤;但有时候,应用这些更改可能需要一些时间。如果想提升性能、更快地对数据应用更改,您现在可以暂停这种持续的数据更新,然后批量应用更改。

只需在顶部菜单中选择 暂停数据更新 按钮,Tableau Prep Builder 便会为您暂停数据更新,并将配置窗格视图切换到列表视图,以便您可以快速应用更改。这样就不会在每次更改时都刷新视图,而是只显示字段的元数据。如果您已完成更改并希望查看字段值中的结果,请单击 恢复数据更新 按钮以切换回标准数据更新模式。

要详细了解如何通过暂停数据更新来批量应用清理操作,请参阅 暂停数据更新以提升性能

确保流程数据保持最新

在发布流程时为云连接器添加或嵌入凭据

在以前的版本中,如果您想要发布包含云连接器的流程并设定该流程的运行计划,则需要提前在 Tableau Server 或 Tableau Online 中配置凭据。否则,Tableau Prep Conductor 就无法检测到您的凭据,因而该流程的运行将失败。现在,完成几个简单的步骤,就可以直接通过 Tableau Prep Builder 中的“发布”对话框为云连接器添加和嵌入凭据。

只需登录您的服务器并选择 “服务器”>“发布流程”。在“发布流程”对话框中,会显示一段新的警告文本,提醒您有一些输入连接需要进行身份验证。点击此消息中的 编辑连接 链接或“连接”部分的 编辑链接 ,然后在“身份验证”下拉菜单中,选择 添加凭据

随即会显示第二条消息要求您确认所做的选择。点击 继续以转到 Tableau Server 或 Tableau Online 中的 帐户设置 页面,然后添加您的凭据。完成后,返回 Tableau Prep Builder,点击 完成 ,您的新凭据将自动嵌入到您的流程中。

如需详细了解如何在发布过程中为云连接器添加凭据,请参阅 发布流程

Tableau Prep 的版本兼容性

检测和禁用不兼容的功能

在 Tableau Prep Builder 2019.3.1 版本中,我们增添了一些警告图标和工具提示,以便您在构建流程时更容易了解哪些功能与您所用的 Tableau Server 版本不兼容。如果您打算发布该流程并按一定的时间计划来运行该流程,那么了解哪些功能不兼容就有助于您明智地决定要在流程中包含哪些功能。

在这一版本中,我们进一步提高了透明度,更便于您处理可能与您所用的 Server 版本不兼容的新功能。现在,您登录到 Server 后,Tableau Prep Builder 就能检测到哪些功能与您所用的 Tableau Server 版本不兼容,并禁用这些功能。这样,如果您打算发布您的流程并按一定的时间计划来运行该流程,就不用再凭猜测来判断可以包含哪些功能了。

如果您仍想使用这类功能并想要通过 Tableau Prep Builder 或命令行手动运行您的流程,可以直接从菜单中启用相应的功能。只需点击 使用功能 按钮,即可启用该功能及所有不兼容的功能。在 Tableau Prep Builder 2019.3.1 版本中引入的警告选项仍然可以帮助您识别哪些功能与您所用的 Server 不兼容。这样,如果您想要在 Tableau Server 中按一定的时间计划来运行该流程,就可以轻松找出并移除不兼容的功能。

要详细了解如何使用不兼容的功能,请参阅 Tableau Prep 的版本兼容性

Tableau Prep Builder 2019.4.2 中的新增功能

连接到数据

使用新的连接器连接到更多数据


在此版本中,我们新增了以下数据连接器:

  • Alibaba AnalyticDB for MySQL
  • Alibaba Data Lake Analytics
  • Databricks
  • Kyvos
  • Qubole Presto

要详细了解如何使用这些连接器连接到数据,请参阅“Tableau Desktop 与 Web 制作帮助”中的 支持的连接器 。要全面了解如何通过连接到数据来构建流程,请参阅 连接到数据

清理并调整数据

更加轻松地将列转置为行


现在,如果需要将数据从列转置为行,您可以在配置窗格中手动选择字段进行转置,也可以让 Tableau Prep Builder 为您推荐要转置的字段并为您创建转置。这两种方法都会自动生成转置步骤,因此您可以快速执行任何其他转置操作,例如重命名转置字段或转置更多字段。
要从配置窗格手动进行从列到行的转置,只需选择要转置的字段,然后点击右键或按住 Ctrl 键点击鼠标 (MacOS),然后从菜单中选择将列转置为行以创建新的转置步骤并转置字段。

如果 Tableau Prep Builder 检测到可以转置的字段,配置窗格工具栏中将显示建议选项。单击工具栏中的
灯泡图标 Small lightbulb ,然后选择转置建议。相关建议会显示将转置的字段。只需单击应用即可生成转置步骤并转置您的字段。

要详细了解如何转置您的数据,请参阅转置您的数据。要详细了解如何使用建议来清理数据,请参阅使用建议应用清理操作(2018.3.2 及更高版本)。

其他增强功能

查看关于长期运行的操作的反馈


为了在处理大型数据集或流程时为您提供更多可见性,我们在流程窗格的顶部添加了进度指示器,以便在 Tableau Prep Builder 处理数据时向您提供状态更新。现在,您可以更清楚地了解 Tableau Prep Builder 在后台执行的操作,因此您不必再猜测数据处理是否仍在正常进行。

Tableau Prep Builder 2019.4.1 中的新增功能

连接到更多云端数据

在此版本中,我们添加了以下云连接器:

  • Box
  • DropBox
  • Google 云端硬盘
  • OneDrive

如果您打算将流程发布到 Tableau Server 或 Tableau Online,则可能需要进行一些额外的配置,以便为这些连接器保存您的凭据。要详细了解如何使用云数据连接器进行连接,请参阅 连接至云数据源

其他增强功能

与 Tableau 分享使用情况数据

Tableau 会收集有助于我们了解产品使用情况的数据,以便改进现有功能并开发新功能。收集和处理所有使用情况数据时,我们都会遵守 Tableau 隐私政策。但是,如果您不想参与,可以选择禁止分享。

用于禁止分享这类数据的选项有所变化。使用情况数据收集功能在默认情况下处于启用状态。如果您不想参与,请从安装程序或“自定义安装程序”(MacOS) 对话框中选中不发送产品使用情况数据复选框,也可以在安装后从“帮助”菜单中选中此复选框。

更多信息,请参阅 Tableau Desktop 和 Tableau Prep 部署指南中的关闭使用情况报告

不再为 MacOS 自动安装默认数据库驱动程序

在 Mac 上安装 Tableau Prep Builder 时,我们仅自动安装 PostgreSQL 数据库驱动程序。如果您需要使用其他驱动程序来连接数据,可以从驱动程序下载页面安装它们。

Tableau Prep Builder 2019.3.2 中的新增功能

性能改进

交互性能改进

有些用户可能在 Prep Builder 数据工作流中遇到过性能问题。对于这些用户,现在有好消息啦!此版本包含诸多改进:

  • 应用软件启动 – 应用软件启动速度比 3.1 版本快多达 15%。
  • Excel 和文本文件加载 – Excel 和文本文件加载速度比 3.1 版本快多达 50%。
  • 通配符并集 – 使用通配符并集的客户应能体验到大幅性能提升:对于文本文件,该操作的速度最多可提升 50%;对于 Excel 文件,该操作的速度最多可提升 700%。
  • 节点具体化 – 通过对流程中缓存并集步骤的更新,客户可以获得高达 95% 的性能提升,具体取决于其流程中并集步骤的数目和单击流程的位置。
与 Conductor 的兼容性

交互性能改进与 Conductor 兼容,应该不会在任何方面影响批量模式。

构建和组织流程

已更新的插入步骤

流程中的插入步骤以前是多步骤过程,但通过这些更新,您可以插入任何步骤(输入和输出除外),无需完成多步骤过程。此功能将适用于复制和粘贴步骤以及可重用流程部分。打开任何流程并导航到一个分支。接着将鼠标悬停在分支上时,注意到有一个新的“+”菜单。然后单击该图标,选择要插入的步骤。

有关更多信息,请参阅 添加或插入步骤

与 Conductor 的兼容性

此功能与 Conductor 完全兼容。它不会影响流程运行方式。

可重用步骤

许多用户发现,自己在准备数据时经常会应用同一套清理操作。因此,他们希望能够在相同的流程中针对不同数据以及跨多个流程重用自己的一些工作。此新功能可帮助用户轻松重用流程中的步骤,从而使用户节省时间并尽可能利用其他人的工作步骤。现在,用户可以选择一组已连接的步骤,并将其保存在文件中以便在其他流程中重用,或将其发布到 Tableau Server 供以后重用或便于他人利用自己的工作步骤。

有关更多信息,请参阅 创建可重用的流程步骤(2019.3.2 及更高版本)

与 Conductor 的兼容性

流程片段是可在 Tableau Server 上发布的 .tfl 文件。如果有输入和输出步骤,则可以计划这些片段。

检查和筛选数据

模糊匹配自定义数据角色

借助 Prep Builder 2019.2.2,用户可以修复内置数据角色的无效值,方法是将其替换为最接近的有效值(模糊匹配)。Prep Builder 2019.3.1 则推出了创建自定义数据角色的功能。通过此版本,用户可以自动修复无效值,其工作原理就是匹配无效值并将其替换为最接近的有效值。现在,用户可以利用自定义数据角色并自动修复无效值!

选择任何数据集和分类字段并作为自定义 数据角色发布。然后将数据角色应用于包含不准确值的数据。通过给出的建议,您可以选择将无效值替换为与数据角色相应的最接近值(系统使用发音和拼写算法来确定),您只需应用它即可修复数据质量问题。

有关模糊匹配的更多信息,请参阅 按数据角色对类似值进行分组

与 Conductor 的兼容性

模糊分组算法不会在批量模式下运行 - 当流程制作完毕且用户选择分组算法时,精确的分组会保存在 更改列表 中,它们会进而在批量模式下运行,使此功能与 Conductor 兼容。

导航和显示

流程导航

如果您在 Prep Builder 中构建大型流程,那么导航这些流程通常很难。通过 流程导航 ,客户获得流程的最小化版本,从而便于进行导航。借助此工具,还可以放大和缩小流程。

  • 打开一个大型流程。
  • 迷你地图位于右下角。
  • 使用选取器,在流程中导航。
  • 使用迷你地图上的其余按钮,如下所示:
  1. 使用向下箭头可以将迷你地图最小化。
  2. 方形”按钮可以将流程缩到足够小,以将整个流程调整为适合屏幕的大小。
  3. +”/“-”按钮可以缩放流程。
  4. 单击 % 指示符可以自动将流程缩放回 100%。

有关更多信息,请参阅 使用流程导航工具

与 Conductor 的兼容性

完全兼容。

列表视图

客户喜欢输入步骤中的视图,因为他们可以轻松查看字段并执行快速操作(例如重命名或移除字段),并希望所有步骤都有类似体验。当客户经常看到视图中的字段少于 4 或 5 个,这使得他们必须通过滚动操作才能查看其余字段时,他们有时会失望。通过新的列表视图,客户可以查看专门侧重于元数据的不同数据视图。通过该视图,用户可以轻松地对步骤执行移除和重命名操作,还可以更改数据类型和添加计算。

  • 打开任意流程。
  • 导航到任意步骤。
  • 通过配置窗格上方的工具栏,选择列表视图图标:
  1. 将鼠标悬停在任意字段,点击“X”按钮以移除该字段。
  2. 通过“...”菜单,可以看到配置窗格中提供的所有清理选项。执行影响值的任何操作时(例如,筛选),都会自动将您转到配置窗格。这些操作仅影响元数据(例如重命名字段)。

有关更多信息,请参阅 选择视图

与 Conductor 的兼容性

完全兼容,因为它对输出运行方式毫无影响。

命令行界面 (CLI) 的改进

运行每个流程时不再需要 MacOS 密钥链凭据

许多客户在其计算机上使用命令行界面自动运行 Tableau Prep 流程。我们在此领域的最新改进使用户在每次运行流程时,不再需要手动输入 MacOS 密钥链凭据。只需使用 Tableau Prep Builder 中安装的命令行界面即可运行任何流程。

与 Conductor 的兼容性

N/A

兼容性

Tableau Prep Builder 是一款独立产品,可与 Tableau Desktop、Tableau Server 和 Tableau Online 无缝衔接。在使用 Tableau Prep Builder 的过程中,您可以随时创建数据提取、将数据源发布到 Tableau Server 或 Tableau Online,甚至可以直接从 Tableau Prep Builder 中打开 Tableau Desktop 来预览数据。

  • Tableau Prep Builder 在 Windows 和 Mac 上皆可运行。它可以创建 Tableau 数据提取(.tde 和 .hyper)以及 CSV 文件,这些文件可以在 Tableau 10.0 和更高版本中使用。
  • 在 Tableau Prep Builder 中,可以连接到很多能在 Tableau Desktop、Server 和 Online 中使用的数据源。要查看 Tableau 支持的所有数据源的列表,请单击此处
  • 对于某些数据源,在连接到数据之前,您可能需要先安装驱动程序。如果遇到这种情况,请参阅驱动程序下载页面。

新工作区让您可以更快分析出真知灼见

Tableau Prep Builder 使用 Tableau 的数据连接器、计算语言和管控结构,让您能够快速上手,并可以在分析流程中的任何阶段开展协作。

Tableau Prep Builder 工作区包括连接窗格、更改窗格,以及可以帮助您探索数据和与数据交互的三个协同区域:

  1. 连接窗格:连接窗格显示您连接到的数据库和文件。添加与一个或多个数据库的连接后,将您要使用的表拖至流程窗格即可。 
  2. 流程窗格:连接、清理、调整和合并数据时,您可以在流程窗格看到相应的步骤。在每个步骤顶部的图标上悬停鼠标,即可查看所做的更改。 
  3. 配置窗格:工作区中心位置的配置窗格显示数据样本中每个字段的摘要。用户可以在此处看到数据的组织结构,并快速找出异常值和 Null。
  4. 更改窗格:Tableau Prep Builder 依更改顺序记录每项更改,因此用户可以随时返回检查这些更改,必要时可进一步编辑。
  5. 数据网格:数据网格显示数据的行级别详细信息。所显示的值反映了配置窗格中定义的操作。您可以筛选、“只保留”和排除此网格中的各个字段值,还可以通过拖放字段来更改显示顺序。

要查看完整说明(包含视频),请访问产品帮助中的工作区

保存和共享输出

定义输出

Tableau Prep Builder 可以保存三种类型的文件:

  1. 包含流程的 .tfl 文件
  2. 包含流程以及基于本地文件的数据源(例如 Excel 和文本文件)的 .tflx 文件
  3. 包含流程运行结果的输出文件

输出文件可以保存为 .hyper、.tde 和 .csv 格式,它们是在输出步骤中指定的。输出文件可在 Tableau Desktop 中打开并可发布到 Tableau Server 或 Tableau Online。

Tableau Desktop

在 Tableau Desktop 上运行流程后可获得格式为 .tde 或 .hyper 的 Tableau 数据提取文件,具体格式取决于 Tableau 的版本,二者都保存在 Tableau 存储库的“数据源”文件夹中。如果要将您准备的数据用于其他工具或流程,您还可以输出为 .csv 文件。

注意!创建数据提取(无论是 .tde 还是 .hyper)并制作基于该数据提取的工作簿后,请遵循适用于其他使用情况的 Tableau 版本兼容性规则。有关更多信息,请参阅使工作簿在版本之间兼容

Tableau Server

要将输出发布到 Tableau Server,请使用 Tableau Prep Builder 中的“发布”菜单。必须启用 Tableau Server REST API,才能收到 Tableau Prep Builder 的发布请求。有关更多信息,请参阅 REST API 要求

Tableau Online

您还可以使用 Tableau Prep Builder 的“发布”菜单将输出以 .hyper 数据提取、.tde 数据提取或 .csv 文件的形式发布到 Tableau Online。这样就可以在对数据进行清理、格式设置和合并后,让其他用户可以对这些数据进行集中式访问。

以更快节奏发布 Tableau Prep Builder 更新

我们正在快速完善 Tableau Prep Builder,后续将频繁推出新功能,更新节奏不会受 Tableau Desktop、Tableau Server 或 Tableau Online 的发布周期影响。客户需要升级到最新版 Tableau Prep Builder,方可用到新功能和修复产品中的已知问题。

本网站将定期发布指向社区用户情景、产品信息以及重要技巧的新链接,让用户在高效迅捷、充满乐趣的体验中,使用最新功能进行数据准备。

其他资源

如何获取 Tableau Prep Builder?

Tableau Prep Builder 仅以订阅方式提供,我们推出的 Tableau Creator 授权方式即包含这款产品。享受维护服务的现有 Tableau Desktop 用户可以凭其维护协议,下载和使用 Tableau Prep Builder。如果您尚未下载 Tableau Prep Builder,可以访问此页面进行下载,也可直接点击本升级页面顶端的下载按钮进行下载。该按钮始终指向 Prep Builder 的最新版本。

不确定自己的许可证情况?请先阅读维护 Tableau Desktop 和 Tableau Prep Builder 的许可证

抢先免费试用 Tableau Prep Builder!

您可以在此处下载 Tableau Prep Builder 的 14 天免费试用版本。
查看技术规范

可在此处查看 Tableau Prep Builder 的技术要求。
Tableau Prep Builder 版本说明

获取帮助

自助资源

技术支持
为了在联系 支持人员后得到令您满意的结果,请提供以下内容:
  • 问题及任何错误消息(展开状态)的屏幕截图
  • 给您致电的最佳时间

咨询服务

我们的顾问可以带您了解如何发挥 Tableau Prep Builder 新功能的最大功用,充分发掘数据中蕴藏的价值。