Tableau Prep Builder 2019.4.2 へのアップグレード

Tableau Prep Builder 2019.4.2 にアップグレードする際に知っておくべきこと

概要

Tableau Prep Builder の概要

Tableau Prep Builder は、分析に必要なデータの結合、分析に適した形式への変換、クリーニングを、誰もが自信をもってすばやくできるように設計された Tableau 製品です。

Tableau Prep Builder の入手方法

Tableau Prep Builder は Tableau Desktop とともに、 Tableau Creator ライセンスプログラムに含まれています。また、Tableau Desktop をすでにご利用でメンテナンス契約をお持ちのお客様にも、メンテナンス契約に含まれるサービスとして Tableau Prep Builder をご利用いただけます。

Tableau Prep Builder を使い始めるために

Tableau Prep Builder 2019.4.2 の新機能

はじめに、Tableau でシニアプロダクトマネージャーを務める Anushka Anand 博士のブログをご覧ください。

Tableau Prep Builder の新機能: ピボットの簡略化、進捗インジケーター、新しいコネクタ

注: バージョン 2019.1.2 より、Tableau Prep は Tableau Prep Builder という名称に変わりました。これは、アドオンとして Tableau Server で使用する新しい Tableau Prep Conductor と区別するための変更です。Conductor を使用することで、Tableau Desktop の Prep Builder で実行した作業を保存し、一元管理されたスケーラブルかつ信頼性の高いサーバー環境で実行できます。これによってデータは常に最新に維持され、簡単に共有できます。


データへの接続

新しいコネクタで接続できるデータが拡大


今回のリリースでは、以下の新しいデータコネクタが追加されました。
  • Alibaba AnalyticDB for MySQL
  • Alibaba Data Lake Analytics
  • Databricks
  • Kyvos
  • Qubole Presto

上記のコネクタを使用してデータに接続する方法の詳細は、Tableau Desktop と Web 作成のヘルプの「 サポートされるコネクタ 」をご覧ください。また、データに接続してフローを作成する方法の概要は、「 データへの接続」をご覧ください。

データのクリーニングと分析に適した形式への変換

列から行へのピボット処理がはるかに簡単に


データを列から行にピボットする必要がある場合に、ユーザーがプロファイルペインでフィールドを手動で選択してピボットすることも、Tableau Prep Builder がピボットするフィールドを推奨してピボットすることもできるようになりました。どちらのオプションでも、ピボットのステップが自動的に作成されるため、ユーザーはピボットされたフィールドの名前変更や他のフィールドのピボットなど、別のピボット操作をすぐに行うことができます。
プロファイルペインで列から行に手動でピボットするには、ピボットするフィールドを選択した後、右クリックまたは control キーを押したままクリック (MacOS) し、メニューで [列を行にピボットする] を選択します。すると新しいピボットステップが作成され、フィールドがピボットされます。

Tableau Prep Builder がピボット可能なフィールドを検出した場合は、プロファイルペインのツールバーに推奨事項オプションが表示されます。ツールバーで電球のアイコン Small lightbulb をクリックし、推奨されたピボットを選択してください。推奨事項には、ピボットされるフィールドが表示されます。[適用] をクリックすると、ピボットのステップが作成されてフィールドがピボットされます。

データのピボットの詳細は、「データのピボット処理」をご覧ください。また、推奨事項を使ってデータをクリーニングする方法の詳細は、「推奨を使用したクリーニング操作の適用 (バージョン 2018.3.2 以降)」をご覧ください。

その他の強化機能

長時間の処理に関するフィードバックを見る


大きなデータセットやフローを処理している場合に状況をわかりやすくするために、フローペインの上部に進捗インジケーターが追加されました。Tableau Prep Builder がデータを処理するにつれて、ステータスも更新されます。Tableau Prep Builder の処理状況がさらにわかりやすくなったため、データがまだ処理中なのか問題が発生したのか、わからなくなることはもうありません。

前月のリリースで Prep Builder に追加された機能を確認できるようにするために、その情報を製品ヘルプへのリンクとともにサマリー形式で追加することにしました。

Tableau Prep Builder の前のバージョンで追加された機能

Tableau Prep Builder 2019.4.1 で追加された機能

クラウドにあるより多くのデータと接続

今回のリリースでは、以下のクラウドコネクタを追加しました。

  • Box
  • Dropbox
  • Google Drive
  • OneDrive

フローを Tableau Server または Tableau Online にパブリッシュすることを計画している場合は、これらのコネクタの資格情報を保存するために追加の構成が必要になることがあります。クラウドデータコネクタへの接続の詳細については、「 クラウド上のデータソースに接続に含まれています。

その他の強化機能

Tableau での使用状況データを共有

Tableau では、既存の機能を改善し、新しい機能を開発できるようにするために、Tableau 製品の使用状況の把握に役立つデータを収集しています。すべての使用状況データは、Tableau プライバシーポリシーに従って収集、処理されます。ただし、参加を希望されない場合はオプトアウトすることができます。

オプトアウトのオプションが変更されました。使用状況データの収集は既定により有効化されています。参加を希望されない場合は、インストーラー (MacOS の場合は [インストーラをカスタマイズ] ダイアログ) から、またはインストール後の場合は [ヘルプ] メニューから、[製品の使用状況データを送信しない] チェックボックスを選択してください。

詳細については、Tableau Desktop および Tableau Prep 導入ガイドの「利用状況レポートをオフにする」を参照してください。

MacOS で既定のデータベースドライバーが自動的にインストールされなくなった

Mac に Tableau Prep Builder をインストールすると、PostgreSQL データベースドライバーのみが自動的にインストールされます。データに接続するためにその他のドライバーが必要な場合は、ドライバーのダウンロードページからダウンロードしてください。

Tableau Prep Builder 2019.3.2 で追加された機能

パフォーマンスの向上

インタラクティブパフォーマンスの向上   

Prep Builder のワークフローでパフォーマンスの問題を経験したことがあるユーザーに良い知らせです。このリリースで次の改善が行われました。

  • アプリの起動 – アプリケーションの起動速度が 3.1 リリースより最大 15% 向上。
  • Excel ファイルおよびテキストファイルの読み込み – Excel ファイルおよびテキストファイルの読み込み速度が 3.1 リリースより最大 50% 向上。
  • ワイルドカードユニオン – ワイルドカードユニオンを使用しているお客様は、テキストファイルで最大 50%、Excel ファイルで最大 700% のパフォーマンス向上を体験できるはずです。
  • ノードの具体化 – フローでのキャッシュ化されたユニオンのステップに対する更新により、フローにあるユニオンのステップ数、およびフローをクリックした場所に応じて、最大 95% パフォーマンスが向上します。
Conductor の互換性

インタラクティブパフォーマンスの向上は Conductor と互換性があり、バッチ処理にはまったく影響しません。

フローの構築と管理

ステップの挿入での更新   

フローへのステップの挿入は複数の手順があるプロセスでしたが、今回の更新で複数の手順を行うことなくすべてのステップ (入力と出力を除く) を挿入できるようになります。この機能はステップのコピーと貼り付け、およびフローでの再利用可能なコンポーネントで使用可能です。任意のフローを開き、分岐に移動します。分岐にカーソルを合わせると、新しい+メニューがあることに気が付くと思います。アイコンをクリックして、挿入したいステップを選択します。

詳しくは、「 ステップの追加または挿入」を参照してください。

Conductor の互換性

この機能は Conductor と完全な互換性があります。これはフローがどのように実行されるかに影響しません。

再利用可能なステップ

多くのユーザーがデータ準備に同じクリーニングの操作を適用しています。また彼らは、同じフローの異なったデータで、また複数フローで作業を再利用できるようにしたいと考えています。新機能によりユーザーは、簡単にフローからステップを再利用し、時間を節約し、可能なときはいつでも他のユーザーによる作業を活用することができます。ユーザーは接続されたステップのグループを選択し、それらをファイルに保存して他のフローで再利用するか Tableau Server にそれらをパブリッシュして、後で再利用または他のユーザーが活用できるようにします。

詳しくは、「 再利用可能なフローステップの作成 (バージョン 2019.3.2 以降)」を参照してください。

Conductor の互換性

フローのスニペットとは単に、Tableau Server にパブリッシュできる .tfl ファイルです。入力および出力のステップがあれば、スケジュールできます。

データの検証とフィルタリング

あいまい一致とカスタムのデータの役割   

Prep Builder 2019.2.2 でユーザーは、ビルトインのデータの役割での無効な値を、あいまい一致の最も近い値に変更することで修正できました。そして、Prep Builder 2019.3.1 ではカスタムのデータの役割を作成する機能が追加されました。このリリースでユーザーは、最も近い有効な値を探してそれに変更することで、自動的に無効な値を修正できるようになります。これでユーザーはカスタムのデータの役割を活用して、無効な値を自動的に修正できるようになりました。

任意のデータセットおよびカテゴリーのフィールドを選択して、カスタムの データの役割としてパブリッシュします。そしてそのデータの役割を、値が不正確なデータに割り当てます。レコメンド機能がデータの役割のための最も近い値を無効な値と変換する候補として提供し (発音とスペルのアルゴリズムを使用します)、簡単に適用してデータ品質の問題を解決できます。

あいまい一致については、「 類似の値をデータの役割でグループ化する」を参照してください。

Conductor の互換性

バッチ処理モードではあいまいグループ化機能は実行されません。フローが作成されユーザーがグループ化アルゴリズムを選択したときは、グループ化は 変更リスト に保存され、それがバッチモードで実行されるので、この機能の Conductor との互換性が保たれます。

ナビゲーションと表示

フローのナビゲーション   

大きなフローを Prep Builder で構築している場合、これらのフローを移動するのがよく困難になります。この フローのナビゲーション により、フローの最小化されたバージョンを見て、移動に使用することができます。またこのツールから、フローを拡大および縮小することができます。

  • 大きなフローを開きます。
  • ミニマップが右下に表示されます。
  • ピッカーを使用してフローを移動します。
  • 次のようにミニマップの残りのボタンを使用します。
  1. ミニマップを最小化できる下矢印。
  2. 画面にすべてのフローが収まるようサイズを調整する四角ボタン。
  3. フローの拡大と縮小ができる [+]/[-] ボタン。
  4. 自動的にフローを 100% に戻す % ボタン。

詳しくは、「 フローナビゲータツールの使用」を参照してください。

Conductor の互換性

完全な互換性があります。

 リストビュー  

すべてのフィールドを簡単に参照して、名前の変更やフィールドの削除などを素早く実行できるので、入力ステップのビューはお客様から人気があり、すべてのステップで同様の操作が望まれていました。多くの場合一度に 4、5 個のフィールドしか見ることができず、残りを表示するのにスクロールしなければならないため、お客様はストレスを感じることがありました。新しいリストビューにより、特にメタデータに焦点を当てたデータの違ったビューが使用できます。このビューから、ユーザーは簡単にステップの削除と名前変更ができ、データ型の変更や計算の追加ができます。

  • 任意のフローを開きます。
  • 任意のステップに移動します。
  • プロファイルペインの上のツールバーより、リストビューアイコンを選択します。
  1. 任意のフィールドにカーソルを合わせて、[X] ボタンをクリックしてフィールドを削除します。
  2. [...] メニューで、プロファイルペインで使用可能なクリーニングオプションを参照します。値に影響を与えるすべての操作 (たとえばフィルター) を行うと、自動的にプロファイルペインに移動します。アクションはメタデータにのみ影響します (たとえばフィールド名の変更)。

詳しくは、「 ビューの選択」を参照してください。

Conductor の互換性

出力の実行方法に影響がないため完全な互換性があります。

コマンドラインインターフェイス (CLI) の改善

MacOS キーチェーン認証資格情報が、それぞれのフロー実行で不要になる   

多くのお客様が、コマンドラインインターフェイスを使用して、マシン上で Tableau Prep フローの実行を自動化しています。この分野での最新の機能改善により、ユーザーは MacOS キーチェーン認証資格情報をフローの実行ごとに手動で入力する必要がなくなります。Tableau Prep Builder にインストールされている、コマンドラインインターフェイスを使用してフローを実行するだけです。

Conductor の互換性

該当なし

互換性

Tableau Prep Builder は、Tableau Desktop、Tableau Server、Tableau Online とシームレスに連携するスタンドアローン製品です。Tableau Prep Builder で作業中のどの時点でも、データの抽出ファイルの作成や、Tableau Server または Tableau Online へのデータソースのパブリッシュができるほか、Tableau Prep Builder から直接 Tableau Desktop を開いてデータをプレビューすることができます。

  • Tableau Prep Builder は Windows および Mac 上で動作します。10.0 以降のバージョンの Tableau で使用可能な Tableau データ抽出ファイル (.tde および .hyper) や CSV ファイルを作成することができます。
  • Tableau Prep Builder では、Tableau Desktop、Server および Online で利用できるデータソースの多くに接続できます。Tableau でサポートされる全データソースのリストについては、こちらをクリックしてください。
  • データソースによっては、データに接続する前にドライバーのインストールが必要になることがあります。この場合には、ドライバーのダウンロードページをご覧ください。

より短時間でインサイトを得るための新しいワークスペース

Tableau Prep Builder は、Tableau のデータコネクタや計算言語、ガバナンス構造を使っているので短期間で使いこなせるようになり、分析プロセスのどの時点でもすぐにコラボレーションを行うことができます。

Tableau Prep Builder のワークスペースは、接続ペイン、変更内容ペイン、および連携する 3 つの領域で構成されており、データ操作と分析がしやすいようデザインされています。

  1. 接続ペイン: 接続ペインは、接続先のデータベースとファイルを表示します。1 つ以上のデータベースへの接続を追加して、分析対象の表をフローペインにドラッグします。 
  2. フローペイン: データ接続、クリーニング、分析に適した形式への変換、結合と進むにつれて、各ステップがフローペインに表示されます。各ステップの上部にあるアイコンにカーソルを合わせると、変更内容が表示されます。 
  3. プロファイルペイン: ワークスペースの中央にあるプロファイルペインは、データサンプルに含まれる各フィールドのサマリーを表示します。ここで、ユーザーはデータの形状を確認し、外れ値や NULL をすばやく見つけることができます。
  4. 変更内容ペイン: Tableau Prep Builder は、変更が行われた順序で変更内容を記録するので、必要に応じていつでも変更内容の確認や編集をすることができます。
  5. データグリッド: データグリッドは、データの行レベルの詳細を表示します。表示された値には、プロファイルペインで定義された処理が反映されています。このグリッドで、個々のフィールド値のフィルタリング、保持、および除外を実行することができ、さらに、フィールドをドラッグ & ドロップして表示順序を変更することができます。

製品のヘルプにあるワークスペースで、ビデオなどによる詳細な説明をご確認いただけます。

出力結果の保存と共有

出力内容の定義

Tableau Prep Builder では、次の 3 つのタイプのファイルを保存できます。

  1. フローが含まれる .tfl ファイル
  2. フローおよびローカルのファイルベースのデータソース (Excel やテキストファイルなど) が含まれる .tflx ファイル
  3. フローの実行結果が含まれる出力ファイル

出力ファイルは、.hyper、.tde、および .csv 形式で保存することができ、出力ステップで定義されます。出力ファイルは、Tableau Desktop で開き、Tableau Server または Tableau Online へパブリッシュできます。

Tableau Desktop

Tableau Desktop でフローを実行すると、Tableau のバージョンに応じて .tde または .hyper のどちらかの Tableau データ抽出ファイルが生成されます。どちらも [データソース] フォルダーにある Tableau リポジトリに保存されます。また、準備したデータを他のツールやプロセスで使用する必要がある場合には、.csv ファイルに出力することもできます。

注: 抽出ファイル (.tde または .hyper のどちらでも) と、それに基づくワークブックを作成後、異なるバージョンの Tableau で使用する場合には、他の使用状況で適用されるのと同じ互換性のルールが適用されます。詳細については、「バージョン間でワークブックの互換性があるようにする」を参照してください。

Tableau Server

出力結果を Tableau Server にパブリッシュするには、Tableau Prep Builder で [パブリッシュ] メニューを使用します。Tableau Prep Builder からパブリッシュのリクエストを受信するには、Tableau Server REST API を有効にする必要があります。詳しくは、「REST API 要件」をご覧ください。

Tableau Online

また、Tableau Prep Builder の [パブリッシュ] メニューを使用して、出力結果を .hyper 抽出ファイル、.tde 抽出ファイル、または .csv ファイルとして Tableau Online にパブリッシュして、クリーニング、書式設定および結合済みのデータへの一元的なアクセスを提供することもできます。

より頻繁な Tableau Prep Builder のアップデート

Tableau はハイペースで開発を続けており、Tableau Desktop や Tableau Server、Tableau Online のリリースサイクルとは別に、Tableau Prep Builder の新機能を頻繁にリリースしていく予定です。今後、新機能や製品の修正を入手するには、最新バージョンの Tableau Prep Builder にアップグレードしてください。

このサイトでは、定期的に新しいリンクを掲載し、コミュニティのユーザーシナリオや製品情報、特に、最新の方法で高速かつ効率的に楽しくデータ準備を行う秘訣を紹介します。

その他のリソース

どうすれば Tableau Prep Builder を入手できますか?

Tableau Prep Builder は、サブスクリプション形式の製品で Tableau Creator ライセンスプログラムに含まれています。Tableau Desktop を既にご利用で、メンテナンス契約をお持ちのユーザーは、メンテナンス契約の一環として、Tableau Prep Builder をダウンロードし、使用することができます。Tableau Prep Builder をまだダウンロードしていない場合は、こちらのページにアクセスするか、このアップグレードページの上部にあるダウンロードボタンをクリックするとダウンロードできます。これらの方法では常に、Prep Builder の最新バージョンがダウンロードされます。

ライセンスの状態が不明な場合は、まず「Tableau Desktop および Tableau Prep Builder でのライセンスの維持」をお読みください。

まずは Tableau Prep Builder を無料でお試しください

Tableau Prep Builder の 14 日間無料トライアル版は、こちらからダウンロードできます。
技術仕様を確認する

Tableau Prep Builder の技術要件は、こちらで確認することができます。
Tableau Prep Builder リリースノート

サポートを受ける

セルフサービス型リソース

テクニカルサポート
Tableau はお客様を最大限にサポートできるように努めています。 サポートにお問い合わせの際は、以下の情報をご提供ください。
  • 問題とすべてのエラーメッセージ (展開したもの) のスクリーンショット
  • お電話を差し上げるご希望の時間

コンサルティングサービス

Tableau のコンサルタントが新しい Tableau Prep Builder の機能を最大限に活用し、データの価値を引き出す方法をご紹介します。