Mise à niveau vers Tableau Prep Builder 2021.1.1

À savoir lorsque vous effectuez une mise à niveau vers Tableau Prep Builder 2021.1.1

Présentation

Présentation de Tableau Prep Builder

Tableau Prep Builder est conçu pour vous aider à combiner, remanier et nettoyer vos données rapidement et sereinement avant de passer à l'analyse.

Où trouver Tableau Prep Builder ?

Tableau Prep Builder est inclus avec Tableau Desktop dans
Tableau Creator .

 

Premiers pas avec Tableau Prep Builder :

Nouveautés de Tableau Prep Builder 2021.1.1

Commencez par lire cet article de Rapinder Jawanda, directrice Gestion des produits, Tableau 
Tableau Prep Builder est maintenant disponible dans le navigateur

Cet article de blog a été créé pour Tableau Prep  Builder 2020.4.1, mais il s'applique également à la version 2021.1.1.

Nouveautés de Tableau Prep Builder 2021.1.1

Cette version n'inclut pas de nouvelles fonctionnalités, mais offre des mises à jour de sécurité importantes. 

Notez également qu'une u nouvelle possibilité de recherche dans l'application a été mise en œuvre. Maintenant, lorsque vous cherchez des champs dans Tableau Prep, les résultats incluent une nouvelle information, le nombre de champs trouvés, qui vous permet de mieux les comprendre. Si aucun champ n'est trouvé, vous en êtes également informé.

 

Remarque : depuis la version 2019.1.2, Tableau Prep change de nom et devient Tableau Prep Builder. Cela permet de le distinguer de Tableau Prep Conductor, qui fonctionne sur Tableau Server sous forme de module complémentaire. Maintenant, avec Tableau Prep Conductor, vous pouvez enregistrer le travail réalisé dans Tableau Prep Builder (inclus avec Tableau Desktop) pour l'exécuter dans un environnement serveur centralisé, évolutif et fiable. Ainsi, vos données sont toujours à jour et faciles à partager.


Nouvelles fonctionnalités ajoutées dans Tableau Prep Builder 2020.4.1

 

Installation et déploiement de Tableau Prep Builder

 

Remarque : les critères ont changé pour la CPU

À compter de la version 2020.4, Tableau nécessite une CPU qui prend en charge les jeux d'instructions SSE4.2 et POPCNT. Ce type de CPU est très répandu sur le marché depuis plus de 10 ans et installé sur la plupart des ordinateurs récents. Notez par ailleurs que les produits Tableau ne sont pas compatibles avec les processeurs Apple M1 (Silicon) à l'heure actuelle. 
 
Si vous tentez d'installer ou de mettre à niveau Tableau sur un ordinateur qui ne prend pas en charge ces jeux d'instructions ou qui utilise un processeur Apple M1, le programme d'installation ne pourra pas effectuer l'opération. 
 
Vous trouverez la liste complète des technologies prises en charge sur la page  tableau.com/fr-fr/techspecs
 

Tableau Prep sur le Web 

 

Tableau Prep Builder dans le navigateur

À partir de Tableau 2020.4.1, vous pouvez créer des flux pour nettoyer et préparer vos données en utilisant Tableau Prep Builder, Tableau Server ou Tableau Online. Tableau Data Management Add-on n'est pas requis, à moins que vous ne souhaitiez programmer vos flux à l'aide de Tableau Prep Conductor. 
 
Vous pouvez vous connecter à vos données, créer des flux ou modifier des flux existants. Votre travail sera enregistré très régulièrement.  Créez des ébauches de flux uniquement disponibles pour vous-même, ou publiez votre flux pour le mettre à disposition de vos collègues. Exécutez vos flux individuels manuellement directement sur le Web, ou programmez leur exécution automatique à l'aide de Tableau Prep Conductor. 
 
Si la plupart des fonctionnalités de Tableau Prep Builder sont disponibles lors de la création et de la modification des flux sur le Web, il se peut que certaines fonctionnalités et certains connecteurs ne le soient pas. Pour en savoir plus, lisez la rubrique d'aide  Tableau Prep sur le Web.
 

Connexion aux données

 

Prise en charge pour les plug-ins de connecteurs

Lorsque Tableau Prep ne fournit pas de connecteur intégré pour vos données, vous pouvez désormais vous connecter à des données ODBC et JDBC à l'aide de plug-ins de connecteurs créés avec le SDK pour les connecteurs Tableau, comme pour Tableau Desktop. Ces plug-ins sont pris en charge lorsque vous vous connectez à des données dans Tableau Prep Builder et sur le Web dans Tableau Server. Pour les utiliser, téléchargez le fichier .taco du connecteur souhaité, puis ajoutez-le dans les dossiers suivants :
 
Tableau Prep Builder :
  • Windows : C:\Users\[Nom de l'utilisateur]\Documents\Mon référentiel Tableau Prep\Connectors
  • macOS : /Users/[utilisateur]/Documents/My Tableau Prep Repository/Connectors

Tableau Server (création de flux sur le Web) :

  • [Répertoire_d'installation_de_Tableau_Server]/data/tabsvc/flowqueryservice/Connectors
Tableau Server (Tableau Prep Conductor) :
  • [Répertoire_d'installation_de_Tableau_Server]/data/tabsvc/flowprocessor/Connectors
Pour plus d'informations sur les plug-ins de connecteurs, consultez la rubrique d'aide Utiliser des plug-ins de connecteurs pour se connecter à des données ODBC et JDBC (version 2020.4.1 et plus récentes).
 
 

Connexion à des données spatiales 

Vous pouvez désormais vous connecter à des fichiers de données spatiales, les nettoyer et les remanier dans Tableau Prep Builder et lors de la création de flux sur le Web. Avec cette fonctionnalité vous pouvez : 
  • Vous connecter à des formats de fichiers de données spatiales :
    1. Tableau Prep Builder : fichiers de formes Esri, bases de données géospatiales Esri, KML, TopoJSON, GeoJSON, extraits, MapInfo MID/MIF, fichiers TAB et fichiers de formes zippés.  
    2. Tableau Server et Tableau Online : fichiers de formes zippés, KML, TopoJSON, GeoJSON, bases de données géospatiales Esri et extraits.
  • Vous connecter à des bases de données spatiales (Amazon Redshift, Microsoft SQL Server, Oracle et PostgreSQL).  
  • Combiner des tables spatiales et non spatiales à l'aide de jointures standard.  
  • Exporter des données spatiales dans un fichier d'extrait (.hyper).  

Les fonctions spatiales, les jointures spatiales par intersection et la visualisation de données spatiales sur une carte dans Tableau Prep ne sont actuellement pas prises en charge.

Pour en savoir plus sur la connexion aux données spatiales, consultez la rubrique d'aide  Se connecter à des fichiers et bases de données spatiales (version 2020.4.1 et plus récentes)

Fonctionnalités ajoutées dans les versions précédentes de Tableau Prep Builder

Vous souhaitez savoir quelles fonctionnalités ont été ajoutées à Tableau Prep Builder dans les versions précédentes ? Vous trouverez ci-dessous une synthèse des nouveautés ainsi que des liens vers l'aide de Tableau.
 

 

Nouveautés de Tableau Prep Builder 2020.3.3

Installation et déploiement de Tableau Prep Builder

Récupérez automatiquement votre flux après un plantage

Comme dans Tableau Desktop, Tableau Prep Builder enregistre automatiquement votre flux en cas de plantage. La prochaine fois que vous lancez l'application, une boîte de dialogue s'affiche, avec une liste des flux récupérés. Vous pouvez choisir d'ouvrir un flux récupéré et reprendre votre travail, ou supprimer les flux récupérés si vous n'en avez pas besoin. Les flux récupérés sont enregistrés dans le dossier Flux récupérés dans Mon référentiel Tableau Prep. Cette boîte de dialogue s'affiche chaque fois que vous ouvrez Tableau Prep Builder, si votre dossier Flux récupérés contient des flux enregistrés.

Cette fonctionnalité est activée par défaut, mais peut être désactivée par un administrateur pendant l'installation ou après. Pour en savoir plus, lisez la rubrique d'aide Enregistrer un flux.

Création et organisation de votre flux

Intégration plus rapide des nouveaux utilisateurs

Désormais, lorsque vous vous connectez à une source de données et la déplacez dans votre espace de travail, Tableau Prep Builder indique où ajouter les prochaines étapes de nettoyage, en ajoutant une suggestion d'étape de nettoyage en regard de l'étape d'entrée. Cliquez sur l'étape suggérée pour l'ajouter d'un seul clic, afficher les détails sur vos données et commencer à les examiner et à les nettoyer immédiatement.

Pour en savoir plus, lisez la rubrique d'aide Créer et organiser votre flux.

Regroupement d'étapes

Utilisez la nouvelle option Regrouper lorsque vous organisez votre flux pour sélectionner plusieurs étapes liées et les regrouper dans un dossier. Avec cette nouvelle fonctionnalité, vous pourrez plus facilement explorer, gérer et partager les flux complexes et volumineux. Au lieu de devoir comprendre le flux entier, les différents utilisateurs pourront se focaliser uniquement sur les groupes d'étapes qui les concernent.

Vous pouvez changer la couleur d'un groupe, ajouter une description, copier des groupes d'étapes et les coller ailleurs dans votre flux, ou enregistrer un groupe dans un fichier ou sur le serveur, pour le réutiliser dans d'autres flux. Il suffit de sélectionner l'ensemble d'étapes à regrouper, puis de cliquer sur Regrouper dans le menu.

Les étapes sélectionnées sont regroupées dans un dossier, dont vous pouvez choisir le nom. Vous pouvez rajouter des étapes à ce groupe ou en supprimer à tout moment. Seules les étapes directement connectées les unes aux autres peuvent être incluses dans un même groupe. Cliquez sur la flèche double pour développer ou réduire le groupe à tout moment.

Pour en savoir plus, lisez la rubrique d'aide Créer et organiser votre flux.

Nettoyage et remaniement des données

Utilisez une année fiscale personnalisée lorsque vous convertissez des champs de dates

Si votre année fiscale ne commence pas en janvier, vous pouvez désormais définir un mois personnalisé, que Tableau Prep Builder utilisera comme mois de début lors de la conversion des valeurs de champ Date ou Date et heure en une date partielle différente. Sélectionnez simplement Année fiscale personnalisée dans le menu Options supplémentaires du champ et définissez simplement le mois de début de votre année fiscale et la date partielle vers laquelle vous souhaitez convertir les valeurs des champs.

Pour en savoir plus, lisez la rubrique d'aide Appliquer des opérations de nettoyage.

Configurez Rserve et TabPy globalement à partir du menu supérieur.

Dans les versions précédentes, lorsque vous souhaitiez inclure une étape de script dans votre flux, vous deviez configurer des connexions à R et TabPy dans chaque étape de script, pour chaque flux qui les contient. Désormais, vous pouvez définir vos connexions à ces extensions Analytics une seule fois, à partir du menu Aide, comme dans Tableau Desktop. Cette configuration s'applique ensuite à chaque flux que vous gérez.

Sélectionnez simplement Aide > Paramètres et Performances > Gérer la connexion à l'extension Analytics, puis sélectionnez Rserve ou Tableau Python (TabPy) dans la liste déroulante et indiquez les informations de connexion. Si vous utilisez les deux extensions Analytics, vous pouvez renseigner les informations de connexion à chaque serveur en utilisant une seule et même boîte de dialogue.

Remarque : vous devez reconfigurer les connexions au serveur en utilisant cette boîte de dialogue pour les flux créés avec des versions antérieures et contenant des étapes de script.

Pour en savoir plus sur l'utilisation de Rserve et Tableau Python (TabPy) dans vos flux, consultez la rubrique d'aide Utiliser des scripts R et Python dans votre flux.

Enregistrement et partage de votre travail

Stockez et réutilisez la configuration d'actualisation incrémentielle.

Désormais, lorsque vous configurez des étapes d'entrée et de sortie avec actualisation incrémentielle et que vous copiez-collez ces étapes ou les enregistrez pour les réutiliser, les informations sur la configuration d'actualisation incrémentielle sont conservées, pour que vous puissiez la réutiliser sans devoir la recréer entièrement.

Pour en savoir plus sur la mise en place et l'utilisation de l'actualisation incrémentielle, consultez la page Actualiser les données de flux à l'aide d'une actualisation incrémentielle.

 

 

Nouveautés de Tableau Prep Builder 2020.3.2

Cette version n'inclut pas de nouvelles fonctionnalités, mais offre des mises à jour de sécurité importantes. 
 
 
 

Nouveautés de Tableau Prep Builder 2020.3.1

Enregistrement et partage de votre travail

Enregistrement de données de sortie de flux vers des bases de données externes

Vous pouvez désormais envoyer tout ou partie de vos résultats de flux vers des bases de données compatibles et créer, remplacer ou ajouter des données de table à l'aide de données de flux nettoyées et préparées. Tableau Prep Builder permet l'enregistrement de données de flux vers les bases de données suivantes :

  • Amazon Redshift
  • Microsoft SQL Server
  • MySQL
  • Oracle
  • PostgreSQL
  • Snowflake
  • Teradata

Dans votre étape de sortie, dans le menu déroulant Enregistrer la sortie, choisissez Table de base de données. Ensuite, sélectionnez la base de données et la table dans lesquelles vous souhaitez enregistrer votre sortie de flux. Vous pouvez également saisir un nom de table pour créer une nouvelle table dans la base de données. Le comparatif des champs vous montre quels champs de votre flux et de votre table ont le même état. Le champ d'état vous donne plus de détails sur les champs discordants. Vous pouvez également ajouter des scripts SQL exécutables avant ou après que les données ont été chargées dans la table de base de données. Vous pouvez utiliser ces scripts pour créer une copie de vos données de table avant d'exécuter le flux, ajouter un index, ajouter des contraintes de base de données à la table de base de données, etc.

Pour en savoir plus sur l'enregistrement de sorties de flux dans des tables, consultez l'article   Enregistrer les données de sortie de flux dans des bases de données externes (version 2020.3.1 et versions ultérieures).

Arrêt des fichiers d'extraits de données Tableau

Les fichiers d'extraits de données Tableau (.tde) ne sont plus pris en charge

À partir de la version 2020.3.1, les fichiers d'extraits de données Tableau (.tde) ne sont plus pris en charge pour les sorties de flux. Tous les flux publiés sur un serveur version 2020.3 ou ultérieure qui génèrent un fichier d'extraits de données Tableau (.tde) doivent être modifiés pour générer un fichier d'extraits Hyper (.hyper), sans quoi ces flux ne parviendront pas à s'exécuter. Les fichiers d'extraits de données Tableau (.tde) peuvent toujours servir à l'intégration au flux. Pour en savoir plus sur la création et la publication d'extraits de données, consultez la rubrique Créer et publier des extraits de données et des sources de données.

Exécution des flux par ligne de commande grâce à .json

La création d'un fichier d'identification .json a été simplifiée

Si vous exécutez vos flux par ligne de commande, et que vous vous connectez à un serveur ou une base de données ou y envoyez des données, vous pouvez désormais utiliser une syntaxe simplifiée lorsque vous créez votre fichier d'identification .json.

Pour en savoir plus, lisez la rubrique d'aide Actualiser les fichiers de sortie du flux depuis la ligne de commande

 

 

Nouveautés de Tableau Prep Builder 2020.2.3

Connexion aux données

Utilisez l'authentification OAuth pour vous connecter aux données avec Snowflake

À présent, lorsque vous vous connectez aux données en utilisant Snowflake, vous pouvez utiliser l'une des méthodes d'authentification suivantes, comme dans Tableau Desktop :

  1. Nom d'utilisateur et mot de passe
  2. Fournisseur d'identité SAML
  3. OAuth

Pour en savoir plus sur la connexion à vos sources de données avec ce connecteur, lisez la rubrique Snowflake dans l'aide de Tableau Desktop. 

 

 

Nouveautés de Tableau Prep Builder 2020.2.2

Connexion aux données

Connexion aux données avec Tableau Server ou Tableau Online

Dans les versions antérieures, vous pouviez uniquement vous connecter à des sources de données publiées stockées sur Tableau Server ou Tableau Online. À présent, si vous avez Data Management Add-on avec Tableau Catalog, vous pouvez également rechercher des bases de données et des tables stockées dans Tableau Server ou Tableau Online et vous y connecter. Il vous suffit de sélectionner Tableau Server dans la nouvelle section Recherche de données du volet Connexion et de vous connecter à votre serveur. Depuis la boîte de dialogue Recherche de données, vous pouvez rechercher des sources de données prêtes à l'emploi et les sélectionner. Des métadonnées supplémentaires, telles que la description de la source de données, les avertissements sur la qualité des données ou encore les certifications vous aident à identifier la source idéale sans même sortir de Tableau Prep Builder. Vous pouvez également utiliser l'option en haut à droite pour filtrer vos résultats selon le type de connexion, les avertissements sur la qualité des données et les certifications. Si vous n'avez pas Tableau Data Management Add-on avec Tableau Catalog activé, seules les sources de données publiées s'affichent. Vous ne voyez pas les métadonnées. Pour en savoir plus sur la connexion aux données, lisez Se connecter aux sources de données publiées (version 2019.3.1 et versions ultérieures). Connexion aux données Alibaba MaxCompute Si vos données sont stockées dans un entrepôt, vous pouvez désormais y accéder à l'aide d'Alibaba MaxCompute.

Pour en savoir plus sur la connexion à vos sources de données avec ce connecteur, lisez la rubrique Alibaba MaxCompute dans l'aide de Tableau Desktop. 

 

 

Nouveautés de Tableau Prep Builder 2020.2.1

Connexion aux données

Connectez-vous à vos données Salesforce.com

Tableau Prep Builder peut désormais se connecter à vos données Salesforce, pour vous permettre de les nettoyer et les préparer à des fins d'analyse dans Tableau. L'utilisation du SOQL personnalisé et la création d'une connexion standard ne sont pas encore prises en charge.

Pour en savoir plus, consultez la rubrique d'aide Se connecter aux données Salesforce (version 2020.2.1 et versions ultérieures).

Des données de flux toujours à jour

Travaillez uniquement avec les données les plus récentes grâce à l'actualisation incrémentielle

Si vos données évoluent en permanence, vous pouvez désormais gagner du temps et économiser des ressources grâce à l'actualisation incrémentielle, en renvoyant et traitant uniquement les lignes de données les plus récentes depuis la dernière exécution du flux. Il vous suffit de configurer les paramètres d'actualisation incrémentielle pour faire en sorte que Tableau Prep Builder détecte et renvoie les nouvelles lignes des données en entrée, et pour choisir la manière dont les tables seront mises à jour par les données en sortie lors de l'exécution du flux.
 
Vous pouvez désormais choisir d'ajouter des données récentes à des tables existantes, ou d'utiliser la fonctionnalité existante permettant de remplacer les données des tables par vos nouvelles données. Programmez l'exécution de vos flux avec Tableau Prep Conductor, ou exécutez les flux individuels de manière incrémentielle dans Tableau Prep Builder ou par le biais de l'interface en ligne de commande.
 
Remarque : Tableau Server 2020.2 ou version ultérieure est requis (avec l'utilisation de Tableau Prep Conductor) pour programmer des flux avec l'actualisation incrémentielle.
 
Pour en savoir plus sur la mise en place et l'exécution des flux avec l'actualisation incrémentielle, consultez la page d'aide Actualiser les données de flux à l’aide d'une actualisation incrémentielle
 
 
 

Nouveautés de Tableau Prep Builder 2020.1.5

L'équipe produit de Tableau Prep met tout en œuvre pour examiner et résoudre tous les problèmes signalés par les utilisateurs ou compromettant l'utilisation optimale du produit. Nous annonçons chaque mois dans les Notes de version les correctifs mis en place pour les défauts qui affectent nos clients.
 
 
 
 

Nouveautés de Tableau Prep Builder 2020.1.4

Connexion aux données

Connexion aux données avec Cloudera Impala

Comme dans Tableau Desktop, vous pouvez désormais vous connecter facilement à vos plus grands ensembles de données à l'aide de Cloudera Impala. Pour en savoir plus sur la connexion à vos sources de données avec Cloudera Impala, reportez-vous à la rubrique Cloudera Hadoop dans l'aide de Tableau Desktop.

Nettoyage et remaniement des données

Conversion des valeurs de date en un seul clic

Pour faciliter le nettoyage de vos données, nous avons ajouté une nouvelle option de menu permettant un nettoyage rapide des dates dans Tableau Prep Builder. Si vous devez convertir vos valeurs de date pour afficher une donnée de type DATEPART comme l'année, le mois ou le jour, vous pouvez sélectionner l'une des options suivantes dans le nouveau menu Convertir les dates au lieu d'écrire un calcul de champ complexe.

Pour en savoir plus sur l'application d'opérations de nettoyage à vos dates, consultez la rubrique d'aide Appliquer des opérations de nettoyage.

Enregistrement et partage de votre travail

Maintien de la connexion au serveur

Il n'est plus nécessaire de vous connecter à Tableau Server ou à Tableau Online à chaque fois que vous lancez Tableau Prep Builder. Désormais, Tableau Prep Builder garde le nom de votre serveur et vos informations de connexion en mémoire lorsque vous quittez l'application, afin de vous connecter automatiquement à votre serveur lors de votre prochaine session.

Cette option vous permet de gagner du temps et de vous connecter facilement pour publier des sources de données ou insérer des étapes de flux enregistrées. Vous avez besoin de savoir si telle ou telle fonctionnalité est compatible avec votre version de serveur ? Des avertissements de compatibilité apparaissent instantanément sans que vous ayez à vous connecter à votre serveur.

Pour en savoir plus, lisez la rubrique d'aide Créer et publier des extraits de données et des sources de données

 

 

Nouveautés de Tableau Prep Builder 2020.1.3

Installation et déploiement de Tableau Prep Builder

Prise en charge de la gestion des licences basée sur la connexion

La gestion des licences basée sur la connexion vous permet de gérer les licences d'utilisateurs disposant d'un rôle Creator sur Tableau Server et Tableau Online. Les utilisateurs avec un rôle Explorer ou Viewer ne peuvent pas se servir de cette fonctionnalité. Si vous utilisez un système de souscriptions basées sur les rôles avec Tableau Server ou Tableau Online, vous pouvez opter pour la gestion des licences basée sur la connexion afin de vous simplifier la tâche. Vous n'aurez alors plus besoin de disposer de clés produit distinctes pour Tableau Desktop et Tableau Prep Builder. Vous devrez uniquement gérer une ou plusieurs clés produit pour Tableau Server sur site, ou aucune dans le cas de Tableau Online.

Pour en savoir plus, lisez la rubrique d'aide Gestion des licences basée sur la connexion.

Connexion aux données

Transmission de paramètres à votre source de données à l'aide de commandes SQL initiales

Vous pouvez désormais transmettre des paramètres à votre source de données à l'aide de commandes SQL initiales, afin de fournir plus de détails sur la version, le nom de flux et le type de votre application Tableau Prep. Tableau Prep Builder prend en charge les paramètres suivants : • TableauApp : renvoie l'application utilisée pour accéder à votre source de données (Tableau Prep Builder ou Tableau Prep Conductor). • TableauVersion : renvoie le numéro de version de l'application. Dans le cas de Tableau Prep Builder, le numéro de version exact est renvoyé (par exemple 2020.1.1). Dans le cas de Tableau Prep Conductor, il s'agit de la version principale du serveur sur lequel Tableau Prep Conductor est activé (par exemple 2020.1). • FlowName : renvoie le nom du fichier « .tfl ».

Pour en savoir plus sur l'utilisation des paramètres lorsque vous vous connectez à votre source de données à l'aide de commandes SQL initiales, consultez la rubrique Inclure des paramètres dans votre déclaration SQL initiale (version 2020.1.3 ou ultérieure)

Nettoyage et remaniement des données

Calculs avec les fonctions LOD, Classement et Numéro de ligne pour le nettoyage de vos données

Si le niveau d'agrégation de vos données ne convient pas à votre analyse, ou si vous devez effectuer des calculs sur un ensemble de lignes, vous pouvez désormais utiliser les calculs de fonction analytique de type FIXED LOD (Niveau de détail fixe), RANK (Classement) et ROW_NUMBER (Numéro de ligne) pour créer les données dont vous avez besoin dans votre ensemble. Vous pouvez par exemple ajouter un calcul FIXED LOD pour modifier la granularité des champs de votre table. Vous pouvez utiliser la nouvelle fonction analytique ROW_NUMBER () pour trouver rapidement des lignes en double. Ou encore vous servir de l'une des nouvelles fonctions RANK () pour trouver les valeurs N premiers et N derniers d'une série de lignes contenant des données similaires. Vous pouvez aussi utiliser le nouvel éditeur de calcul visuel pour obtenir davantage de conseils au moment de créer ces types d'expressions.

Pour en savoir plus sur l'utilisation de ces champs calculés pour nettoyer vos données, consultez la rubrique d'aide Créer des calculs de niveau de détail et de classement

 

 

Nouveautés de Tableau Prep Builder 2020.1.2

Nouveautés de Tableau Prep Builder 2020.1.2 :
 
Mises à jour des bibliothèques tierces : OpenSSL, postgresql et postgres jdbc. 
 
 
 

Nouveautés de Tableau Prep Builder 2020.1.1

Connexion aux données

Identifiez facilement l'origine des entrées de flux

Si vos flux comportent plusieurs entrées, vous risquez d'avoir du mal à retrouver les différentes tables ou sources de données que vous avez utilisées pour chaque entrée si vous devez actualiser ou remplacer une connexion. Pour vous aider, nous avons ajouté une nouvelle fonctionnalité qui met en surbrillance le connecteur et la table pour l'entrée sélectionnée dans le volet Connexions. Sélectionnez simplement une ou plusieurs étapes d'entrée dans le volet Flux pour voir clairement le connecteur et les tables associés dans le volet Connexions.

Pour en savoir plus sur la connexion à des données pour créer un flux, reportez-vous à la rubrique d'aide Se connecter aux données.

Nettoyage et remaniement des données

Suspendez les mises à jour de données pour booster les performances

Chaque fois que vous appliquez des opérations de nettoyage à vos données, Tableau Prep Builder actualise la vue pour vous permettre de voir instantanément les résultats de vos modifications. Lorsque vous créez des flux, cette réactivité vous permet de savoir rapidement quelles étapes suivre ensuite, mais l'application de ces changements peut prendre du temps.

Pour booster les performances et accélérer les modifications, vous pouvez désormais suspendre ces actualisations constantes pour appliquer plusieurs modifications en même temps. Cliquez simplement sur le bouton Suspendre les mises à jour de données dans le menu du haut. Tableau Prep Builder suspend alors les mises à jour et bascule en mode Liste, ce qui vous permet d'appliquer rapidement vos modifications. La vue n'est plus actualisée à chaque changement et seules les métadonnées des champs sont affichées. Lorsque vous avez fini et que vous souhaitez voir les résultats sur les valeurs des champs, cliquez sur Reprendre les mises à jour de données pour revenir au mode d'actualisation standard.

Pour en savoir plus, reportez-vous à la rubrique d'aide Suspendre les mises à jour des données pour améliorer les performances.

Des données de flux toujours à jour

Ajoutez ou intégrez des informations d'identification pour les connecteurs cloud lorsque vous publiez vos flux

Dans les versions antérieures, si vous souhaitiez publier et programmer un flux incluant des connecteurs cloud, vous deviez définir au préalable ces informations d'identification dans Tableau Server ou Tableau Online. Sinon, Tableau Prep Conductor ne pouvait pas les détecter et le flux ne pouvait pas s'exécuter. Vous pouvez désormais ajouter et intégrer les informations d'identification de vos connecteurs cloud en quelques étapes simples, directement dans la boîte de dialogue Publier de Tableau Prep Builder. Connectez-vous simplement à votre serveur et choisissez Serveur > Publier le flux. Dans la boîte de dialogue Publier le flux, un message s'affiche pour vous avertir que des connexions à des entrées nécessitent une authentification. Cliquez sur le lien Modifier les connexions dans ce message ou sur le lien Modifier dans la section Connexions, puis sélectionnez Ajouter des informations d'identification dans la liste déroulante Authentification. Un nouveau message confirme votre sélection. Cliquez sur Continuer pour accéder aux Paramètres du compte dans Tableau Server ou Tableau Online, puis ajoutez vos informations d'identification. Lorsque vous avez terminé, revenez dans Tableau Prep Builder et cliquez sur Terminé. Vos informations d'identification sont automatiquement intégrées à votre flux.

Pour en savoir plus sur l'ajout d'informations d'identification pour les connecteurs cloud lors de la publication, consultez l'article d'aide Publier un flux.

Compatibilité de version avec Tableau Prep

Détectez et activez les fonctionnalités incompatibles

Dans Tableau Prep Builder 2019.3.1, nous avons ajouté des icônes d'alerte et des infobulles pour vous permettre d'identifier plus facilement les fonctionnalités incompatibles avec votre version de Tableau Server pendant la création de votre flux. Ainsi, vous pouviez décider en toute connaissance de cause quelles fonctionnalités inclure dans le flux si vous souhaitiez le publier et l'exécuter régulièrement. Cette version va plus loin encore.

Désormais, une fois que vous êtes connecté à votre serveur, Tableau Prep Builder peut détecter les fonctionnalités qui ne sont pas compatibles avec votre version de Tableau Server et il les désactive. De cette façon, vous n'avez plus à vous demander quelles fonctionnalités vous pouvez inclure dans votre flux si vous prévoyez de le publier et de l'exécuter régulièrement. Si vous souhaitez tout de même utiliser une fonctionnalité incompatible et exécuter vos flux manuellement à l'aide de Tableau Prep Builder ou à partir de la ligne de commande, vous pouvez l'activer directement dans le menu. Cliquez simplement sur le bouton Utiliser la fonctionnalité pour activer cette fonctionnalité ainsi que toutes les autres qui sont incompatibles. Les avertissements mis en place dans Tableau Prep Builder version 2019.3.1 permettent toujours d'identifier les fonctionnalités incompatibles avec votre serveur. Ainsi, vous les repérez facilement et pouvez les supprimer si vous souhaitez planifier l'exécution d'un flux dans Tableau Server.

Pour en savoir plus sur l'utilisation de fonctionnalités incompatibles, consultez l'article d'aide Compatibilité de version avec Tableau Prep

 

 

Nouveautés de Tableau Prep Builder 2019.4.2

Connexion aux données

Connexion à davantage de données grâce aux nouveaux connecteurs

Cette nouvelle version inclut les nouveaux connecteurs de données suivants :

  • Alibaba AnalyticDB for MySQL
  • Alibaba Data Lake Analytics
  • Databricks
  • Kyvos
  • Qubole Presto

Pour en savoir plus sur la manière de vous connecter à vos données à l'aide de ces connecteurs, consultez l'article Connecteurs pris en charge dans l'aide de Tableau Desktop et de la création Web. Pour obtenir des informations générales sur la connexion aux données pour créer un flux, consultez l'article d'aide Se connecter aux données

 

Nettoyage et remaniement des données

La permutation des colonnes en lignes n'a jamais été aussi simple

Lorsque vous devez permuter vos données des colonnes en lignes, vous pouvez désormais sélectionner des champs manuellement dans le volet Profil. Tableau Prep Builder peut également recommander des champs à permuter, et créer la permutation pour vous. Ces deux options génèrent automatiquement l'étape de permutation correspondante, pour vous permettre d'effectuer rapidement toute action supplémentaire, comme la permutation de champs supplémentaires ou l'attribution d'un nouveau nom aux champs permutés. Pour permuter manuellement les colonnes en lignes depuis le volet Profil, sélectionnez simplement les champs à permuter, puis cliquez avec le bouton droit de la souris (ou cliquez en maintenant la touche Ctrl enfoncée sur Mac) et sélectionnez Permuter les colonnes en lignes dans le menu pour créer l'étape de permutation. Si Tableau Prep Builder détecte des champs pouvant être permutés, une recommandation s'affiche dans la barre d'outils du volet Profil. Cliquez sur l'icône en forme d'ampoule Small lightbulb dans la barre d'outils et sélectionnez la recommandation. Celle-ci indique les champs qui vont être permutés. Cliquez simplement sur Appliquer pour générer l'étape de permutation et l'appliquer. Pour en savoir plus sur la permutation de données, lisez Permuter vos données.

Pour en savoir plus sur l'utilisation des recommandations pour nettoyer les données, consultez la rubrique d'aide Appliquer les opérations de nettoyage selon les recommandations (version 2018.3.2 ou ultérieure) 

 

Autres améliorations

Suivez l'avancement des opérations à exécution longue

Pour vous offrir une meilleure visibilité lors du traitement d'ensembles de données ou de flux volumineux, nous avons ajouté un indicateur de progression en haut du volet Flux, qui donne des informations sur l'état au fur et à mesure que Tableau Prep Builder traite vos données. Vous pouvez désormais voir plus facilement comment Tableau Prep Builder travaille en arrière-plan, et vous pouvez également déterminer si vos données sont toujours en cours de traitement ou si un problème s'est produit. 

 

 

Nouveautés de Tableau Prep Builder 2019.4.1

Connexion à encore plus de données dans le cloud

Cette version inclut ces nouveaux connecteurs cloud :

  • Box
  • Dropbox
  • Google Drive
  • OneDrive

Une configuration supplémentaire peut être nécessaire pour enregistrer vos informations d'identification pour ces connecteurs si vous envisagez de publier vos flux sur Tableau Server ou Tableau Online. Pour en savoir plus sur l'utilisation des connecteurs de données cloud, lisez la rubrique d'aide Se connecter aux sources de données dans le cloud.

Autres améliorations

Partage des données d'utilisation avec Tableau

Tableau collecte des données qui nous permettent de comprendre comment vous utilisez nos produits afin d'améliorer les fonctionnalités existantes et d'en proposer de nouvelles. Ces données d'utilisation sont collectées et gérées conformément à la Politique de confidentialité de Tableau. Vous pouvez toutefois y mettre fin. L'option pour faire cesser la collecte a changé. La collecte des données d'utilisation est activée par défaut. Pour la désactiver, sélectionnez l'option Ne pas envoyer des données d'utilisation du produit lors de l'installation ou dans les options de personnalisation de l'installation sur macOS, ou bien dans le menu Aide une fois le produit installé.

Pour en savoir plus, lisez Désactiver les rapports sur l'utilisation dans le guide de déploiement de Tableau Desktop et Tableau Prep.

Fin de l'installation automatique des pilotes de base de données par défaut sur macOS

Lors de l'installation de Tableau Prep Builder sur Mac, seul le pilote de base de données PostgreSQL est installé automatiquement. Si vous avez besoin d'autres pilotes pour vous connecter à vos données, vous pouvez les installer depuis la page Téléchargement de pilote

 

 

Nouveautés de Tableau Prep Builder 2019.3.2

Amélioration des performances

Amélioration des performances interactives

Bonne nouvelle pour les utilisateurs qui rencontrent des problèmes de performances dans leurs workflows Tableau Prep Builder : cette nouvelle version apporte de nombreuses améliorations.

  • Démarrage : l'application démarre jusqu'à 15 % plus vite que la version 3.1.
  • Chargement des fichiers Excel et texte : le chargement des fichiers Excel et texte est jusqu'à 50 % plus rapide que dans la version 3.1.
  • Union avec caractère générique : les clients utilisant des unions avec caractères génériques pourront profiter d'un gain de performances pouvant atteindre 50 % pour les fichiers texte, et 700 % pour les fichiers Excel.
  • Matérialisation des nœuds : les modifications apportées à la mise en cache des étapes d'union dans un flux permettent aux clients de profiter d'un gain de performances pouvant atteindre 95 % en fonction du nombre d'étapes d'union dans le flux et de l'endroit où ils cliquent dans le flux.
Compatibilité avec Tableau Prep Conductor

Les améliorations des performances interactives sont compatibles avec Tableau Prep Conductor et ne devraient pas affecter le mode batch.

Création et organisation de votre flux

Amélioration de l'insertion d'étapes

L'insertion d'étapes dans un flux était une opération complexe, mais la nouvelle version vous permet d'ajouter l'étape de votre choix (hormis les étapes d'entrée et de sortie) sans avoir à répéter les mêmes opérations chronophages. Cette nouvelle fonctionnalité vous permet de copier et coller les étapes et composants de vos flux pour les réutiliser. Ouvrez un flux, puis accédez à une branche. Lorsque vous survolez cette branche, une icône + s'affiche. Cliquez sur cette icône pour sélectionner l'étape que vous souhaitez insérer.

Pour en savoir plus, lisez la rubrique d'aide Ajouter ou insérer des étapes.

Compatibilité avec Tableau Prep Conductor

Cette fonctionnalité est totalement compatible avec Tableau Prep Conductor. Elle n'a aucune incidence sur la manière dont les flux s'exécutent.

Réutilisation d'étapes

Bon nombre d'utilisateurs doivent préparer leurs données en répétant les mêmes opérations de nettoyage, mais ils souhaiteraient réutiliser leur travail avec d'autres données dans des flux différents. Avec cette nouvelle fonctionnalité, vous pouvez facilement réutiliser les étapes d'un flux pour gagner du temps, et même utiliser des étapes créées par d'autres utilisateurs. Désormais, vous pouvez sélectionner un groupe d'étapes connectées et les enregistrer dans un fichier pour les réutiliser dans d'autres flux, ou les publier sur Tableau Server pour les réutiliser ultérieurement ou permettre à d'autres utilisateurs de les exploiter.

Pour en savoir plus, lisez la rubrique d'aide Créer des étapes réutilisables (à partir de la version 2019.3.2).

Compatibilité avec Tableau Prep Conductor

Les extraits de flux sont des fichiers .tfl que vous pouvez publier sur Tableau Server. Vous pouvez également les programmer s'il existe une étape d'entrée et de sortie.

Examen et filtrage des données

Rôles de données personnalisés approchants

Dans Tableau Prep Builder 2019.2.2, vous pouviez corriger les valeurs non valides dans les rôles de données intégrés, en les remplaçant par les valeurs valides les plus proches, par « fuzzy matching ». Tableau Prep Builder 2019.3.1 permettait de créer des rôles de données personnalisés. Dans cette nouvelle version, vous pouvez corriger automatiquement les valeurs non valides en les remplaçant par les valeurs valides les plus proches. Désormais, vous pouvez corriger automatiquement les valeurs non valides en tirant parti de la puissance des rôles de données personnalisés. Sélectionnez simplement un ensemble de données et un champ de catégorie, puis publiez-le sous forme de rôle de données personnalisé. Appliquez ensuite ce rôle à des données contenant des valeurs non valides. Les recommandations proposent de remplacer les valeurs non valides par les valeurs les plus proches pour le rôle en question (grâce à l'algorithme Prononciation + Orthographe). Il vous suffit d'appliquer cette modification pour corriger vos données.

Pour plus d'informations sur le « fuzzy matching », consultez la rubrique d'aide Regrouper des valeurs similaires par type de données.

Compatibilité avec Tableau Prep Conductor

Les algorithmes de regroupement par similitude ne fonctionnent pas en mode batch. Lorsque le flux est créé et que l'utilisateur sélectionne un algorithme de regroupement, les regroupements exacts sont stockés dans la liste Modifications, et ceux-ci sont ensuite exécutés en mode batch, ce qui rend cette fonctionnalité compatible avec Tableau Prep Conductor.

Navigation et affichage

Navigation dans le flux

Si vous créez un flux contenant de nombreuses étapes dans Tableau Prep Builder, vous risquez d'avoir du mal à le parcourir. Avec la navigation dans le flux vous pouvez afficher une version réduite de vos flux, pour les parcourir plus rapidement. Cet outil permet également d'effectuer un zoom avant ou arrière sur vos flux.

    • Ouvrez un flux contenant de nombreuses étapes.
    • Une mini-carte s'affiche dans le coin inférieur droit.
    • Utilisez l'outil de sélection pour parcourir le flux.
    • Les autres boutons de la mini-carte s'utilisent comme suit :
    1. La flèche vers le bas permet de réduire la mini-carte.
    2. Le bouton carré permet de zoomer de manière à afficher le flux entier sur votre écran.
    3. Les boutons +/- permettent d'effectuer un zoom avant et arrière.
    4. Cliquez sur l'indicateur % pour revenir au zoom à 100 %.

Pour en savoir plus, lisez la rubrique d'aide Utiliser l'outil de navigation de flux.

Compatibilité avec Tableau Prep Conductor

Entièrement compatible.

Vue Liste

Pour les utilisateurs, la vue de l'étape des données entrantes est utile, car elle permet de voir facilement tous les champs et d'effectuer des opérations rapides comme renommer ou supprimer des champs. Les utilisateurs souhaitaient profiter d'une expérience similaire pour toutes les étapes. Il était souvent frustrant de ne voir que 4 ou 5 champs à la fois dans la vue et de devoir faire défiler l'écran pour afficher le reste. La nouvelle vue Liste permet d'avoir un aperçu différent des données, centré sur les métadonnées. Elle permet aux utilisateurs de supprimer ou renommer facilement les étapes, ou encore de changer le type de données et d'ajouter des calculs.

  • Ouvrez un flux.
  • Accédez à l'étape de votre choix.
  • Dans la barre d'outils au-dessus du volet Profil, cliquez sur l'icône de la vue Liste :
    1. Survolez un champ, puis cliquez sur X pour le supprimer.
    2. Dans le menu ..., vous pouvez accéder à toutes les options de nettoyage qui sont disponibles dans le volet Profil. Toutes les opérations qui ont un impact sur vos valeurs (comme le filtrage) vous amèneront automatiquement dans le volet Profil. Les actions effectuées affectent uniquement les métadonnées (comme l'attribution d'un nouveau nom à un champ).

Pour en savoir plus, lisez la rubrique d'aide Sélectionner votre vue.

Compatibilité avec Tableau Prep Conductor

Compatibilité totale, sans aucun effet sur la manière dont les sorties sont générées.

Améliorations pour l'interface en ligne de commande

Les identifiants du trousseau macOS ne sont plus nécessaires pour l'exécution des flux

Bon nombre de clients utilisent l'interface en ligne de commande pour automatiser l'exécution des flux Tableau Prep. Grâce aux améliorations incluses dans cette nouvelle version, vous n'avez plus besoin de fournir manuellement les identifiants du trousseau macOS à chaque exécution du flux. Il vous suffit d'exécuter un flux à l'aide de l'interface en ligne de commande installée avec Tableau Prep Builder.

Compatibilité avec Tableau Prep Conductor

S. O. 

Compatibilité

 

Tableau Prep Builder est un outil indépendant qui fonctionne en toute transparence avec Tableau Desktop, Tableau Server et Tableau Online. À tout moment dans Tableau Prep Builder, vous pouvez créer un extrait de vos données, publier votre source sur Tableau Server ou Tableau Online, ou même ouvrir Tableau Desktop depuis Tableau Prep Builder pour voir un aperçu de vos données.

  • Tableau Prep Builder est compatible avec Windows et Mac. Il permet de créer des extraits Tableau (.tde et .hyper) et des fichiers CSV utilisables dans Tableau 10.0 et les versions plus récentes.
  • Dans Tableau Prep Builder, vous pouvez vous connecter à la plupart des sources de données disponibles dans Tableau Desktop, Tableau Server et Tableau Online. Pour voir la liste complète des sources de données prises en charge par Tableau, cliquez ici.
  • Pour certaines sources de données, il peut être nécessaire d'installer des pilotes avant de vous y connecter. Le cas échéant, consultez la page Téléchargement de pilote.

 

Nouvel espace de travail pour accélérer la découverte d'insights

 

Tableau Prep Builder utilise les connecteurs, l'éditeur de calcul et la structure de gouvernance de Tableau pour vous aider à suivre ce qui se passe et à collaborer à chaque étape du processus analytique.

L'espace de travail se compose d'un volet pour les connexions, d'un volet pour les modifications, et de trois zones coordonnées vous permettant d'interagir avec vos données et de les explorer.

  1. Volet Connexions : ce volet contient les bases de données et fichiers auxquels vous êtes connecté. Vous pouvez ajouter des connexions à une ou plusieurs bases de données, puis faire glisser les tables à utiliser dans le volet Flux. 
  2. Volet Flux : à mesure que vous vous connectez aux données, les nettoyez, les remaniez et les combinez, ces étapes s'affichent dans le volet Flux. Survolez les icônes au-dessus de chaque étape pour voir les modifications que vous avez effectuées. 
  3. Volet Profil : le volet Profil, au centre de l'espace de travail, affiche un récapitulatif de chaque champ de votre échantillon de données. Il permet aux utilisateurs de voir comment sont formées les données et de rapidement repérer les valeurs inhabituelles et valeurs null.
  4. Volet Modifications : Tableau Prep Builder garde une trace de toutes vos modifications, dans l'ordre dans lequel vous les effectuez, pour vous permettre de les passer en revue et d'y revenir si nécessaire.
  5. Grille de données : la grille de données affiche les détails au niveau des lignes dans vos données. Les valeurs indiquées reflètent les opérations effectuées dans le volet Profil. Vous pouvez filtrer les données, conserver des champs ou les exclure dans cette grille, et modifier l'ordre d'affichage en les faisant glisser.

 

Vous trouverez une description complète, ainsi qu'une vidéo, dans la rubrique Espace de travail de l'aide du produit.

Enregistrement et partage des fichiers de sortie

 

Enregistrement d'un fichier de sortie

Tableau Prep Builder permet d'enregistrer trois types de fichiers :

  1. Fichiers .tfl contenant un flux
  2. Fichiers .tflx contenant un flux et des sources de données basées sur des fichiers locaux, comme des fichiers Excel ou texte
  3. Fichiers de sortie contenant les résultats de l'exécution d'un flux

Les fichiers de sortie peuvent être enregistrés aux formats .hyper, .tde et .csv, et sont définis à l'étape Sortie. Vous pouvez les ouvrir dans Tableau Desktop et les publier sur Tableau Server ou Tableau Online.

 

Tableau Desktop

L'exécution du flux dans Tableau Desktop produit un extrait de données Tableau, au format .tde ou .hyper selon votre version de Tableau. Le fichier de cet extrait est enregistré dans le référentiel Tableau, dans le dossier des sources de données. Vous pouvez également créer un fichier .csv pour utiliser vos données préparées dans d'autres outils ou processus. Remarque : une fois l'extrait créé, que ce soit au format .tde ou .hyper, lorsqu'il est utilisé dans un classeur, les règles de compatibilité habituelles s'appliquent pour les différentes versions de Tableau. Pour en savoir plus, lisez la rubrique d'aide Rendre les classeurs compatibles entre les versions.

Tableau Server

Pour publier votre fichier de sortie sur Tableau Server, utilisez la commande Publier de Tableau Prep Builder. L'API REST de Tableau Server doit être activée pour permettre la réception des demandes de publication envoyées par Tableau Prep Builder. Pour en savoir plus, consultez la rubrique Référence sur l'API REST (en anglais).

Tableau Online

Vous pouvez également utiliser la commande Publier de Tableau Prep Builder pour publier vos résultats sur Tableau Online, sous la forme d'un extrait .hyper ou .tde ou d'un fichier .csv, et ainsi proposer un accès centralisé aux données que vous avez nettoyées, mises en forme et combinées.

 

Mises à jour fréquentes pour Tableau Prep Builder

 

Nous lancerons régulièrement de nouvelles fonctionnalités pour Tableau Prep Builder, indépendamment des mises à jour de Tableau Desktop, Tableau Server et Tableau Online. Les clients devront passer à la version la plus récente de Tableau Prep Builder pour profiter des dernières fonctionnalités et des correctifs.

À intervalles réguliers, nous publierons des liens vers des cas d'utilisation de la Communauté, des informations sur le produit ou des astuces pour vous aider à optimiser la préparation de vos données.

Ressources supplémentaires

 
Où trouver Tableau Prep Builder ?
Tableau Prep Builder est proposé uniquement dans le cadre d'une souscription avec le package Tableau Creator. Les utilisateurs actuels de Tableau Desktop qui ont un contrat de maintenance pourront télécharger et utiliser Tableau Prep Builder dans le cadre de ce contrat de maintenance. Si vous n'avez pas encore téléchargé Tableau Prep Builder, rendez-vous sur cette page ou cliquez sur le bouton de téléchargement en haut de cette page afin d'accéder à la toute dernière version du produit. Vous ne savez pas quels types de licences vous utilisez ? Commencez par lire la rubrique d'aide Gérer les licences pour Tableau Desktop et Tableau Prep Builder.
 
Essayez Tableau Prep Builder gratuitement !
Vous pouvez télécharger une version d'évaluation gratuite de Tableau Prep Builder valable 14 jours en cliquant ici.
 
Caractéristiques techniques
Pour consulter les caractéristiques techniques de Tableau Prep Builder, cliquez ici.
 
Notes de version de Tableau Prep Builder

Obtenir de l'aide

 
Assistance technique
Pour obtenir la meilleure
Assistance , pensez à nous transmettre :
  • Des captures d'écran illustrant le problème et les messages d'erreur éventuels (affichés en entier)
  • Heures auxquelles vous êtes joignable
 
Services de conseil
Nos conseillers vous expliquent comment tirer le meilleur parti des fonctionnalités de Tableau Prep Builder et révéler le potentiel de vos données.