Tableau Online 升级将带来哪些变化

您已收到来自 Tableau Online 的电子邮件通知,告知您即将进行升级。此页面将帮助您做好准备,以便您的 Tableau Online 用户可以继续使用 Tableau Desktop 和 Tableau Online。

如果您不是 Tableau Online 管理员,请参阅以下其他资源页面:

  • Tableau Desktop 升级资源
  • Tableau Server 升级资源


  • 学习

    概述

    如果您想获取关于 Tableau Online 的更多信息,请从此处开始了解云端自助式分析。

    新增功能

    我们会定期发布新增和改进功能。有关详细信息,请参阅 Tableau Online 新增功能。以下是最新的改进之处:

    • 新增了 .hyper 数据提取格式并改进了数据引擎
    • 改进了订阅功能
    • 改进了 Tableau Bridge、Web 制作等众多功能!

    Hyper 是 Tableau 新推出的内存驻留数据引擎技术,针对大型或复杂数据集进行了优化,可对这类数据集快速进行数据摄取和分析查询处理。Hyper 的引入带来了许多与数据提取相关的改变。从 Tableau 10.5 开始,新的数据提取即使用 .hyper 文件格式而非 .tde 文件格式。

    以下各节介绍了会导致 .tde 数据提取升级为 .hyper 数据提取的操作,用户可能会报告的常见问题,以及如果您搭配使用旧版本的 Tableau Desktop 和 Tableau Server 10.5 版会出现的重要兼容性问题。制定升级计划时,请将查看此内容作为其中一项。

    数据提取文件转换为 .hyper 格式

    升级 Tableau Online 后,用户可能会注意到或报告其 .tde 数据提取已更改为新的 .hyper 格式;或者他们可能会收到提及新 .hyper 数据提取格式的错误消息。数据提取文件由改进的数据引擎进行转换,这将帮助 Tableau 用户更快地创建和刷新更大的数据提取。

    若要了解数据提取会在哪些情况下从 .tde 升级到新的 .hyper 格式,请参阅下表。黑色圆圈表示数据提取将被升级为 .hyper 格式。有关更多详细信息,请参阅 Tableau 帮助中的导致数据提取升级的任务

    有关 Tableau Desktop 文件转换注意事项的更多信息,请参阅 Tableau Desktop 升级页面

      Tableau Bridge Tableau 数据提取命令行实用工具 Tableau Online
    (包括使用 Tableau 数据提取命令行实用工具)
    10.4 及更低版本 10.5 及更高版本 10.4 及更低版本 10.5 及更高版本
    完全数据提取刷新
    增量数据提取刷新
    将数据追加到数据提取

    了解上述行为

    这到底意味着什么?请参阅下方具体要点,了解即将发生哪些改动,而您又可以建议 Tableau 用户执行什么操作:
  • Tableau Online 运行的所有刷新操作都会将您的 .tde 数据提取升级为 .hyper 格式。
  • Tableau Online 发布后,您可能会注意到,当立即刷新时,您的 .tde 数据提取不会全部升级为 .hyper 格式。这是 Tableau Online 全面过渡至 .hyper 格式这一过程中的预期行为。
  • 数据提取一旦升级为新的 .hyper 数据提取格式,便无法还原。这意味着,已升级的数据提取无法转换回 .tde 数据提取,并且 Tableau 10.4(及更低版本)的数据引擎无法读取已升级的数据提取。
  • 使用 10.4(或更低版本)客户端(如 Tableau Bridge、Tableau 数据提取命令行实用工具、API 等)对数据源执行完全刷新后:您可以执行刷新,数据提取将保留为 .tde 格式。此外,您可以使用 Tableau Desktop 10.4(及更低版本)打开并连接到已发布的数据源。
  • 在使用 Tableau Bridge 10.4(或更低版本)对数据源执行增量刷新后:您可以执行刷新,数据提取将保存为 .hyper 格式。但是,您将无法使用 Tableau Desktop 10.4 及更低版本来打开此已刷新的数据源(无论是增量刷新还是完全刷新),而在使用 Tableau Desktop 10.4(及更低版本)下载并打开该数据源后,系统会要求您找到并重新生成数据提取。将您的用户重定向到“数据提取升级之后”,了解重新创建数据提取的步骤。
  • 使用 10.4(或更低版本)客户端(例如 Tableau 数据提取命令行实用工具、API 等)对数据源执行增量刷新后:您可以执行刷新,数据提取将保留为 .tde 格式。请注意,在您使用 Tableau Desktop 10.4(及更低版本)下载并打开该数据源后,系统会要求您找到并重新生成数据提取。将您的用户重定向到“数据提取升级之后”,了解重新创建数据提取的步骤。
  • 数据提取兼容性情景

    如果您的 Tableau Online 用户报告称,他们在与数据提取进行交互时无法执行特定操作,则他们可能遇到了数据提取兼容性问题。

    下表从用户视角展示了几个情景示例,并介绍了执行涉及数据提取的特定操作时,Tableau Online 的后台会发生什么情况。

    请注意,对于已发布数据源,以下工作簿行为是相同的。


      使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
    作为 Tableau Online 和 Tableau Desktop 用户,您尝试将工作簿或数据提取发布到 Tableau Online
     
    • 您可以发布此工作簿或数据提取
    • 数据提取保留为 .tde 格式
    • 您可以发布此工作簿或数据提取
    • 数据提取保留为 .tde 格式
    • 您可以发布此工作簿或数据提取
    • 数据提取保存为 .hyper 格式
      使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
    作为 Tableau Online 和 Tableau Desktop 用户,您尝试对工作簿进行 Web 编辑或将其保存到 Tableau Online
    (在将其发布到 Tableau Online 之后)
     

    不在 Tableau Online 中进行刷新或追加

    • 您可以对此工作簿进行 Web 编辑
    • 您将无法在 Tableau Desktop 10.4 或更低版本中再次下载和打开此工作簿。 但是,您可以将此工作簿以旧版本的格式导出。
    • 数据提取保留为 .tde 格式
    • 您可以对此工作簿进行 Web 编辑
    • 数据提取保留为 .tde 格式
    • 您可以对此工作簿进行 Web 编辑
    • 数据提取保留为 .hyper 格式
     

    在 Tableau Online 中刷新或追加数据提取

    • 您可以对此工作簿进行 Web 编辑
    • 下一次刷新发生时,数据提取保存为 .hyper 格式
    • 注意:如果您未编辑工作簿,直接执行刷新/追加,则数据提取不会升级,而是保留为 .tde 格式。
    • 您可以对此工作簿进行 Web 编辑
    • 数据提取保存为 .hyper 格式
    • 您可以对此工作簿进行 Web 编辑
    • 数据提取保留为 .hyper 格式
      使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
    作为 Tableau Online 和 Tableau Desktop 用户,您尝试下载并打开工作簿和数据提取
     

    使用 Tableau Desktop 10.4(及更低版本)

    • 您可以下载和共享此工作簿。对此工作簿进行 Web 编辑后,您将无法在 Tableau Desktop 10.4 或更低版本中再次下载和打开此工作簿。
    • 如果不编辑工作簿,直接执行刷新/追加操作,则在使用 Tableau Desktop 10.4 下载并打开此工作簿后,系统可能会要求您找到并重新生成数据提取。请参阅“数据提取升级之后”,了解重新创建数据提取的步骤。
    • 您可以将此工作簿以旧版本的格式导出。
    您无法与此工作簿或数据提取进行交互。有关详细信息,请参阅这篇知识库文章 您无法与此工作簿或数据提取进行交互。有关详细信息,请参阅这篇知识库文章
     

    使用 Tableau Desktop 10.5(及更高版本)

    您可以下载并打开此工作簿和数据提取。 您可以下载并打开此工作簿和数据提取。 您可以下载并打开此工作簿和数据提取。
      使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
    作为 Tableau Online 用户,您需要使用 Tableau Desktop 中的“导出为版本...”,并在相应的 Tableau 版本(或更高版本)中打开工作簿
      如果工作簿使用的是 .tde 数据提取,则可以在相应的 Tableau 版本(或更高版本)中导出并打开此工作簿和数据提取。 如果工作簿使用的是 .tde 数据提取,则可以在相应的 Tableau 版本(或更高版本)中导出并打开此工作簿和数据提取。 此数据源使用的是 .hyper 格式的数据提取,因此无法执行此操作。相应选项将变为灰色。有关详细信息,请参阅这篇知识库文章。**
     
    **在 Tableau Online 中使用“下载为旧版本”选项时,可下载此工作簿的旧版本(此类工作簿可使用 Tableau Desktop 10.4 及更低版本打开)。但请注意,如果使用了 .hyper 数据提取,则它将包含在打包工作簿文件中,旧版本的 Tableau Desktop 无法读取此类文件。

    在 Tableau Desktop 10.4 及更低版本中,无论尝试对通过 Tableau Desktop 10.5 或更高版本创建的数据提取进行任何操作,都将导致错误消息。有关详细信息,请参阅这篇知识库文章

    特定于 Tableau Online

    Tableau Bridge、Tabcmd、API 2.0 和 Tableau 数据提取命令行实用工具
  • 安装新的 Tableau Desktop 主要版本时,会同时安装最新版 Tableau Bridge 客户端。有关何时升级 Tableau Bridge 的更多信息,请参阅这篇文章
  • 若要使用 Tabcmd 发布 .hyper 数据提取或与之交互,您需要 Tabcmd 10.5 或更高版本;请参阅 Tableau 帮助中的安装 Tabcmd
  • 使用数据提取 API 2.0,您可以打开并创建新的 .hyper 数据提取。请注意,数据提取 API 2.0 无法创建 .tde 数据提取。
  • 数据提取 API 2.0 不再包含服务器 API,请使用 REST API 发布您的数据提取。
  • 类似于 Tableau Bridge,Tableau 数据提取命令行实用工具也会使用新的 .hyper 格式进行数据提取转换。有关此主题的更多信息,请参阅 Tableau 帮助中的 Tableau 数据提取命令行实用工具
  • 其他资源

    获取帮助

    自助资源
    技术支持
  • 提交支持案例。为尽快获得支持,请提供以下信息: