Hyper 支持资源

关于 Hyper 转换和兼容性的所有支持信息。

概述

Hyper 是 Tableau 的内存驻留数据引擎技术,针对大型或复杂数据集进行了优化,可对这类数据集快速进行数据摄取和分析查询处理。Hyper 的引入带来了许多与数据提取相关的改变。从 Tableau 10.5 开始,新的数据提取即使用 .hyper 文件格式而非 .tde 文件格式。

以下各节介绍了会导致 .tde 数据提取升级为 .hyper 数据提取的操作,用户可能会遇到的常见问题,以及升级 Tableau 产品后可能出现的重要兼容性问题(例如,Tableau Desktop、Tableau Online 和 Tableau Server 没有同时升级)。制定升级计划时,请将查看此内容作为其中一项。

要跳转到具体产品对应的部分,请单击以下某个选项:

Tableau Desktop 的 .hyper 数据提取文件转换

在 Tableau Desktop、Tableau Server 或 Tableau Online 升级后,您可能会遇到有关数据提取和/或工作簿的新问题或新行为。执行特定操作会将现有 .tde 数据提取更改为新的 .hyper 数据提取格式。

在更新、发布或与他人共享您的工作成果时,需要考虑以下几点:

  • 数据提取一旦升级为新的 .hyper 数据提取格式,便无法还原。这意味着,已升级的数据提取无法转换回 .tde 数据提取,并且 10.5 以前的 Tableau Desktop 版本无法打开已升级的数据提取。
  • 升级后的数据提取不向后兼容。我们建议您组织中的 Tableau Server 和所有 Tableau Desktop 副本都使用相同的版本,并按照相同的计划升级到 10.5(或更高版本)。
  • 有关兼容性问题的更多信息,请参阅: Tableau Desktop 和 Tableau Server 之间的版本兼容性

    下表显示了哪些操作会导致 .tde 格式被转换为新的 .hyper 格式。蓝色复选标记表示数据提取将被转换为 .hyper 格式。



      Tableau Desktop
    10.4 及更低版本 10.5 及更高版本
    完全数据提取刷新
    将数据追加到数据提取
    手动升级数据提取

数据提取兼容性情景 - Tableau Desktop 和 Tableau Reader

请参阅下表,了解有关 Tableau Desktop 和 Tableau Reader 之间的数据提取兼容性的更多信息。

  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 或更高版本中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
使用 Tableau Reader 和 Tableau Desktop 10.4 及更低版本打开工作簿 您可以打开此工作簿。 您将无法与此工作簿或此数据提取进行交互。有关详细信息,请参阅这篇知识库文章 您将无法与此工作簿或此数据提取进行交互。有关详细信息,请参阅这篇知识库文章
使用 Tableau Reader 和 Tableau Desktop 10.5 及更高版本打开工作簿 您可以打开此工作簿。请注意,这是预期的版本控制行为,数据提取不会影响此情景。 您可以打开此工作簿。请注意,这是预期的版本控制行为,数据提取不会影响此情景。 您可以打开此工作簿。请注意,这是预期的版本控制行为,数据提取不会影响此情景。

Tableau Online - .hyper 数据提取文件转换

升级 Tableau Online 后,用户可能会注意到或报告其 .tde 数据提取已更改为新的 .hyper 格式,或者他们可能会收到提及新 .hyper 数据提取格式的错误消息。数据提取文件由改进的数据引擎进行转换,这将帮助 Tableau 用户更快地创建和刷新更大的数据提取。

若要了解数据提取会在哪些情况下从 .tde 升级到新的 .hyper 格式,请参阅下表。蓝色复选标记表示数据提取将被转换为 .hyper 格式。有关更多详细信息,请参阅 Tableau 帮助中的导致数据提取升级的任务

有关 Tableau Desktop 文件转换注意事项的更多信息,请参阅 Tableau Desktop 升级页面

  Tableau Bridge Tableau 数据提取命令行实用工具 Tableau Online
10.4 及更低版本 10.5 及更高版本 10.4 及更低版本 10.5 及更高版本
完全数据提取刷新
增量数据提取刷新
将数据追加到数据提取



了解上述行为

这到底意味着什么?请参阅下方具体要点,了解即将发生哪些改动,而您又可以建议 Tableau 用户执行什么操作:

  • Tableau Online 运行的所有刷新操作都会将您的 .tde 数据提取升级为 .hyper 格式。
  • 数据提取一旦升级为新的 .hyper 数据提取格式,便无法还原。这意味着,已升级的数据提取无法转换回 .tde 数据提取,并且 Tableau 10.4(及更低版本)的数据引擎无法读取已升级的数据提取。
  • 使用 10.4(或更低版本)客户端(如 Tableau Bridge、Tableau 数据提取命令行实用工具、API 等)对数据源执行完全刷新后:您可以执行刷新,数据提取将保留为 .tde 格式。此外,您可以使用 Tableau Desktop 10.4(及更低版本)打开并连接到已发布的数据源。
  • 在使用 Tableau Bridge 10.4(或更低版本)对数据源执行增量刷新后:您可以执行刷新,数据提取将保存为 .hyper 格式。但是,您将无法使用 Tableau Desktop 10.4 及更低版本来打开该已刷新的数据源(无论是增量刷新还是完全刷新),而在使用 Tableau Desktop 10.4(及更低版本)下载并打开该数据源后,系统会要求您找到并重新生成数据提取。不妨请您的用户参阅“数据提取升级后应该做什么”,了解重新创建数据提取的步骤。
  • 使用 10.4(或更低版本)客户端(例如 Tableau 数据提取命令行实用工具、API 等)对数据源执行增量刷新后:您可以执行刷新,数据提取将保留为 .hyper 格式。请注意,在您使用 Tableau Desktop 10.4(及更低版本)下载并打开该数据源后,系统会要求您找到并重新生成数据提取。不妨请您的用户参阅“数据提取升级后应该做什么”,了解重新创建数据提取的步骤。



确定数据提取的转换时间

要了解具体哪些数据提取会受到影响,您可以进入管理员视图,然后按作业类型进行筛选。有关更多信息,请参阅数据提取后台任务

在“任务”中按“TdeRefreshExtract”和“TdeIncrementalExtract”筛选,即可找出当前格式为 .tde 的所有数据提取。这些数据提取将升级为 .hyper 格式。

Tableau Online 数据提取兼容性情景

如果您的 Tableau Online 用户报告称,他们在与数据提取进行交互时无法执行特定操作,则可能是遇到了数据提取兼容性问题。

下表从用户视角展示了几个情景示例,并介绍了执行涉及数据提取的特定操作时,Tableau Online 的后台会发生什么情况。

请注意,对于已发布数据源,以下工作簿行为是相同的。



  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 或更高版本中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
作为 Tableau Online 和 Tableau Desktop 用户,您尝试将工作簿或数据提取发布到 Tableau Online
 
  • 您可以发布此工作簿或数据提取
  • 数据提取保留为 .tde 格式
  • 您可以发布此工作簿或数据提取
  • 数据提取保留为 .tde 格式
  • 您可以发布此工作簿或数据提取
  • 数据提取保存为 .hyper 格式

  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 或更高版本中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
作为 Tableau Online 和 Tableau Desktop 用户,您尝试对工作簿进行 Web 编辑或将其保存到 Tableau Online
(在将其发布到 Tableau Online 之后)
 

不在 Tableau Online 中进行刷新或追加

  • 您可以对此工作簿进行 Web 编辑
  • 您将无法在 Tableau Desktop 10.4 或更低版本中再次下载和打开此工作簿。但是,您可以将此工作簿以旧版本的格式导出。
  • 数据提取保留为 .tde 格式
  • 您可以对此工作簿进行 Web 编辑
  • 数据提取保留为 .tde 格式
  • 您可以对此工作簿进行 Web 编辑
  • 数据提取保留为 .hyper 格式
 

在 Tableau Online 中刷新或追加数据提取

  • 您可以对此工作簿进行 Web 编辑
  • 下一次刷新发生时,数据提取保存为 .hyper 格式
  • 您可以对此工作簿进行 Web 编辑
  • 数据提取保存为 .hyper 格式
  • 您可以对此工作簿进行 Web 编辑
  • 数据提取保留为 .hyper 格式

  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 或更高版本中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
作为 Tableau Online 和 Tableau Desktop 用户,您尝试下载并打开工作簿和数据提取
 

使用 Tableau Desktop 10.4(及更低版本)

  • 您可以下载和共享此工作簿。对此工作簿进行 Web 编辑后,您将无法在 Tableau Desktop 10.4 或更低版本中再次下载和打开此工作簿。
  • 如果不编辑工作簿,直接执行刷新/追加操作,则在使用 Tableau Desktop 10.4 下载并打开此工作簿后,系统可能会要求您找到并重新生成数据提取。请参阅“数据提取升级后应该做什么”,了解重新创建数据提取的步骤。
  • 您可以将此工作簿以旧版本的格式导出。
您无法与此工作簿或数据提取进行交互。有关详细信息,请参阅这篇知识库文章 您无法与此工作簿或数据提取进行交互。有关详细信息,请参阅这篇知识库文章
 

使用 Tableau Desktop 10.5(及更高版本)

  • 您可以下载并打开此工作簿和数据提取。
  • 如果在使用旧版本 Tableau Desktop 编辑或下载工作簿时遇到问题,请参阅以下知识库文章
  • 您可以下载并打开此工作簿和数据提取。
  • 如果在使用旧版本 Tableau Desktop 编辑或下载工作簿时遇到问题,请参阅以下知识库文章
  • 您可以下载并打开此工作簿和数据提取。
  • 如果在使用旧版本 Tableau Desktop 编辑或下载工作簿时遇到问题,请参阅以下知识库文章

  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 或更高版本中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
作为 Tableau Online 用户,您使用 Tableau Desktop 中的“导出为版本...”,并在相应的 Tableau 版本(或更高版本)中打开工作簿
  如果工作簿使用的是 .tde 数据提取,则可以在相应的 Tableau 版本(或更高版本)中导出并打开此工作簿和数据提取。 如果工作簿使用的是 .tde 数据提取,则可以在相应的 Tableau 版本(或更高版本)中导出并打开此工作簿和数据提取。 此数据源使用的是 .hyper 格式的数据提取,因此无法执行此操作。相应选项将变为灰色。有关详细信息,请参阅这篇知识库文章。**
 

**在 Tableau Online 中使用“下载为旧版本”选项时,可下载此工作簿的旧版本(此类工作簿可使用 Tableau Desktop 10.4 及更低版本打开)。但请注意,如果使用了 .hyper 数据提取,则它将包含在打包工作簿文件中,旧版本的 Tableau Desktop 无法读取此类文件。

在 Tableau Desktop 10.4 及更低版本中,不论尝试对通过 Tableau Desktop 10.5 或更高版本创建的数据提取进行何种操作,都将出现错误消息。有关详细信息,请参阅这篇知识库文章

Tableau Server 的 .hyper 数据提取文件转换

我们建议您组织中的 Tableau Server 和所有 Tableau Desktop 都使用相同的版本,并按照相同的计划升级到 10.5(或更高版本)。

升级 Tableau Server 后,用户可能会注意到或报告其 .tde 数据提取已更改为新的 .hyper 格式;或者他们可能会收到提及新 .hyper 数据提取格式的错误消息。此数据提取文件转换是改进的数据引擎的一部分,可帮助 Tableau 用户更快地创建和刷新更大的数据提取。

有关 Tableau Desktop 文件转换注意事项的更多信息,请参阅 Tableau Desktop 升级页面

若要了解数据提取会在哪些情况下从 .tde 升级到新的 .hyper 格式,请参阅下表。蓝色复选标记表示数据提取将被转换为 .hyper 格式。有关更多详细信息,请参阅 Tableau 帮助中的导致数据提取升级的任务



Tabcmd Tableau 数据提取命令行实用工具
完全数据提取刷新
增量数据提取刷新
将数据追加到数据提取


Tableau Server 数据提取兼容性情景

如果您的 Tableau Server 用户报告称其在与提取进行交互时无法执行特定操作,则他们可能遇到了提取兼容性问题。

下表从用户视角展示了几个情景示例,并介绍了在执行特定操作时,Tableau Server 的后台会发生什么情况。

  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 或更高版本中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
作为 Tableau Server 和/或 Tableau Desktop 用户,您尝试将工作簿或数据提取发布到
 

Tableau Server 10.4 及更低版本

  • 您可以发布此工作簿或数据提取
  • 数据提取保留为 .tde 格式
  • 您将收到错误消息;有关详细信息,请查看这篇知识库文章
  • 在 Tableau Server 10.4 及更低版本中,该格式兼容所有相应的 Tableau Server 版本。
您将收到错误消息;有关详细信息,请查看这篇知识库文章
 

Tableau Server 10.5 及更高版本

  • 您可以发布此工作簿或数据提取
  • 数据提取保留为 .tde 格式
  • 您可以发布此工作簿或数据提取
  • 数据提取保留为 .tde 格式
  • 您可以发布此工作簿或数据提取
  • 数据提取保存为 .hyper 格式

  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 或更高版本中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
作为 Tableau Server 和/或 Tableau Desktop 用户,您尝试进行 Web 编辑或保存到 Tableau Server

(在将其发布到 Tableau Server 之后)
 

不在 Tableau Server 中进行刷新或追加

  • 您可以对此工作簿进行 Web 编辑。
  • 在所有 Tableau Server 版本中,数据提取保留为 .tde 格式。
  • 您可以对此工作簿进行 Web 编辑。
  • 在 Tableau Server 10.5 及更高版本中,数据提取保留为 .tde 格式
  • 您可以对此工作簿进行 Web 编辑。
  • 数据提取保存为 .hyper 格式
 

在 Tableau Server 中刷新或追加数据提取

  • 您可以对此工作簿进行 Web 编辑。
  • 在 Tableau Server 10.4 及更低版本中,数据提取保留为 .tde 格式。
  • 在 Tableau Server 10.5 及更高版本中,编辑工作簿或追加数据提取后,该数据提取将转换为新的 .hyper 格式。
  • 您可以对此工作簿进行 Web 编辑。
  • 在 Tableau Server 10.5 及更高版本中,数据提取更改为新的 .hyper 格式。
  • 您可以对此工作簿进行 Web 编辑。
  • 数据提取保存为 .hyper 格式

  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 或更高版本中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
作为 Tableau Server 和 Tableau Desktop 用户,您尝试下载并打开工作簿和数据提取
 

使用 Tableau Desktop 10.4(及更低版本)

  • 您可以下载并打开此工作簿。
  • 在 Tableau Server 10.4 及更低版本中,该格式兼容所有相应的 Tableau Server 版本。
  • 在 Tableau Server 10.5 及更高版本中,您可以打开工作簿,但无法使用数据提取。有关详细信息,请参阅这篇知识库文章
在所有 Tableau Server 版本中,您将收到一条错误消息;有关详细信息,请参阅这篇知识库文章 在所有 Tableau Server 版本中,您将收到一条错误消息;有关详细信息,请参阅这篇知识库文章
 

使用 Tableau Desktop 10.5(及更高版本)

您可以下载并打开此工作簿。 数据提取发布为 .hyper 数据提取格式,因此您可以从 Tableau Server 10.5(或更高版本)下载并打开此工作簿。 数据提取发布为 .hyper 数据提取格式,因此您可以从 Tableau Server 10.5 下载并打开此工作簿。

  使用 Tableau Desktop 10.4 及更低版本创建的工作簿和数据提取 使用 10.4 数据提取在 Tableau Desktop 10.5 中创建的工作簿 使用 Tableau Desktop 10.5 及更高版本创建的工作簿和数据提取
作为 Tableau Server 用户,您使用 Tableau Desktop 中的“导出为版本…”,并在相应的 Tableau 版本(或更高版本)中打开工作簿
 
  • 如果工作簿使用的是 .tde 数据提取,则可以在相应的 Tableau 版本(或更高版本)中导出并打开此工作簿和数据提取。
  • 在 Tableau Server 10.5(或更高版本)中编辑并保存工作簿后,您可以在相应的 Tableau 版本(或更高版本)中下载并打开此工作簿和数据提取。
如果工作簿使用的是 .tde 数据提取,则可以在相应的 Tableau 版本(或更高版本)中导出并打开此工作簿和数据提取。 此数据源使用的是 .hyper 格式的数据提取,因此无法将此工作簿导出到较低版本的 Tableau。有关详细信息,请参阅这篇知识库文章
 

在 Tableau Desktop 10.4 及更低版本中,不论尝试对通过 Tableau Desktop 10.5 或更高版本创建的数据提取进行何种操作,都将出现错误消息。有关详细信息,请参阅这篇知识库文章