Tableau Online のアップグレードについて

このページでは、Tableau Online のユーザーが Tableau Desktop と Tableau Online を、引き続き使用できるようにするための情報をご紹介します。

Tableau Online の管理者ではない方は、次の他のリソースページを参照してください:

  • Tableau Desktop アップグレード用リソース
  • Tableau Server アップグレード用リソース.


  • 情報の収集

    概要

    Tableau Online についてさらに詳しい情報が必要な場合は、こちらでクラウドでのセルフサービス分析について確認できます。詳細については、Tableau Online の概要および Tableau Online ヘルプを参照してください。

    Tableau Desktop 32 ビットバージョンを使用しているユーザーは、10.5 以降の機能が必要な場合や、Tableau Online からワークブックをダウンロードする必要がある場合、オペレーティングシステムを 64 ビット版に、また Tableau Desktop を最新バージョンにアップグレードする必要があります。詳細については、32 ビットのアップグレード用リソースを参照してください。

    新機能

    新機能や強化された機能が定期的にリリースされています。詳しくは、「Tableau Online の新機能」を参照してください。たとえば、新機能や機能強化には以下が含まれています。

    Hyper は、大規模または複雑なデータセットの最速のデータインジェストと分析クエリ処理に最適化された、Tableau のインメモリデータエンジンテクノロジーです。Hyper の導入により、抽出に関する数多くの変更点があります。Tableau 10.5 以降、新規の抽出には .tde の代わりに .hyper ファイル形式が使用されます。

    以下のセクションに、何をすると .tde の抽出が .hyper にアップグレードされるのか、ユーザーから報告される可能性のある一般的な問題、古いバージョンの Tableau Desktop と Tableau Online バージョン 10.5 を使用する場合の互換性に関する重要な注意点が説明されています。アップグレード計画の一環としてこのコンテンツをご確認ください。



    Hyper への完全なアップグレード

    今後数週間以内に Tableau Online のアップグレードが開始され、Hyper のみとなります。 抽出の更新を予定されている場合は、お客様のサイトの更新は 3 月 26 日以降に開始されます。サイトがアップグレードされると、次回の更新が実行される際に .tde から .hyper ファイルへの変換が実行されます。

    この移行の理由は、より高速な抽出パフォーマンスなどの Hyper が提供する利点を、すべてのお客様が最大限に活用できるようにするためです。

    抽出のアップグレードは 3 月 26 日週に開始されます。



    変換に関する注意事項

    Tableau 側で、お客様の抽出ファイルを .tde から .hyper ファイルへと変換します。この作業の期間中、使用時にパフォーマンスや可用性に関して違いを感じることはありません。知っておくべき重要なことは、抽出が .hyper ファイルへと変換されると、デスクトップの古いバージョンでは hyper 抽出を含むワークブックをダウンロードしたり開いたりすることができなくなることです。

    互換性やシナリオの詳細については、このページの以下の各セクションを参照してください。



    Hyper への変換に関する準備

    • まず、Tableau Online へのワークブックのダウンロードやパブリッシュに使用している Tableau Desktop のコピーが、Tableau 10.5 (またはそれ以降のバージョン) にアップグレードされていることを確認します。
    • Tableau Bridge を使用している場合は、Tableau Bridge のバージョンが Tableau 10.5 以降にアップデートされていることを確認します。

    .hyper 形式への抽出ファイルの変換

    Tableau Online のアップグレード後、.tde 形式の抽出ファイルが新しい .hyper 形式に変換された、または新しい .hyper 形式の抽出に関するエラーメッセージが表示されたという報告がユーザーから寄せられる可能性があります。機能強化されたデータエンジンによって抽出ファイルが変換されます。これにより、サイズの大きな抽出の作成や変換を短時間で行えるようになります。

    抽出が .tde 形式から新しい .hyper 形式にアップグレードされるタイミングについては、次の表を参照してください。この黒い円は、抽出が .hyper 形式にアップグレードされることを示しています。詳しくは、Tableau ヘルプの「何が抽出のアップグレードを引き起こすか」を参照してください。

    Tableau Desktop のファイル変換に関する考慮事項の詳細については、Tableau Desktop のアップグレードページを参照してください。

      Tableau Bridge Tableau データ抽出コマンドラインユーティリティ Tableau Online
    10.4 以前 10.5 以降 10.4 以前 10.5 以降
    抽出の完全更新
    抽出の増分更新
    抽出へのデータの追加

    上記の動作について

    具体的にどのようなことを意味しているのかについて説明します。以下のポイントを確認して、何が起きているのかを理解し、Tableau ユーザーに対処方法を伝える上で役立ててください。
  • Tableau Online によって実行される更新処理では、.tde 形式の抽出が必ず .hyper 形式にアップグレードされます。
  • 抽出を更新しても、すぐにすべての .tde ファイルが .hyper 形式にアップグレードされない場合があります。これは、Tableau Online で .hyper 形式への移行中に想定される動作です。
  • 抽出が新しい .hyper 形式にアップグレードされると、その変更を元に戻すことはできません。つまり、アップグレードした抽出を .tde 形式に変換し直すことはできず、アップグレード済みの抽出は Tableau 10.4 (およびそれ以前) のデータエンジンで読み込むことはできなくなります。
  • 10.4 (またはそれ以前のバージョン) のクライアント (Tableau Bridge、Tableau データ抽出コマンドラインユーティリティ、API など) を使用してデータソースの完全更新を実行した後: 更新を実行しても、抽出は .tde 形式のまま維持されます。また、Tableau Desktop 10.4 (およびそれ以前のバージョン) を使用して、パブリッシュされたデータソースに接続して開くことができます。
  • Tableau Bridge 10.4 (またはそれ以前のバージョン) を使用してデータソースの増分更新を実行した後: 更新を実行すると、抽出は .hyper 形式で保存されます。ただし、この更新済みのデータソースは、Tableau Desktop 10.4 およびそれ以前のバージョンを使用して開くことはできなくなります (増分更新か完全更新かは関係ありません)。また、Tableau Desktop 10.4 (およびそれ以前のバージョン) を使用してデータソースをダウンロードして開いた後、抽出の場所を指定して再生成するように求められます。抽出を再作成する方法については、「抽出のアップグレード後」を参照するようにユーザーに伝えてください。
  • 10.4 (またはそれ以前のバージョン) のクライアント (Tableau データ抽出コマンドラインユーティリティ、API など) を使用してデータソースの増分更新を実行した後: 更新を実行することができ、抽出は .hyper 形式で保存されます。Tableau Desktop 10.4 (およびそれ以前のバージョン) を使用してデータソースをダウンロードして開いた後、抽出の場所を指定して再生成するよう求められることに注意してください。抽出を再作成する方法については、「抽出のアップグレード後に予測されること」を参照するようにユーザーに伝えてください。

  • 抽出がいつ変換されたのかを知る方法

    どの抽出が影響を受けるかについて具体的に確認するには、管理ビューを使用してジョブタイプでフィルターします。詳細については、抽出でのバックグラウンドタスクを参照してください。

    「TdeRefreshExtract」および「TdeIncrementalExtract」でタスクをフィルターすると、現在 .tde 形式で今後 .hyper 形式にアップグレードされるすべての抽出が識別できます。

    抽出の互換性に関するシナリオ

    Tableau Online のユーザーから、抽出を操作する際に特定のアクションを実行できないという報告があった場合は、抽出の互換性の問題が発生している可能性があります。

    次の表は、ユーザーの視点から見たシナリオの例を示しており、抽出に関係する特定のアクションが実行されたときに、Tableau Online のバックグラウンドで何が起こっているかを説明しています。

    以下に説明するワークブックに関する動作は、パブリッシュされたデータソースについても同様です。


      ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
    Tableau Online および Desktop のユーザーがワークブックまたは抽出を Tableau Online にパブリッシュ
     
    • このワークブックまたは抽出はパブリッシュできます
    • 抽出は .tde 形式のままです
    • このワークブックまたは抽出はパブリッシュできます
    • 抽出は .tde 形式のままです
    • このワークブックまたは抽出はパブリッシュできます
    • 抽出は .hyper 形式で保存されます

      ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
    Tableau Online および Desktop のユーザーがワークブックを Web 編集し、Tableau Online に保存
    (Tableau Online にパブリッシュした後)
     

    Tableau Online では更新も追加も行われません

    • このワークブックを Web 編集できます
    • Tableau Desktop 10.4 以前のバージョンでダウンロードして開くことはできなくなります。ただし、このワークブックを以前のバージョンの形式にエクスポートすることはできます。
    • 抽出は .tde 形式のままです
    • このワークブックを Web 編集できます
    • 抽出は .tde 形式のままです
    • このワークブックを Web 編集できます
    • 抽出は .hyper 形式のままです
     

    Tableau Online での抽出の更新または追加

    • このワークブックを Web 編集できます
    • 次に更新が実行されると、抽出は .hyper 形式で保存されます
    • 注: ワークブックを編集せずに更新/追加を実行した場合、抽出はアップグレードされず、.tde 形式のままとなります。これは、Tableau Online で .hyper 形式への移行中に想定される動作です。
    • このワークブックを Web 編集できます
    • 抽出は .hyper 形式で保存されます
    • このワークブックを Web 編集できます
    • 抽出は .hyper 形式のままです

      ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
    Tableau Online および Desktop のユーザーがワークブックと抽出をダウンロードして開く
     

    Tableau Desktop 10.4 (およびそれ以前のバージョン) を使用

    • このワークブックをダウンロードして共有できます。ワークブックを Web 編集した後、Tableau Desktop 10.4 以前のバージョンでダウンロードして開くことはできなくなります。
    • ワークブックを編集せずに更新/追加を実行した場合、Tableau Desktop 10.4 を使用してワークブックをダウンロードして開いた後、抽出の場所を指定して再生成するように求められることがあります。抽出を再作成する方法については、「抽出のアップグレード後に予測されること」を参照してください。
    • このワークブックを以前のバージョンの形式にエクスポートできます。
    ワークブックまたは抽出を操作することはできません。詳しくは、こちらのナレッジベースの記事を参照してください。 ワークブックまたは抽出を操作することはできません。詳しくは、こちらのナレッジベースの記事を参照してください。
     

    Tableau Desktop 10.5 (およびそれ以降のバージョン) を使用

    • このワークブックおよび抽出をダウンロードして開くことができます。
    • 古いバージョンの Tableau Desktop によるワークブックの編集やダウンロードに関して問題が発生する場合は、以下のナレッジベースの記事を参照してください。
    • このワークブックおよび抽出をダウンロードして開くことができます。
    • 古いバージョンの Tableau Desktop によるワークブックの編集やダウンロードに関して問題が発生する場合は、以下のナレッジベースの記事を参照してください。
    • このワークブックおよび抽出をダウンロードして開くことができます。
    • 古いバージョンの Tableau Desktop によるワークブックの編集やダウンロードに関して問題が発生する場合は、以下のナレッジベースの記事を参照してください。

      ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
    Tableau Online ユーザーが Tableau Desktop の [バージョン名を付けてエクスポート] を使用して、対応するバージョン (またはそれ以降のバージョン) の Tableau でワークブックを開く
      ワークブックで .tde 形式の抽出が使用されている場合、このワークブックをエクスポートして開き、対応するバージョン (またはそれ以降のバージョン) の形式で抽出できます。 ワークブックで .tde 形式の抽出が使用されている場合、このワークブックをエクスポートして開き、対応するバージョン (またはそれ以降のバージョン) の形式で抽出できます。 このデータソースで .hyper 形式の抽出が使用されているため、このアクションは実行できません。オプションが淡色表示されます。詳しくは、こちらのナレッジベースの記事 を参照してください。**
     
    ** Tableau Online で以前のバージョンとしてダウンロードするオプションを使用すると、このワークブックを以前のバージョンの形式でダウンロードできます (ワークブックを Tableau Desktop 10.4 およびそれ以前のバージョンで開くことができます)。ただし、.hyper 形式の抽出が使用されている場合、パッケージドワークブックファイルにその抽出が含まれ、そのファイルは以前のバージョンの Tableau Desktop では読み取れないことに注意してください。

    Tableau Desktop 10.5 以降で作成された抽出に対して Tableau Desktop 10.4 以前のバージョンでなんらかのアクションを実行すると、エラーメッセージが表示されます。詳しくは、こちらのナレッジベースの記事を参照してください。

    Tableau Online に固有の情報

    Tableau Bridge、Tabcmd、API 2.0、Tableau データ抽出コマンドラインユーティリティ
  • Tableau Desktop の新しいメジャーバージョンをインストールすると、最新の Tableau Bridge クライアントがインストールされます。Tableau Bridge のアップグレードのタイミングについては、こちらの記事を参照してください。
  • Tabcmd で .hyper 形式の抽出をパブリッシュまたは操作するには、Tabcmd 10.5 以降が必要です。詳しくは、Tableau ヘルプの「tabcmd のインストール」を参照してください。
  • データ抽出 API 2.0 を使用すると、新しい .hyper 形式の抽出を開くことや作成することができます。データ抽出 API 2.0 では、.tde 形式の抽出を作成できないことに注意してください。
  • データ抽出 API 2.0 には、Server API は含まれなくなりました。抽出のパブリッシュには REST API を使用してください。
  • Tableau Bridge と同じように、Tableau データ抽出コマンドラインユーティリティでも抽出が .hyper 形式に変換されます。このトピックの詳細については、Tableau ヘルプの「Tableau データ抽出コマンドラインユーティリティ」を参照してください。
  • Tableau Online のポッドの移行

    Tableau は、第 1 世代の Tableau Online ポッドを移すことにより、AWS 上での導入のフットプリントを拡張しています。このように AWS へ移行することにより、安定性とパフォーマンスに対してお客様が求める要求を継続的に満たすことが可能になります。
    さらに、これによってイノベーションに注力するための自由が与えられます。インフラストラクチャ管理の負荷を AWS の専門家に任せることで、私たちは今日の市場で最高の分析プラットフォームの提供に注力し続けることができます。

    Tableau Online のお客様で、サイトが既存のポッド (10AY/10AZ) 内にある場合、お客様のサイトは移行されます。

    ポッドのサービス停止とポッドの移行の詳細については、こちらをクリックしてください。

    Tableau Online のポッドがダウンしている場合の対応方法

    • trust.tableau.com で、Tableau Online が予定のメンテナンス中ではないか確認してください。
    • サービスが稼働中であり、Tableau サポートによるアラートバナー (tableau.com/ja-jp/support ページの上部) が表示されていない場合は、テクニカルサポートチームに連絡してください (エラー内容をご説明ください)。
    • 更新情報や Tableau Online に予期しない影響が及ぶ場合のお知らせについては、Tableau サポートチームの Twitter アカウント (@TableauSupport) を確認してください。

    Tableau Online のポッドのメンテナンスや移行予定を確認する方法

    • メンテナンス予定については、その情報を通知するメールが送信されているはずです。
    • そのメールの宛先は Tableau Online 管理者であり、件名に次の情報が含まれています。Tableau Online ポッド名 停止予定: 日付

    Tableau Online のアップグレード後に何らかの問題に気付いた場合の対処法

    Tableau Online のアップグレード後に、管理者およびユーザーが異常な動作に気づいた場合は、以下のガイドラインに従ってください。

    • 機能が変更されていることを確認します。Tableau Online の新機能ページには、機能が変更されたことが記載されているはずです。
    • その異常な動作について、Tableau ナレッジベースを検索し、回避策があるかどうか確認します。
    • 上記のいずれによっても解決できない場合は、テクニカルサポートチームに連絡してください (エラー内容をご説明ください)。

    ポッド名を知る方法

    • Tableau Online サイトにアクセスすると、その URL にポッド名が含まれています。たとえば次のようになります。 10ay.online.tableau.com/#/site/sitename
    • Tableau Online 管理者は、メンテナンスに関する通知メールを受領します。そのメールには、サイトが属しているポッド名が記載されており、件名には以下の情報が含まれています。Tableau Online ポッド名 停止予定: 日付



    認証が必要な新しい AWS ポッドの IP アドレス

    近日中に発売される新しい AWS ポッド用に新規の IP アドレスを追加しました。クラウドデータプロバイダーはセキュリティ対策として、認証済みの IP アドレスのリストの提出を求める場合があります。外部アプリケーションはこの IP アドレスに基づいてユーザーのデータにアクセスを要求します。明示的に承認されていない IP アドレスからの要求は却下される可能性があります。

    Tableau Online にパブリッシュしているライブ接続が途切れないようにするには、新しい IP アドレスを認証済み IP アドレスのリストに追加してください。Tableau Online の IP アドレスの詳細については、Tableau ヘルプのデータプロバイダー認可用 Tableau Online IP アドレスを参照してください。

    その他のリソース

    サポートを受ける

    セルフサービス型リソース
    テクニカルサポート
  • サポートケースをオープン。ケース作成時は次の情報をご提供くださいますようお願いいたします。ご提供いただく情報によって、サポートにかかる時間が短縮される場合があります。