Tableau Desktop 10.5 へのアップグレード

Tableau Desktop 10.5 へのアップグレードをお考えですか。このページから始めましょう。

情報の収集

概要

Tableau 10.5 で、データ分析をワンランク上に進化させることができます。詳細はここからご覧ください。

新機能

新しい .hyper という抽出の形式や機能が強化されたデータエンジンから、ツールヒント Viz や Tableau Desktop の大規模導入に関する機能強化まで、Tableau 10.5 には多数の新機能があります。アップグレードの前に、10.5 の新機能をお確かめください。

Hyper は、大規模または複雑なデータセットの最速のデータインジェストと分析クエリ処理に最適化された、Tableau の新しいインメモリデータエンジンテクノロジーです。Hyper の導入により、抽出に関する数多くの変更点があります。Tableau 10.5 以降、新しい抽出に .tde の代わりに .hyper ファイル形式が使用されます。

以下のセクションに、何をすると .tde の抽出が .hyper にアップグレードされるのか、起こり得る一般的な問題、Tableau 製品のアップグレード後の互換性に関する重要な注意点が説明されています。アップグレード計画の一環としてこのコンテンツをご確認ください。

.hyper 形式への抽出ファイルの変換

Tableau Desktop、Tableau Server、または Tableau Online のアップグレード後に、抽出やワークブックで新しい問題または現象が発生することがあります。特定のアクションを実行すると、既存の .tde 形式の抽出が新しい .hyper 形式の抽出に変更されます。

作業内容の更新、パブリッシュ、または他のユーザーとの共有を行う場合、考慮すべきことがいくつかあります。

  • 抽出が新しい .hyper 形式にアップグレードされると、その変更を元に戻すことはできません。つまり、アップグレードした抽出を .tde 形式に変換し直すことはできず、アップグレード済みの抽出を Tableau 10.5 より前のバージョンの Tableau Desktop で開くことはできなくなります。
  • アップグレード済みの抽出には後方互換性はありません。組織内の Tableau Server およびすべての Tableau Desktop を同じバージョンに揃え、同じスケジュールで 10.5 にアップグレードすることをお勧めします。
  • 互換性の問題については、次のページを参照してください。 Desktop と Server の互換性

    次の表は、.tde 形式が新しい .hyper 形式に変換されるきっかけとなるアクションを示しています。この黒い円は、抽出が .hyper 形式に変換されることを示しています。



      Tableau Desktop
    10.4 以前 10.5 以降
    抽出の完全更新
    抽出へのデータの追加
    抽出を手動でアップグレード

抽出の互換性のシナリオ - Tableau Desktop と Tableau Reader

Tableau Desktop と Tableau Reader の間での抽出の互換性について詳しくは、次の表を参照してください。

  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Reader および Tableau Desktop 10.4 以前を使用してワークブックを開く このワークブックを開くことができます。 ワークブックまたは抽出を操作することはできません。詳しくは、こちらのナレッジベースの記事を参照してください。 ワークブックまたは抽出を操作することはできません。詳しくは、こちらのナレッジベースの記事を参照してください。
Tableau Reader および Tableau Desktop 10.5 以降を使用してワークブックを開く このワークブックを開くことができます。これはバージョン管理の正常な動作であり、抽出はこのシナリオには影響しません。 このワークブックを開くことができます。これはバージョン管理の正常な動作であり、抽出はこのシナリオには影響しません。 このワークブックを開くことができます。これはバージョン管理の正常な動作であり、抽出はこのシナリオには影響しません。

抽出の互換性のシナリオ - Tableau Desktop と Tableau Server

次の表は、ユーザーの視点から見たシナリオの例を示しており、抽出に関係する特定のアクションが実行されたときに、Tableau Server のバックグラウンドで何が起こるかを説明しています。

Tableau Server のアップグレードの詳細については、Tableau Server 管理者向けの各リソースページを参照してください。

以下に説明するワークブックに関する動作は、パブリッシュされたデータソースについても同様です。

  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Server および/または Desktop のユーザーがワークブックまたは抽出をパブリッシュ
 

パブリッシュ先が Tableau Server 10.4 以前

  • このワークブックまたは抽出はパブリッシュできます
  • 抽出は .tde 形式のままです
  • エラーが表示されます。詳しくは、こちらのナレッジベースの記事を参照してください。
  • Tableau Server 10.4 以前では、すべての対応する Tableau Server のバージョンと互換性があります。
エラーが表示されます。詳しくは、こちらのナレッジベースの記事を参照してください。
 

パブリッシュ先が Tableau Server 10.5 以降

  • このワークブックまたは抽出はパブリッシュできます
  • 抽出は .tde 形式のままです
  • このワークブックまたは抽出はパブリッシュできます
  • 抽出は .tde 形式のままです
  • このワークブックまたは抽出はパブリッシュできます
  • 抽出は .hyper 形式で保存されます
  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Server および/または Desktop のユーザーが Web 編集し、Tableau Server に保存
(Tableau Server にパブリッシュした後)
 

Tableau Server では更新も追加も行われません

  • このワークブックを Web 編集できます。
  • どのバージョンの Tableau Server でも、抽出は .tde 形式のままです。
  • このワークブックを Web 編集できます。
  • Tableau Server 10.5 以降では、抽出は .tde 形式のままです。
  • このワークブックを Web 編集できます。
  • 抽出は .hyper 形式で保存されます
 

Tableau Server での抽出の更新または追加

  • このワークブックを Web 編集できます。
  • Tableau Server 10.4 以前では、抽出は .tde 形式のままです。
  • Tableau Server 10.5 以降では、ワークブックの編集または抽出の追加を行った後、抽出は新しい .hyper 形式に変換されます。
  • このワークブックを Web 編集できます。
  • Tableau Server 10.5 以降では、抽出は新しい .hyper 形式に変換されます。
  • このワークブックを Web 編集できます。
  • 抽出は .hyper 形式で保存されます
  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Server および Desktop のユーザーがワークブックと抽出をダウンロードして開く
 

Tableau Desktop 10.4 (およびそれ以前のバージョン) を使用

  • このワークブックをダウンロードして開くことができます。
  • Tableau Server 10.4 以前では、すべての対応する Tableau Server のバージョンと互換性があります。
  • Tableau Server 10.5 以降では、ワークブックを開けますが、抽出を使用することはできません。詳しくは、こちらのナレッジベースの記事を参照してください。
すべてのバージョンの Tableau Server で、エラー メッセージが表示されます。詳しくは、こちらのナレッジベースの記事を参照してください。 すべてのバージョンの Tableau Server で、エラーが発生します。詳しくは、こちらのナレッジベースの記事を参照してください。
 

Tableau Desktop 10.5 (およびそれ以降のバージョン) を使用

このワークブックをダウンロードして開くことができます。 抽出は .hyper 形式の抽出としてパブリッシュされているため、このワークブックをダウンロードして Tableau Server 10.5 で開くことができます。 抽出は .hyper 形式の抽出としてパブリッシュされているため、このワークブックをダウンロードして Tableau Server 10.5 で開くことができます。
  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Server ユーザーが Tableau Desktop の [バージョン名を付けてエクスポート] を使用して、対応するバージョン (またはそれ以降のバージョン) の Tableau でワークブックを開く
 
  • ワークブックで .tde 形式の抽出が使用されている場合、このワークブックをエクスポートして開き、対応するバージョン (またはそれ以降のバージョン) の形式で抽出できます。
  • ワークブックを Tableau Server 10.5 (以降) で編集して保存した後、このワークブックと抽出をダウンロードして対応するバージョン (またはそれ以降のバージョン) の Tableau で開くことができます。
ワークブックで .tde 形式の抽出が使用されている場合、このワークブックをエクスポートして開き、対応するバージョン (またはそれ以降のバージョン) の形式で抽出できます。 このデータソースは .hyper 形式の抽出を使用しているため、ワークブックを古いバージョンの Tableau 用にエクスポートすることはできません。詳しくは、こちらのナレッジベースの記事を参照してください。
 

Tableau Desktop 10.5 以降で作成された抽出に対して Tableau Desktop 10.4 以前のバージョンでなんらかのアクションを実行すると、エラーメッセージが表示されます。詳しくは、こちらのナレッジベースの記事を参照してください。

抽出の互換性のシナリオ - Tableau Desktop と Tableau Online

次の表は、ユーザーの視点から見たシナリオの例を示しており、抽出に関係する特定のアクションが実行されたときに、Tableau Online のバックグラウンドで何が起こるかを説明しています。

Tableau Online のアップグレードの詳細については、Tableau Online 管理者向けの各リソースページを参照してください。

以下に説明するワークブックに関する動作は、パブリッシュされたデータソースについても同様です。


  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Online および Desktop のユーザーがワークブックまたは抽出を Tableau Online にパブリッシュ
 
  • このワークブックまたは抽出はパブリッシュできます
  • 抽出は .tde 形式のままです
  • このワークブックまたは抽出はパブリッシュできます
  • 抽出は .tde 形式のままです
  • このワークブックまたは抽出はパブリッシュできます
  • 抽出は .hyper 形式で保存されます
  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Online および Desktop のユーザーがワークブックを Web 編集し、Tableau Online に保存
(Tableau Online にパブリッシュした後)
 

Tableau Online では更新も追加も行われません

  • このワークブックを Web 編集できます
  • Tableau Desktop 10.4 以前のバージョンでダウンロードして開くことはできなくなります。ただし、このワークブックを以前のバージョンの形式にエクスポートすることはできます。
  • 抽出は .tde 形式のままです
  • このワークブックを Web 編集できます
  • 抽出は .tde 形式のままです
  • このワークブックを Web 編集できます
  • 抽出は .hyper 形式のままです
 

Tableau Online での抽出の更新または追加

  • このワークブックを Web 編集できます
  • 次に更新が実行されると、抽出は .hyper 形式で保存されます
  • 注: ワークブックを編集せずに更新/追加を実行した場合、抽出はアップグレードされず、.tde 形式のままとなります。
  • このワークブックを Web 編集できます
  • 抽出は .hyper 形式で保存されます
  • このワークブックを Web 編集できます
  • 抽出は .hyper 形式のままです
  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Online および Desktop のユーザーがワークブックと抽出をダウンロードして開く
 

Tableau Desktop 10.4 (およびそれ以前のバージョン) を使用

  • このワークブックをダウンロードして共有できます。ワークブックを Web 編集した後、Tableau Desktop 10.4 以前のバージョンでダウンロードして開くことはできなくなります。
  • ワークブックを編集せずに更新/追加を実行した場合、Tableau Desktop 10.4 を使用してワークブックをダウンロードして開いた後、抽出の場所を指定して再生成するように求められることがあります。抽出を再作成する方法については、「抽出のアップグレード後」を参照してください。
  • このワークブックを以前のバージョンの形式にエクスポートできます。
ワークブックまたは抽出を操作することはできません。詳しくは、こちらのナレッジベースの記事を参照してください。 ワークブックまたは抽出を操作することはできません。詳しくは、こちらのナレッジベースの記事を参照してください。
 

Tableau Desktop 10.5 (およびそれ以降のバージョン) を使用

このワークブックおよび抽出をダウンロードして開くことができます。 このワークブックおよび抽出をダウンロードして開くことができます。 このワークブックおよび抽出をダウンロードして開くことができます。
  ワークブックと抽出を Tableau Desktop 10.4 以前で作成 10.4 の抽出を使って Tableau Desktop 10.5 でワークブックを作成 ワークブックと抽出を Tableau Desktop 10.5 以降で作成
Tableau Online ユーザーが Tableau Desktop の [バージョン名を付けてエクスポート] を使用して、対応するバージョン (またはそれ以降のバージョン) の Tableau でワークブックを開く
  ワークブックで .tde 形式の抽出が使用されている場合、このワークブックをエクスポートして開き、対応するバージョン (またはそれ以降のバージョン) の形式で抽出できます。 ワークブックで .tde 形式の抽出が使用されている場合、このワークブックをエクスポートして開き、対応するバージョン (またはそれ以降のバージョン) の形式で抽出できます。 このデータソースで .hyper 形式の抽出が使用されているため、このアクションは実行できません。オプションが淡色表示されます。詳しくは、こちらの詳しくは、こちらのナレッジベースの記事を参照してください。**
 
** Tableau Online で以前のバージョンとしてダウンロードするオプションを使用すると、このワークブックを以前のバージョンの形式でダウンロードできます (ワークブックを Tableau Desktop 10.4 およびそれ以前のバージョンで開くことができます)。ただし、.hyper 形式の抽出が使用されている場合、パッケージドワークブックファイルにその抽出が含まれ、そのファイルは以前のバージョンの Tableau Desktop では読み取れないことに注意してください。

Tableau Desktop 10.5 以降で作成された抽出に対して Tableau Desktop 10.4 以前のバージョンでなんらかのアクションを実行すると、エラーメッセージが表示されます。詳しくは、こちらのナレッジベースの記事を参照してください。

パブリッシュ

  • .hyper 形式の抽出を含むワークブックを以前のバージョンの Tableau Server にパブリッシュできなくなり、パブリッシュするためのダイアログで赤い感嘆符のマークが表示されます。
  • Tableau Desktop は、同じバージョンまたはそれ以降のバージョンの Tableau Server にのみパブリッシュできます。Tableau Server の古いバージョン (10.2 以降) にワークブックをパブリッシュすると、パブリッシュ先のサーバーのバージョンに合わせてワークブックがダウングレードされることを伝えるメッセージではなく、警告メッセージが表示されます。詳しくは、Tableau ヘルプの「Tableau Server の古いバージョンにダウングレードおよびワークブックをパブリッシュする」を参照してください。
  • パブリッシュ先の Tableau Server の方が新しいバージョンの場合、ワークブックのバージョンは、Tableau Server のバージョンにアップグレードされません。ただし、そのワークブックを Web 編集を使って編集してから上書き保存するか、ワークブックの抽出を更新すると、ワークブックがアップグレードされます。ダウンロードした場合、アップグレードされたワークブックを以前のバージョンの Tableau Desktop で開くことはできません。
  • ワークブックを Tableau Server または Tableau Online にパブリッシュした後、アップグレード済みの .hyper 形式の抽出が使用されているビューで問題が発生することがあります。発生することのある問題としては、ビューに表示されるマークが少なくなる、ビューで別の形状が使用される、ビューが空白になる、などがあります。これらの問題のトラブルシューティング方法については、Tableau ヘルプの「ビュー内の値およびマークの変更」を参照してください。
  • 最新バージョンの Tableau Desktop を使用していて、Tableau Server がまだアップグレードされていない場合は、Tableau Desktop から互換性のあるファイルをパブリッシュできます (Tableau Server 10.2 以降に対応)。詳しくは、「Tableau ヘルプ」をご覧ください。
  • 以前のバージョンの Tableau Server をご使用の場合、データを引き続き共有できるように、製品バージョンを確認してください。
  • その他のリソース

    他のユーザーとワークブックを共有する場合、
    他のユーザーがワークブックを開くのに使用するバージョンがわかっていれば、Tableau Desktop 10.5 の [バージョン名を付けてエクスポート] オプションを使用できます。これにより、最新バージョンの Tableau Desktop を使用していないユーザーでも、ワークブックを開いて編集できるようになります (Tableau 10.2 以降に対応)。

    ワークブックをパブリッシュする際にエラーが発生することがあります。詳しくは、こちらのナレッジベースの記事を参照してください。

    まずテストしてください。
    期待通りの動作が得られるように、 既知の問題 を読んでから Tableau Desktop 10.5 をインストールしてください。
  • 同じコンピューター上に複数のバージョンの Tableau Desktop をインストールすることができます。インストールされている最も新しいバージョンが 10.5 の場合、これが既定のバージョンになります。
  • 既定のバージョンを変更する場合は、次の手順に従ってください: Tableau Desktop のアップグレード
  • 新しいコンピューターにインストールする場合は、
    そのコンピューターにライセンスを移行する必要があります。詳しくは、Tableau ヘルプの「Tableau Desktop のアップグレード」および「Tableau Desktop の移動または非アクティブ化」を参照してください。
    技術仕様を確認する
    Tableau 10.5 から、Tableau の新しいバージョンは 64 ビットのオペレーティングシステムでのみ動作します。対象製品の詳細や、32 ビット版の Tableau Desktop、Tableau Reader、Tableau Public をインストールしているかどうかを確認するには、リソースページをご覧ください。
    Tableau Desktop 10.0 のリリース後、Windows Vista、Internet Explorer 10.1 以前、OS X Mavericks はサポートされていない点にご注意ください。最新の技術仕様をご覧ください。
    修正点をご覧ください。
    この新しいメンテナンスリリースでの修正点を確認するには、リリースノートを参照してください。

    ヘルプの利用

    セルフサービス型リソース
    テクニカルサポート
    コンサルティングサービス
    Tableau のコンサルタントが新機能を最大限に活用する方法をご紹介し、データの価値を引き出すお手伝いをします。