Assistance

Téléchargement de pilote

Recherchez le pilote pour votre base de données afin de connecter les produits Tableau à vos données.

Pour obtenir le pilote adéquat, vous devrez peut-être connaître la version de votre produit Tableau. Dans Tableau Desktop, sélectionnez Aide > À propos de Tableau. Dans Tableau Server, cliquez sur l'icône d'information Icône d'information et sélectionnez À propos de Tableau Server.

Actian Matrix (ParAccel)
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote Windows pour Actian Matrix :

  1. Accédez au site Actian et ouvrez une session.
  2. Dans la zone Select Via Product (sélectionner par produit), choisissez ce qui suit :
    • Sous Product (produit) : Actian Matrix Drivers (pilotes Actian Matrix)
    • Sous Release (version) : ODBC
  3. Dans la liste qui s'affiche, sélectionnez le pilote ODBC le plus récent qui correspond à votre plate-forme et à la version de votre système.
  4. Téléchargez et installez les pilotes.
Ressources
Actian Vector
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote Windows pour Actian Vector :

  1. Accédez au site Actian et ouvrez une session.
  2. Dans la zone Select Via Product (sélectionner par produit), choisissez ce qui suit :
    • Sous Product (produit) : Actian Ingres Drivers (pilotes Actian Ingres)
    • Sous Release (version) : ODBC
  3. Dans la liste qui s'affiche, sélectionnez le pilote ODBC le plus récent qui correspond à votre plate-forme et à la version de votre système.
  4. Téléchargez et installez les pilotes.
Ressources
Amazon Aurora
Tableau Desktop & Tableau Server: 9.0.4 - 10.2.2

Amazon Aurora utilise des pilotes MySQL. Si vous n'avez pas installé de pilotes MySQL, procédez comme suit afin d'installer le pilote Windows pour MySQL :

  1. Accédez au site MySQL.
  2. Sur la page Download Connector/ODBC (télécharger le connecteur/ODBC), sélectionnez le pilote correspondant à votre plate-forme et à la version de votre système.
  3. Téléchargez et installez le pilote.
Ressources
Tableau Desktop: 9.3 - 10.2.2

Amazon Aurora uses MySQL drivers. The MySQL Windows driver is installed by default with Tableau Desktop.

Resources
Tableau Desktop: 9.0.4 - 10.2.2
Télécharger la version mac

Amazon Aurora utilise des pilotes MySQL. Si vous n'avez pas installé de pilotes MySQL, procédez comme suit afin d'installer le pilote Mac pour MySQL :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé TableauDrivers.dmg.
  4. Cliquez deux fois sur le fichier MySQL Connector ODBC 5.3.pkg pour exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Amazon Aurora.
Ressources
Tableau Desktop: 9.0.4 - 9.2

Amazon Aurora uses MySQL drivers. If you don't have MySQL drivers installed, follow these steps to install the Windows driver for MySQL:

  1. On the MySQL website, review the prerequisites for installing the Connector/ODBC drivers on Windows. Make sure the prerequisite software is installed on your computer.
  2. On the Download Connector/ODBC page, select the driver for your platform and bit version.
  3. Download and install the driver.
Resources
Amazon EMR
Tableau Desktop & Tableau Server: 8.2.7 - 8.2.x, 8.3.2 - 10.2.2

Procédez comme suit pour installer les pilotes Windows pour Amazon EMR :

  1. Accédez au site Amazon Web Services.
  2. Sélectionnez le fichier .zip ODBC pour votre environnement : 
    • Pour Hive : AmazonHiveODBC_.zip
    • Pour Impala : ImpalaODBC.zip
  3. Téléchargez et installez les pilotes.
Ressources
Tableau Desktop: 8.2.7 - 8.2.x, 8.3.2 - 10.2.2

Installation des pilotes pour le service Web Amazon EMR : Hive ou Impala

Hive – Procédez comme suit pour installer les pilotes d'Amazon EMR Hive sur votre ordinateur Mac :

  1. Assurez-vous que l'administrateur ODBC est installé sur votre système. Vous pouvez le télécharger depuis le site d'Apple : https://support.apple.com/kb/DL895?locale=fr_FR. Maintenez la touche CTRL enfoncée et cliquez sur le fichier .dmg téléchargé pour l'installer.
  2. Accédez à la page Web d'Amazon Elastic MapReduce et cliquez sur le lien de téléchargement du fichier HiveODBC.zip.
  3. Cliquez deux fois sur le fichier téléchargé, puis accédez au dossier Mac OS X et ouvrez-le.
  4. Cliquez deux fois sur le fichier AmazonHiveODBC.dmg.
  5. Cliquez deux fois sur le fichier AmazonHiveODBC.pkg et acceptez les paramètres par défaut.
  6. Depuis le Finder, sélectionnez Utilitaires, puis ouvrez l'administrateur ODBC.
  7. Sélectionnez l'onglet Pilotes, puis cliquez sur Ajouter.
  8. Dans le champ Description, saisissez Pilote ODBC Amazon Hive.
  9. Dans le champ de fichier Pilote, choisissez ou saisissez /opt/amazon/hiveodbc/lib/universal/libamazonhiveodbc.dylib.
  10. Cliquez sur OK, puis sur Appliquer, et fermez l'administrateur ODBC.
  11. Fermez la session, puis rouvrez une session sur votre Mac.
  12. Ouvrez Tableau Desktop et connectez-vous à Amazon EMR.

Impala – Procédez comme suit pour installer les pilotes d'Amazon EMR Impala sur votre ordinateur Mac :

  1. Assurez-vous que l'administrateur ODBC est installé sur votre système. Vous pouvez le télécharger depuis le site d'Apple : https://support.apple.com/kb/DL895?locale=fr_FR. Maintenez la touche CTRL enfoncée et cliquez sur le fichier .dmg téléchargé pour l'installer.
  2. Accédez à la page Web d'Amazon Elastic MapReduce et cliquez sur le lien de téléchargement du fichier ImpalaODBC.zip.
  3. Cliquez deux fois sur le fichier téléchargé, puis accédez au dossier Mac OS X et ouvrez-le.
  4. Cliquez deux fois sur le fichier AmazonImpalaODBC.dmg.
  5. Cliquez deux fois sur le fichier AmazonImpalaODBC.pkg et acceptez les valeurs par défaut.
  6. Depuis le Finder, sélectionnez Utilitaires, puis ouvrez l'administrateur ODBC.
  7. Sélectionnez l'onglet Pilotes, puis cliquez sur Ajouter.
  8. Dans le champ Description, saisissez Pilote ODBC Amazon Impala.
  9. Dans le champ de fichier Pilote, choisissez ou saisissez /opt/amazon/impalaodbc/lib/universal/libamazonimpalaodbc.dylib.
  10. Cliquez sur OK, puis sur Appliquer, et fermez l'administrateur ODBC.
  11. Fermez la session, puis rouvrez une session sur votre Mac.
  12. Ouvrez Tableau Desktop et connectez-vous à Amazon EMR.
Ressources
Amazon Redshift
Tableau Desktop & Tableau Server: 8.2.9 - 8.2.x, 8.3.4 - 9.2.x

Procédez comme suit pour installer le pilote Windows pour Amazon Redshift :

  1. Accédez au site Amazon Web Services.
  2. Suivez les instructions de la section To install the ODBC driver (pour installer le pilote ODBC).

Notez qu'il n'est pas nécessaire de créer une entrée DSN système pour que le pilote fonctionne avec Tableau.

Ressources
Tableau Desktop & Tableau Server: 8.2.0 - 8.2.8, 8.3.0 - 8.3.3
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Windows 32 bits pour Amazon Redshift.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Windows 64 bits pour Amazon Redshift.

Ressources
Tableau Desktop: 10.2

Le pilote Mac pour Amazon Redshift est installé par défaut avec Tableau Desktop.

Ressources
Tableau Desktop: 9.3 - 10.2.2

Le pilote Amazon Redshift pour Windows est installé par défaut avec Tableau Desktop 9.3 et versions ultérieures.

Ressources
Tableau Desktop: 8.2.9 - 8.2.x, 8.3.4 - 10.1

Procédez comme suit pour installer le pilote Mac pour Amazon Redshift :

  1. Fermez Tableau Desktop.
  2. Téléchargez le fichier AmazonRedshiftODBC.dmg à partir de la page Amazon Redshift sur le site de la documentation d'Amazon.
  3. Cliquez deux fois sur le fichier AmazonRedshiftODBC.dmg téléchargé.
  4. Cliquez deux fois sur le fichier AmazonRedshiftODBC.pkg et acceptez les paramètres par défaut.
  5. Ouvrez Tableau Desktop et connectez-vous à Amazon Redshift.
Ressources
Tableau Desktop: 8.2.0 - 8.2.8, 8.3.0 - 8.3.3
Télécharger la version mac

Procédez comme suit pour installer le pilote Mac pour Amazon Redshift :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé TableauDrivers.dmg.
  4. Cliquez deux fois sur Tableau PostgreSQL Libraries.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Amazon Redshift.
Ressources
Tableau Server: 9.3 - 10.2.2

Pour Tableau Server, procédez comme suit afin d'installer le pilote Windows pour Amazon Redshift :

  1. Accédez au site Amazon Web Services.
  2. Suivez les instructions de la section To install the ODBC driver (pour installer le pilote ODBC).

Notez qu'il n'est pas nécessaire de créer une entrée DSN système pour que le pilote fonctionne avec Tableau.

Ressources
Anaplan
Tableau Desktop & Tableau Server: 10.1.2

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: 10.1.2

Il n'est pas obligatoire d'installer un pilote.

Ressources
Apache Drill
Tableau Desktop & Tableau Server: 10.2

Procédez comme suit afin d'installer le pilote Windows pour Apache Drill :

  1. Accédez au site Web d'Apache Drill.
  2. Suivez les instructions de téléchargement et d'installation du pilote ODBC MapR Drill sur Windows.

Remarque : à partir de la version Tableau 10.2, vous n'avez plus besoin d'installer ou d'utiliser un fichier TDC.

Ressources
Tableau Desktop: 10.2

Procédez comme suit afin d'installer le pilote Mac pour Apache Drill :

  1. Fermez Tableau Desktop.
  2. Accédez au site Web d'Apache Drill.
  3. Suivez les instructions de téléchargement et d'installation du pilote ODBC MapR Drill sur Mac.
    • Si vous ne parvenez pas à ouvrir le fichier .pkg du pilote avec un double-clic, maintenez la touche CTRL enfoncée en cliquant dessus et choisissez Ouvrir.
    • L'étape 3 indiquée sur le site Web d'Apache Drill est facultative.
  4. Ouvrez Tableau Desktop et connectez-vous à Apache Drill.
Ressources
Aster Database
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Le pilote ODBC Aster 5.x et versions ultérieures est requis pour Aster Database 5.x et versions ultérieures. Le pilote ODBC Aster 4.6.3 est requis pour Aster Database 4.6.x.

Procédez comme suit afin d'installer le pilote Windows pour Aster Database :

  1. Connectez-vous au site Teradata pour accéder aux pilotes Aster.
  2. À la section Aster Client Tools for Windows (outils client Aster pour Windows), sélectionnez le fichier .zip correspondant à votre environnement Windows : 32 ou 64 bits.
  3. Téléchargez et installez les pilotes.
Ressources
Tableau Desktop: 10.2
Télécharger la version mac

Procédez comme suit afin d'installer le pilote Mac pour les bases de données Aster :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes à partir du lien  Télécharger.
  3. Cliquez sur le fichier téléchargé.
  4. Maintenez la touche CTRL enfoncée et cliquez sur le fichier .pkg, puis cliquez sur Ouvrir > Ouvrir pour exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Aster Database.
Ressources
Cisco Information Server
Tableau Desktop & Tableau Server: 9.3.1 - 10.2.2

Procédez comme suit afin d'installer le pilote Windows pour Cisco Information Server :

  1. Sélectionnez votre version de Cisco Information Server :
  2. Connectez-vous au site Cisco.
  3. Sélectionnez le paquet d'installation client (Client Installation Package) le plus récent contenant les pilotes ODBC.
  4. Téléchargez et installez le pilote.
Ressources
Cloudera Hadoop
Tableau Desktop & Tableau Server: Toutes les versions prises en charge

Assurez-vous que vous utilisez les derniers pilotes disponibles. Procédez comme suit afin d'installer le pilote Windows sur Cloudera Hadoop :

  1. Accédez au site Cloudera et ouvrez une session.
  2. Dans la section ODBC and JDBC Drivers (Pilotes ODBC et JDBC), sélectionnez le téléchargement du pilote ODBC compatible avec votre environnement (Hive ou Impala).
  3. Sélectionnez la version de votre système d'exploitation.
  4. Téléchargez et installez les pilotes.

Remarque : n'utilisez pas le pilote ODBC Cloudera Impala 2.5.28. Il n'est pas compatible avec les produits Tableau.

Ressources
Tableau Desktop: Toutes les versions prises en charge

Assurez-vous que vous utilisez les derniers pilotes disponibles. Procédez comme suit afin d'installer le pilote Mac pour Cloudera Hadoop :

  1. Accédez au site Cloudera et ouvrez une session.
  2. Dans la section ODBC and JDBC Drivers (Pilotes ODBC et JDBC), sélectionnez le téléchargement du pilote ODBC compatible avec votre environnement (Hive ou Impala).
  3. Sélectionnez la version de votre système d'exploitation.
  4. Téléchargez et installez les pilotes.

Remarque : n'utilisez pas le pilote ODBC Cloudera Impala 2.5.28. Il n'est pas compatible avec les produits Tableau.

Ressources
DataStax Enterprise
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote Windows pour DataStax Enterprise :

  1. Accédez au site DataStax.
  2. Dans la section Loaders and ODBC/JDBC Drivers (chargeurs et pilotes ODBC/JDBC), sélectionnez le pilote correspondant à votre environnement.
  3. Téléchargez et installez le pilote.
Ressources
EXASolution
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote pour EXASolution :

  1. Accédez au site Exasol.
  2. Dans la section Latest 5.0 Downloads (téléchargements des versions 5.0 les plus récentes), recherchez le pilote ODBC à télécharger, puis recherchez le pilote ODBC correspondant à votre environnement Windows (x86.msi ou x86_64.msi).
  3. Cliquez sur le lient pour télécharger et installer le pilote.
Ressources
Tableau Desktop: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote Mac pour EXASolution :

  1. Fermez Tableau Desktop.
  2. Téléchargez le tout dernier pilote ODBC pour Mac OS à partir du site Web d'Exasol.
  3. Cliquez deux fois sur le fichier .dmg téléchargé.
  4. Cliquez deux fois sur Click to install (Cliquer pour installer) pour installer le pilote.
  5. Ouvrez Tableau Desktop et connectez-vous à EXASolution.
Ressources
Firebird
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Google Analytics
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Google BigQuery
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Google Cloud SQL
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Google Cloud SQL utilise les pilotes MySQL. Si vous n'avez pas installé de pilotes MySQL, procédez comme suit afin d'installer le pilote Windows pour MySQL :

  1. Accédez au site MySQL.
  2. Sur la page Download Connector/ODBC (télécharger le connecteur/ODBC), sélectionnez le pilote correspondant à votre plate-forme et à la version de votre système.
  3. Téléchargez et installez le pilote.
Ressources
Tableau Desktop: 9.3 - 10.2.2

Google Cloud SQL uses MySQL drivers. The MySQL Windows driver is installed by default with Tableau Desktop.

Resources
Tableau Desktop: 8.2 - 9.2

Google Cloud SQL uses MySQL drivers. If you don't have MySQL drivers installed, follow these steps to install the Windows driver for MySQL:

  1. On the MySQL website, review the prerequisites for installing the Connector/ODBC drivers on Windows. Make sure the prerequisite software is installed on your computer.
  2. On the Download Connector/ODBC page, select the driver for your platform and bit version.
  3. Download and install the driver.
Resources
Tableau Desktop: toutes les versions prises en charge
Télécharger la version mac

Google Cloud SQL utilise les pilotes MySQL. Si vous n'avez pas installé de pilotes MySQL, procédez comme suit afin d'installer le pilote Mac pour MySQL :

  1. Fermez Tableau Desktop.
  2. Cliquez sur le lien Télécharger pour télécharger le pilote.
  3. Cliquez deux fois sur le fichier téléchargé TableauDrivers.dmg.
  4. Cliquez deux fois sur le fichier MySQL Connector ODBC 5.3.pkg pour exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Google Cloud SQL.
Ressources
Google Sheets
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Hortonworks Hadoop Hive
Tableau Desktop & Tableau Server: Toutes les versions prises en charge

Assurez-vous que vous utilisez les derniers pilotes disponibles. Procédez comme suit afin d'installer le pilote Hortonworks Hadoop Hive sur votre ordinateur Windows :

  1. Accédez au site Hortonworks.
  2. Dans la section Hortonworks ODBC Driver for Apache Hive (pilote ODBC Hortonworks pour Apache Hive), sélectionnez le pilote correspondant à la version de votre environnement Windows.
  3. Téléchargez et installez le pilote.
Ressources
Tableau Desktop: Toutes les versions prises en charge

Assurez-vous que vous utilisez les derniers pilotes disponibles. Procédez comme suit afin d'installer le pilote Mac pour Hortonworks Hadoop Hive :

  1. Fermez Tableau Desktop.
  2. Accédez au site Hortonworks.
  3. À la section Hortonworks ODBC Driver for Apache Hive (pilote Hortonworks ODBC pour Apache Hive), téléchargez le pilote pour OS X.
  4. Cliquez sur Documentation pour ouvrir Hortonworks Hive ODBC Driver with SQL Connector User Guide (Guide d'utilisation du pilote ODBC Hive d'Hortonworks avec connecteur SQL), et suivez les instructions de la section « Mac OS X Driver » (Pilote Mac OS X), rubrique « Installing the Driver » (Installation du pilote).
  5. Ouvrez Tableau Desktop et connectez-vous à Hortonworks.
Ressources
HP Vertica
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote Windows pour HP Vertica :

  1. Accédez à la page des téléchargements HPE Vertica sur le site Vertica.
  2. Téléchargez et installez la version la plus récente du pilote ODBC pour Windows.
Ressources
Tableau Desktop: Toutes les versions prises en charge

Installation du pilote Mac pour votre version de HP Vertica :

HP Vertica 7.1 et version ultérieure : procédez comme suit pour installer le pilote Mac correspondant à HP Vertica (version 7.1 ou ultérieure).

  1. Fermez Tableau Desktop.
  2. Téléchargez le pilote ODBC pour Mac à partir de la page HP Vertica Downloads (téléchargements HP Vertica) du site Web de Vertica.
  3. Maintenez la touche CTRL enfoncée, cliquez sur le fichier vertica-odbc-<version>.mac.pkg, puis cliquez sur Ouvrir pour exécuter le logiciel d'installation. Acceptez les paramètres par défaut.
  4. Ouvrez Tableau Desktop et connectez-vous à HP Vertica.

HP Vertica 7.0.x et version antérieure : procédez comme suit pour installer le pilote Mac correspondant à HP Vertica (version 7.0.x ou antérieure).

  1. Assurez-vous qu'un administrateur ODBC est installé sur votre système. Vous pouvez en télécharger un depuis le site d'Apple : https://support.apple.com/kb/DL895?locale=fr_fr. Maintenez la touche CTRL enfoncée et cliquez sur le fichier .dmg téléchargé pour l'installer.
  2. Téléchargez la dernière version du pilote MAC 64 bits à partir du portail myVertica.
    Pour d'autres scénarios d'installation, consultez la section Installing the ODBC Driver on Macintosh OS X (Installation du pilote ODBC sur Mac OS X) sur le site Web de Vertica.
  3. Lancez Terminal et entrez la commande suivante pour créer le répertoire cible :
    sudo mkdir -p /Library/ODBC/vertica
  4. Passez au répertoire que vous venez de créer :
    cd /Library/ODBC/vertica
  5. Décompressez le fichier contenant le pilote ODBC à l'aide de la commande suivante :
    sudo tar -xzf ~/Downloads/vertica-odbc-<version>.64.mac.tar
    Remarque : remplacez <version> par le numéro de version du fichier téléchargé.
  6. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  7. Cliquez deux fois sur TableauDrivers.dmg dans le dossier Téléchargements.
  8. Cliquez deux fois sur Tableau Vertica Configure.pkg et acceptez les paramètres par défaut. Vous serez invité à redémarrer votre Mac.
  9. Ouvrez Tableau Desktop et connectez-vous à HP Vertica.
Ressources
IBM BigInsights
Tableau Desktop & Tableau Server: 8.2.3 - 10.2.2
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Windows 32 bits pour IBM BigInsights.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Windows 64 bits pour IBM BigInsights.

Ressources
IBM DB2
Tableau Desktop & Tableau Server: toutes les versions prises en charge
Télécharger la version windows 32 bit

Utilisez ce connecteur afin de vous connecter à IBM DB2 pour une base de données z/OS ou à IBM dashDB.

Cliquez sur le lien Télécharger et installez le pilote Windows 32 bits pour IBM DB2.

Ressources
Télécharger la version windows 64 bit

Utilisez ce connecteur afin de vous connecter à IBM DB2 pour une base de données z/OS ou à IBM dashDB.

Cliquez sur le lien Télécharger et installez le pilote Windows 64 bits pour IBM DB2.

Ressources
IBM PDA (Netezza)
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Contactez votre chargé de compte Netezza.

Ressources
JSON File
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Kognitio
Tableau Desktop & Tableau Server: 9.3.1 - 10.2.2
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Windows 32 bits pour Kognitio.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Windows 64 bits pour Kognitio.

Ressources
Tableau Desktop: 9.3.1 - 10.2.2
Télécharger la version mac

Procédez comme suit afin d'installer le pilote Mac pour Kognitio :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez sur le fichier téléchargé.
  4. En maintenant la touche CTRL enfoncée, cliquez sur le fichier Kognitio-ODBC-80101s160113.pkg, puis cliquez sur Ouvrir > Ouvrir pour exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Kognitio.
Ressources
MapR Hadoop Hive
Tableau Desktop & Tableau Server: Toutes les versions prises en charge

Assurez-vous que vous utilisez les derniers pilotes disponibles. Procédez comme suit afin d'installer le pilote Windows pour MapR Hadoop Hive :

  1. Sur le site de documentation de MapR , accédez à la section Install the Hive ODBC Connector on Windows (Installation du connecteur ODBC Hive sur Windows). Les instructions comprennent un lien pour télécharger l'ensemble de pilotes.
  2. Téléchargez l'ensemble de pilotes correspondant à votre environnement Windows.
  3. Suivez les instructions d'installation du connecteur ODBC.
Ressources
Tableau Desktop: Toutes les versions prises en charge

Assurez-vous que vous utilisez les derniers pilotes disponibles. Procédez comme suit afin d'installer le pilote Mac pour MapR Hadoop Hive :

  1. Fermez Tableau Desktop.
  2. Accédez à la section « Installing the Hive ODBC Connector on MacOS » (Installation du connecteur ODBC Hive sur Mac OS) de la page Web MapR Hive ODBC Connector.
  3. Dans la section « System Requirements » (Configuration requise), cliquez sur le lien de téléchargement du connecteur ODBC Hive pour Mac OS.
  4. Cliquez deux fois sur le fichier MapRHiveODBC.dmg téléchargé.
  5. En maintenant la touche CTRL enfoncée, cliquez sur le fichier MapRHiveODBC.pkg. Ensuite, cliquez sur Ouvrir pour exécuter le logiciel d'installation. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à MapR Hadoop Hive.
Ressources
Marketo
Tableau Desktop & Tableau Server: 10.0.1

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: 10.0.1

Il n'est pas obligatoire d'installer un pilote.

Ressources
MarkLogic
Tableau Desktop & Tableau Server: 8.2.3 - 10.2.2
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Windows 32 bits pour MarkLogic.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Windows 64 bits pour MarkLogic.

Ressources
MemSQL
Tableau Desktop & Tableau Server: 10.0 - 10.2.2

MemSQL utilise des pilotes MySQL. Si vous n'avez pas installé de pilotes MySQL, procédez comme suit afin d'installer le pilote Windows pour MySQL :

  1. Accédez au site MySQL.
  2. Sur la page Download Connector/ODBC (télécharger le connecteur/ODBC), sélectionnez le pilote correspondant à votre plate-forme et à la version de votre système.
  3. Téléchargez et installez le pilote.
Ressources
Tableau Desktop: 10.0 - 10.2.2
Télécharger la version mac

MemSQL utilise des pilotes MySQL. Si vous n'avez pas installé de pilotes MySQL, procédez comme suit afin d'installer le pilote Mac pour MySQL :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé TableauDrivers.dmg.
  4. Cliquez deux fois sur le fichier MySQL Connector ODBC 5.3.pkg pour exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à MemSQL.
Ressources

MemSQL uses MySQL drivers. The MySQL Windows driver is installed by default with Tableau Desktop.

Resources
Microsoft Access
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Les produits Tableau utilisent les pilotes installés par Microsoft Office si la version (32 ou 64 bits) est identique. Si tel est le cas, l'installation de pilotes supplémentaires n'est pas nécessaire.

Cependant, vous devez télécharger et installer le moteur de base de données Microsoft Access si l'une des conditions suivantes s'applique :

  • Vous n'avez pas installé Microsoft Office.
  • Vous avez installé Microsoft Office, mais la version est différente de celle des produits Tableau.
Ressources
Microsoft Analysis Services
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Installation des pilotes pour votre version 32 bits de Microsoft Analysis Services :

2014 SP1 (version 12.0.2000.8) 

2012 SP1 (version 11.0.2100.60)

2008 R2 (version 10.51.2500.0)

2008

2005

Ressources

Installation des pilotes pour votre version 64 bits de Microsoft Analysis Services :

2014 SP1 (version 12.0.2000.8) 

2012 SP1 (version 11.0.2100.60)

2008 R2 (version 10.51.2500.0)

2008

2005

Ressources
Microsoft Excel
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Les produits Tableau utilisent les pilotes installés par Microsoft Office pour la connexion aux fichiers Excel si la version (32 ou 64 bits) est identique. Si tel est le cas, l'installation de pilotes supplémentaires n'est pas nécessaire.

Cependant, vous devez télécharger et installer le moteur de base de données Microsoft Access pour connecter Tableau à Excel, si l'une des conditions suivantes s'applique :

  • Vous n'avez pas installé Microsoft Office.
  • Vous avez installé Microsoft Office, mais la version est différente de celle des produits Tableau.
Ressources
Tableau Desktop: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Microsoft PowerPivot
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Important : pour PowerPivot, installez la version du pilote qui correspond à celle de Microsoft Office installée sur votre ordinateur.

Pour vous connecter à PowerPivot, installez le pilote qui prend en charge cette connexion, puis installez le module complémentaire Tableau pour PowerPivot.

URL SharePoint et Microsoft Office (32 bits)

Si vous connectez Tableau à PowerPivot à l'aide de l'URL SharePoint, téléchargez et installez la version 32 bits du pilote SQLSERVER2008_ASOLEDB10 à partir du site Tableau.

Il peut également être nécessaire d'installer Microsoft Core XML Services (MSXML) 6.0 - 32 bits.

URL SharePoint et Microsoft Office (64 bits)

Si vous connectez Tableau à PowerPivot à l'aide d'une URL SharePoint, téléchargez et installez la version 64 bits du pilote SQLSERVER2008_ASOLEDB10 à partir du site Tableau.

Il peut également être nécessaire d'installer Microsoft Core XML Services (MSXML) 6.0 - 64 bits.

UNC SharePoint ou fichier Excel local 

Si vous connectez Tableau à PowerPivot à l'aide d'une UNC SharePoint ou si vous vous connectez à un fichier Excel local, installez les pilotes suivants :

  1. Accédez à la page Microsoft SQL Server 2012 SP1 PowerPivot pour Microsoft Excel 2010 et cliquez sur Télécharger.
  2. Sélectionnez le programme d'installation correspondant à la version de Microsoft Office installée sur votre ordinateur.
  3. Téléchargez et installez le pilote.

Installation du module complémentaire Tableau

Ensuite, installez le module complémentaire Tableau pour Microsoft PowerPivot. Installez la version du module complémentaire Tableau qui correspond à votre version de Microsoft Office :

Ressources
Microsoft SQL Server
Tableau Desktop: 10.2

Le pilote Mac pour Microsoft SQL Server est installé par défaut avec Tableau Desktop.

Ressources
Tableau Desktop: 8.2 - 10.1
Télécharger la version mac

Le connecteur Microsoft SQL Server permet de connecter les produits Tableau à Microsoft SQL Server PDW. Il permet aussi de connecter Tableau 9.0.3. et toute version ultérieure à la base de données Microsoft Azure SQL, ainsi qu'à l'entrepôt de données Microsoft Azure SQL.

Procédez comme suit pour installer le pilote Microsoft SQL Server pour votre ordinateur Mac.

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé TableauDrivers.dmg.
  4. Cliquez deux fois sur Simba SQL Server ODBC.pkg pour exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Microsoft SQL Server.
Ressources
Tableau Desktop: toutes les versions prises en charge

Le connecteur Microsoft SQL Server permet de connecter les produits Tableau à Microsoft SQL Server PDW. Il permet aussi de connecter Tableau 9.0.3. et toute version ultérieure à la base de données Microsoft Azure SQL, ainsi qu'à l'entrepôt de données Microsoft Azure SQL.

Installez le pilote correspondant à votre version 32 bits de Microsoft SQL Server et Tableau Desktop :

  • SQL Server 2008 R2 et Tableau Desktop 9.3 ou versions ultérieures : le pilote est installé par défaut.
  • SQL Server 2008 R2 et Tableau Desktop 8.2 - 9.2.x : téléchargez et installez le pilote.
  • SQL Server 2012 SP3 et toutes les versions de Tableau Desktop : téléchargez et installez le pilote.
  • SQL Server 2016 et Tableau Desktop 9.3 ou versions ultérieures : le pilote est installé par défaut.
  • SQL Server 2016 et Tableau Desktop 8.2 - 9.2.x. Il est recommandé d'utiliser le pilote SQL Server 2008 R2 : téléchargez et installez le pilote.
Ressources

Le connecteur Microsoft SQL Server permet de connecter les produits Tableau à Microsoft SQL Server PDW. Il permet aussi de connecter Tableau 9.0.3. et toute version ultérieure à la base de données Microsoft Azure SQL, ainsi qu'à l'entrepôt de données Microsoft Azure SQL.

Installez le pilote correspondant à votre version 64 bits de Microsoft SQL Server et Tableau Desktop :

  • SQL Server 2008 R2 et Tableau Desktop 9.3 ou versions ultérieures : le pilote est installé par défaut.
  • SQL Server 2008 R2 et Tableau Desktop 8.2 - 9.2.x : téléchargez et installez le pilote.
  • SQL Server 2012 SP3 et toutes les versions de Tableau Desktop : téléchargez et installez le pilote.
  • SQL Server 2016 et Tableau Desktop 9.3 ou versions ultérieures : le pilote est installé par défaut.
  • SQL Server 2016 et Tableau Desktop 8.2 - 9.2.x. Il est recommandé d'utiliser le pilote SQL Server 2008 R2 : téléchargez et installez le pilote.
Ressources
Tableau Server: toutes les versions prises en charge

Le connecteur Microsoft SQL Server permet de connecter les produits Tableau à Microsoft SQL Server PDW. Il permet aussi de connecter Tableau 9.0.3. et toute version ultérieure à la base de données Microsoft Azure SQL, ainsi qu'à l'entrepôt de données Microsoft Azure SQL.

Installez le pilote correspondant à votre version 64 bits de Microsoft SQL Server et Tableau Server :

  • SQL Server 2008 R2 et toutes les versions prises en charge de Tableau Server : téléchargez et installez le pilote.
  • SQL Server 2012 SP3 et toutes les versions prises en charge de Tableau Server : téléchargez et installez le pilote.
  • SQL Server 2016 et toutes les versions prises en charge de Tableau Server. Il est recommandé d'utiliser le pilote SQL Server 2008 R2 : téléchargez et installez le pilote.
Ressources

Le connecteur Microsoft SQL Server permet de connecter les produits Tableau à Microsoft SQL Server PDW. Il permet aussi de connecter Tableau 9.0.3. et toute version ultérieure à la base de données Microsoft Azure SQL, ainsi qu'à l'entrepôt de données Microsoft Azure SQL.

Installez le pilote correspondant à votre version 32 bits de Microsoft SQL Server et Tableau Server :

  • SQL Server 2008 R2 et toutes les versions prises en charge de Tableau Server : téléchargez et installez le pilote.
  • SQL Server 2012 SP3 et toutes les versions prises en charge de Tableau Server : téléchargez et installez le pilote.
  • SQL Server 2016 et toutes les versions prises en charge de Tableau Server. Il est recommandé d'utiliser le pilote SQL Server 2008 R2 : téléchargez et installez le pilote.
Ressources
MonetDB
Tableau Desktop & Tableau Server: 9.1.2 - 10.2.2

Procédez comme suit pour installer le pilote MonetDB de Windows pour Tableau 9.1.2 et versions ultérieures.

  1. Accédez à la page de téléchargement MonetDB pour Windows et sélectionnez le répertoire Jun2016. Nous vous conseillons d'utiliser le pilote Jun2016.
  2. Sélectionnez le programme d'installation ODBC pour votre environnement Windows.
  3. Téléchargez et installez le pilote.
Ressources
MySQL
Tableau Desktop: 10.2

Le pilote Mac pour MySQL est installé par défaut avec Tableau Desktop.

Ressources
Tableau Desktop: 9.3 - [version actuelle]

Le pilote MySQL pour Windows est installé par défaut avec Tableau Desktop.

Ressources
Tableau Desktop: 8.2 - 10.1
Télécharger la version mac

Procédez comme suit afin d'installer le pilote MySQL sur votre ordinateur Mac :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé TableauDrivers.dmg.
  4. Cliquez deux fois sur le fichier MySQL Connector ODBC 5.3.pkg pour exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à MySQL.
Ressources
Tableau Desktop: 8.2 - 9.2

Procédez comme suit afin d'installer le pilote MySQL sur votre ordinateur Windows :

  1. Accédez à la page de téléchargement MySQL pour les connecteurs ODBC.
  2. Sélectionnez le programme d'installation MSI correspondant à votre environnement Windows : 32 ou 64 bits.
  3. Téléchargez et installez le pilote.

Remarque : nous vous recommandons fortement d'effectuer une mise à niveau vers la dernière version du pilote ODBC MySQL, car elle contient un correctif pour la faille Heartbleed.

Ressources
Tableau Server: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote MySQL sur votre ordinateur Windows :

  1. Accédez à la page de téléchargement MySQL pour les connecteurs ODBC.
  2. Sélectionnez le programme d'installation MSI correspondant à votre environnement Windows : 32 ou 64 bits.
  3. Téléchargez et installez le pilote.

Remarque : nous vous recommandons fortement d'effectuer une mise à niveau vers la dernière version du pilote ODBC MySQL, car elle contient un correctif pour la faille Heartbleed.

Ressources
OData
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Utilisez le connecteur OData pour vous connecter aux données de Windows Azure Marketplace.

Ressources
Oracle
Tableau Desktop: 10.2
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle pour Tableau Desktop 10.2 sur Windows 32 bits.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle pour Tableau Desktop 10.2 sur Windows 64 bits.

Ressources

Le pilote Mac pour Oracle est installé par défaut avec Tableau Desktop.

Ressources
Tableau Desktop: 10.1
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle pour Tableau Desktop 10.1 sur Windows 32 bits.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle pour Tableau Desktop 10.1 sur Windows 64 bits.

Ressources
Tableau Desktop: 10.0
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 32 bits pour Tableau Desktop 10.0.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 64 bits pour Tableau Desktop 10.0.

Ressources
Tableau Desktop: 9.3
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 32 bits pour Tableau Desktop 9.3.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 64 bits pour Tableau Desktop 9.3.

Ressources
Tableau Desktop: 9.2
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 32 bits pour Tableau Desktop 9.2.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 64 bits pour Tableau Desktop 9.2.

Ressources
Tableau Desktop: 9.1
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 32 bits pour Tableau Desktop 9.1.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 64 bits pour Tableau Desktop 9.1.

Ressources
Tableau Desktop: 9.0
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 32 bits pour Tableau Desktop 9.0.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 64 bits pour Tableau Desktop 9.0.

Ressources
Tableau Desktop: 8.3
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 32 bits pour Tableau Desktop 8.3.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 64 bits pour Tableau Desktop 8.3.

Ressources
Tableau Desktop: 8.2
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 32 bits pour Tableau Desktop 8.2.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle compatible sous Windows 64 bits pour Tableau Desktop 8.2.

Ressources
Tableau Desktop: 8.2 - 10.1
Télécharger la version mac

Procédez comme suit afin d'installer le pilote Oracle sur votre ordinateur Mac :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé TableauDrivers.dmg.
  4. Cliquez deux fois sur Tableau Oracle Libraries.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Oracle.
Ressources
Tableau Server: toutes les versions prises en charge

Le pilote Oracle pour Windows 32 bits est installé par défaut avec Tableau Server.

Ressources

Le pilote Oracle pour Windows 64 bits est installé par défaut avec Tableau Server.

Ressources
Oracle Eloqua
Tableau Desktop & Tableau Server: 10.1.2

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: 10.1.2

Il n'est pas obligatoire d'installer un pilote.

Ressources
Oracle Essbase
Tableau Desktop: 10.2
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase pour Tableau Desktop 10.2 sur Windows 64 bits.

Ressources
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase pour Tableau Desktop 10.2 sur Windows 32 bits.

Ressources
Tableau Desktop: 10.1
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase pour Tableau Desktop 10.1 sur Windows 64 bits.

Ressources
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase pour Tableau Desktop 10.1 sur Windows 32 bits.

Ressources
Tableau Desktop: 10.0
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 64 bits pour Tableau Desktop 10.0.

Ressources
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 32 bits pour Tableau Desktop 10.0.

Ressources
Tableau Desktop: 9.3
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 32 bits pour Tableau Desktop 9.3.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 64 bits pour Tableau Desktop 9.3.

Ressources
Tableau Desktop: 9.2
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 32 bits pour Tableau Desktop 9.2.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 64 bits pour Tableau Desktop 9.2.

Ressources
Tableau Desktop: 9.1
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 32 bits pour Tableau Desktop 9.1.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 64 bits pour Tableau Desktop 9.1.

Ressources
Tableau Desktop: 9.0
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 32 bits pour Tableau Desktop 9.0.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 64 bits pour Tableau Desktop 9.0.

Ressources
Tableau Desktop: 8.3
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 32 bits pour Tableau Desktop 8.3.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 64 bits pour Tableau Desktop 8.3.

Ressources
Tableau Desktop: 8.2
Télécharger la version windows 32 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 32 bits pour Tableau Desktop 8.2.

Ressources
Télécharger la version windows 64 bit

Cliquez sur le lien Télécharger et installez le pilote Oracle Essbase compatible sous Windows 64 bits pour Tableau Desktop 8.2.

Ressources
Tableau Server: toutes les versions prises en charge

Le pilote Oracle Essbase pour Windows 32 bits est installé par défaut avec Tableau Server.

Ressources

Le pilote Oracle Essbase pour Windows 64 bits est installé par défaut avec Tableau Server.

Ressources
Other Databases (ODBC)
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Important : si vous utilisez un pilote ODBC pour vous connecter à une base de données non prise en charge, les résultats peuvent varier. La compatibilité avec les fonctionnalités de Tableau Desktop et Tableau Server n'est pas garantie.

Ressources
Pivotal Greenplum Database
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote de Pivotal Greenplum Database sur votre ordinateur Windows :

  1. Accédez au site Pivotal , puis ouvrez une session.
  2. Faites défiler la page vers le bas, jusqu'à la section Data (données), puis cliquez sur Pivotal Greenplum.
  3. Dans la section Release Download Files (fichiers de téléchargement de version), cliquez sur Greenplum DataDirect ODBC and JDBC Drivers (pilotes JDBC et ODBC Greenplum DataDirect).
  4. Sélectionnez le pilote ODBC correspondant à votre environnement : Windows 32 ou 64 bits.
  5. Téléchargez et installez le pilote.
Ressources
Tableau Desktop: toutes les versions prises en charge
Télécharger la version mac

Procédez comme suit afin d'installer le pilote de Pivotal Greenplum Database sur votre ordinateur Mac :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé TableauDrivers.dmg.
  4. Cliquez deux fois sur Tableau PostgreSQL Libraries.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Pivotal Greenplum Database.
Ressources
PostgreSQL
Tableau Desktop: 10.2

Le pilote Mac pour PostgreSQL est installé par défaut avec Tableau Desktop.

Ressources
Tableau Desktop: 9.3 - 10.2.2

Le pilote PostgreSQL est installé par défaut avec Tableau Desktop 9.3 et versions ultérieures.

Ressources
Tableau Desktop: 8.2 - 9.2
Télécharger la version windows 32 bit, 64 bit

Cliquez sur le lien Télécharger et installez le pilote Windows pour PostgreSQL.

Ressources
Tableau Desktop: 8.2 - 10.1
Télécharger la version mac

Procédez comme suit afin d'installer le pilote Mac pour PostgreSQL :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé.
  4. Cliquez deux fois sur Tableau PostgreSQL Libraries.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à PostgreSQL.
Ressources
Tableau Server: toutes les versions prises en charge
Télécharger la version windows 32 bit, 64 bit

Cliquez sur le lien Télécharger et installez le pilote Windows pour PostgreSQL.

Ressources
Presto
Tableau Desktop & Tableau Server: 10.0 - 10.2.2

Procédez comme suit afin d'installer le pilote Windows pour Presto :

  1. Accédez à la page Web Teradata Presto, puis complétez les champs avec les informations demandées.
  2. Téléchargez le fichier tar.gz du package client Presto (Presto Client Package).
  3. Décompressez le fichier tar.gz.
  4. Cliquez deux fois sur le fichier .msi correspondant à votre environnement pour démarrer l'assistant de configuration du pilote ODBC Teradata Presto.
Ressources
Tableau Desktop: 10.0 - 10.2.2

Procédez comme suit afin d'installer le pilote Mac pour Presto :

  1. Fermez Tableau Desktop.
  2. Rendez-vous sur le site de Teradata Presto, puis complétez les champs avec les informations demandées.
  3. Cliquez sur Download (Télécharger).
  4. Acceptez le contrat de licence.
  5. Cliquez sur Presto Client Package pour télécharger le fichier .tar.gz.
  6. Cliquez deux fois sur le fichier téléchargé pour le décompresser.
  7. Cliquez deux fois sur le fichier .dmg.
  8. Maintenez la touche CTRL enfoncée et cliquez sur le fichier .pkg, puis sur Ouvrir > Ouvrir.
  9. Suivez les instructions qui s'affichent pour installer le pilote ODBC Teradata Presto.
  10. Ouvrez Tableau Desktop et connectez-vous à Presto.
Ressources
Progress OpenEdge
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Contactez votre chargé de compte Progress.

Ressources
QuickBooks Online
Tableau Desktop & Tableau Server: 10.0 - 10.2.2

Il n'est pas obligatoire d'installer un pilote.

Ressources
Salesforce
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
SAP HANA
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Connectez-vous au centre de téléchargement de logiciel SAP afin d'obtenir le pilote Windows pour SAP HANA. Si vous ne disposez pas des informations d'identification pour vous connecter, contactez l'administrateur SAP afin d'obtenir de l'aide.

Ressources
Tableau Desktop: 10.0 - 10.2.2

Procédez comme suit afin d'installer le pilote JDBC pour SAP HANA sur votre ordinateur Mac :

  1. Fermez Tableau Desktop.
  2. Si Java n'est pas encore installé sur votre Mac, téléchargez la version la plus récente depuis https://www.java.com/fr/download et installez-la.
  3. Demandez à votre administrateur de vous fournir le pilote SAP HANA JDBC (ngdbc.jar), puis copiez le fichier dans le répertoire ~/Library/Tableau/Drivers. Ce répertoire est créé lorsque vous démarrez Tableau pour la première fois.
  4. Assurez-vous que vous disposez des droits de lecture sur le fichier .jar afin que Tableau puisse y accéder.
  5. Ouvrez Tableau Desktop et connectez-vous à SAP HANA.
Ressources
SAP NetWeaver Business Warehouse
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Connectez-vous au centre de téléchargement de logiciel SAP afin d'obtenir le pilote Windows pour SAP NetWeaver Business Warehouse. Si vous ne disposez pas des informations d'identification pour vous connecter, contactez l'administrateur SAP afin d'obtenir de l'aide.

Ressources
SAP Sybase ASE
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Connectez-vous au centre de téléchargement de logiciel SAP afin d'obtenir le pilote Windows pour SAP Sybase ASE. Si vous ne disposez pas des informations d'identification pour vous connecter, contactez l'administrateur SAP afin d'obtenir de l'aide.

Ressources
SAP Sybase IQ
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Connectez-vous au centre de téléchargement de logiciel SAP afin d'obtenir le pilote Windows pour SAP Sybase IQ. Si vous ne disposez pas des informations d'identification pour vous connecter, contactez l'administrateur SAP afin d'obtenir de l'aide.

Ressources
SharePoint Lists
Tableau Desktop & Tableau Server: 10.2
Télécharger la version windows 32 bit, 64 bit

Cliquez sur le lien Télécharger, puis suivez les instructions pour installer le pilote Windows pour les listes SharePoint (pilote ODBC CData pour SharePoint).

Ressources
Tableau Desktop: 10.2
Télécharger la version mac

Procédez comme suit afin d'installer le pilote Mac pour les listes SharePoint :

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez sur le fichier .dmg téléchargé.
  4. Double-cliquez sur le fichier .pkg du pilote ODBC CData pour SharePoint afin d'exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous aux listes SharePoint.
Ressources
Snowflake
Tableau Desktop & Tableau Server: 9.3 - 10.2.2

Procédez comme suit afin d'installer le pilote ODBC de Windows pour Snowflake :

  1. Connectez-vous à l'instance Snowflake.
  2. Sélectionnez Help > Download > ODBC Driver (Aide > Télécharger > Pilote ODBC).
  3. Sélectionnez le pilote ODBC correspondant à votre système d'exploitation pour télécharger la dernière version.

Pour en savoir plus sur l'installation et la configuration, suivez le lien vers la documentation Snowflake sur la page du pilote ODBC.

Ressources
Tableau Desktop: 9.3 - 10.2.2

Procédez comme suit afin d'obtenir le pilote ODBC de Mac pour Snowflake :

  1. Connectez-vous à l'instance Snowflake.
  2. Sélectionnez Help > Download > ODBC Driver (Aide > Télécharger > Pilote ODBC).
  3. Sélectionnez le pilote ODBC correspondant à votre système d'exploitation pour télécharger la dernière version.

Pour en savoir plus sur l'installation et la configuration, suivez le lien vers la documentation Snowflake sur la page du pilote ODBC.

Ressources
Spark SQL
Tableau Desktop & Tableau Server: 8.2.8 - 8.2.x, 8.3.3 - 8.3.x, 9.0 - 10.2.2
Télécharger la version windows 32 bit

Utilisez le connecteur Spark SQL pour vous connecter à un cluster Spark sur Azure HDInsight, Databricks ou Apache Spark.

Cliquez sur le lien Télécharger et installez le pilote Windows 32 bits pour Spark SQL.

Ressources
Télécharger la version windows 64 bit

Utilisez le connecteur Spark SQL pour vous connecter à un cluster Spark sur Azure HDInsight, Databricks ou Apache Spark.

Cliquez sur le lien Télécharger et installez le pilote Windows 64 bits pour Spark SQL.

Ressources
Tableau Desktop: 10.2

Le pilote Mac pour Spark SQL est installé par défaut avec Tableau Desktop.

Ressources
Tableau Desktop: 8.2.8 - 8.2.x, 8.3.3 - 8.3.x, 9.0 - 10.1
Télécharger la version mac

Procédez comme suit pour installer le pilote Spark SQL sur votre ordinateur Mac.

  1. Fermez Tableau Desktop.
  2. Téléchargez les pilotes en cliquant sur le lien Télécharger.
  3. Cliquez deux fois sur le fichier téléchargé, TableauDrivers.dmg.
  4. Cliquez deux fois sur le fichier SimbaSparkODBC.dmg pour exécuter le programme d'installation.
  5. Acceptez les paramètres par défaut.
  6. Ouvrez Tableau Desktop et connectez-vous à Spark SQL.
  7. Ressources
Spatial File
Tableau Desktop & Tableau Server: 10.2
Tableau Desktop: 10.2
Splunk
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Procédez comme suit afin d'installer le pilote Windows pour Splunk :

  1. Accédez à la page du pilote ODBC Splunk et ouvrez une session.
  2. Téléchargez et installez le pilote.
Ressources
Statistical File
Tableau Desktop & Tableau Server: 9.0 - 10.2.2

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: 9.0 - 10.2.2

Il n'est pas obligatoire d'installer un pilote.

Ressources
Teradata
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Outre la connexion à un serveur Teradata, pour Tableau Desktop 8.2.9 - 8.2.x, 8.3.4 et version ultérieure, utilisez le connecteur Teradata afin de vous connecter à un serveur Teradata Unity.

Procédez comme suit afin d'installer le pilote Windows pour Teradata :

  1. Accédez à la page Downloads du site Teradata et ouvrez une session.
  2. Sélectionnez ODBC Driver > Windows.
  3. Téléchargez le dernier pilote ODBC de Teradata pour Windows.
  4. Décompressez le fichier téléchargé et installez les pilotes.
Ressources
Tableau Desktop: toutes les versions prises en charge

Outre la connexion à un serveur Teradata, pour Tableau Desktop 8.2.9 - 8.2.x, 8.3.4 et version ultérieure, utilisez le connecteur Teradata afin de vous connecter à un serveur Teradata Unity.

Procédez comme suit afin d'installer les pilotes Mac pour Teradata :

  1. Fermez Tableau Desktop.
  2. Sur la page Downloads du site de Teradata, connectez-vous à votre compte Teradata.
  3. Sélectionnez ODBC Driver > Mac.
  4. Téléchargez le dernier pilote ODBC de Teradata pour Mac OS X.
  5. Cliquez deux fois sur le fichier .tar téléchargé.
  6. En maintenant la touche Ctrl enfoncée, cliquez sur Ouvrir pour exécuter le fichier .pkg Teradata. Acceptez les paramètres par défaut.
    Remarque : le message d'erreur suivant peut s'afficher : « ODBC Administrator Tool does not appear to be installed. » (Il semblerait que l'Administrateur ODBC ne soit pas installé). Cliquez sur OK pour fermer ce message d'erreur. Cette erreur n'a pas de conséquence sur l'installation du pilote.
  7. Redémarrez l'ordinateur.
  8. Ouvrez Tableau Desktop et connectez-vous à un serveur Teradata.
Ressources
Teradata OLAP
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Contactez votre chargé de compte Teradata.

Ressources
Text File
Tableau Desktop & Tableau Server: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Tableau Desktop: toutes les versions prises en charge

Il n'est pas obligatoire d'installer un pilote.

Ressources
Web Data Connector
Tableau Desktop & Tableau Server: 9.1 - 10.2.2

Cette source de données n'est pas prise en charge par le système d'exploitation sélectionné.

Connecteurs de données Web de la communauté

Affichez les connecteurs de données Web créés par les clients et les partenaires Tableau.