版本号

10300.17.0515.2100


发行日期

2017-05-31


产品支持

阅读更多内容

What's New

Help Redesign


Combined help system

Starting with version 10.3, Tableau Desktop Help is now known as Tableau Help. Tableau Help contains all help topics related to analyzing and consuming data in Tableau Desktop, Tableau Server, and Tableau Online. This help is for people who create workbooks or data sources and publish them, and for people who want to see, interact with, and share views in Tableau.

We welcome your feedback on this change, as well as any feedback or ideas you might have on how to make our content better. Please use the feedback bar on the top of any page ("Was this page helpful?") to open the comment field and submit your feedback.

Using Tableau on the Web provides links to the topics that used to be located in Tableau Server and Tableau Online help.

Connect to and Prepare Data


Connect to .pdf files

Now you can use the PDF File connector to connect to tables in your .pdf files. For more information, see PDF File.

Union even more data

You can union tables from a .pdf file as well as Aster Database, Cloudera Hadoop, Hortonworks Hadoop, IBM DB2, IBM PDA (Netezza), Pivotal Greenplum Database, SAP Sybase ASE, SAP Sybase IQ, and Teradata. For more information about union, see Union Your Data.

Recommended tables and joins

When you’re setting up your Tableau data source or modifying an existing one, it can be helpful to see what tables are popular with other people at your organization. So when you connect to a database while simultaneously signed in to Tableau Server (from Tableau Desktop), in the left pane a Recommended list shows the tables used most often in data sources and workbooks published to Tableau Server.

After you add a recommended table to the canvas, others tables that are frequently joined to it appear in the Recommended list. Double-click one to automatically create a recommended join between the tables, using the most popular fields and join type by default. Note: If foreign keys are specified in the database, they override the recommended joins.

Recommended tables and joins are supported for a subset of connectors. For more information, see About Recommended tables and joins.

New connectors

New Amazon Athena connector

Use the Amazon Athena connector to connect to Amazon Athena data. For more information, see Amazon Athena.

New Dropbox connector

Use the Dropbox connector to connect data on Dropbox. For more information, see Dropbox.

New MongoDB BI connector

Use the MongoDB BI connector to connect to MongoDB BI data. For more information, see MongoDB BI.

New OneDrive connector

Use the OneDrive connector to connect to data on OneDrive. For more information, see OneDrive.

New ServiceNow ITSM connector

Use the ServiceNow ITSM connector to connect to ServiceNow ITSM data. For more information, see ServiceNow ITSM.

JSON schema updates

Tableau scans the data in the first 10,000 rows of the JSON file and infers the schema from that process. Sometimes, more fields exist in rows that were not scanned to create the inferred schema. Now, Tableau indicates when additional fields are detected that you may want to include in your analysis. For more information, see JSON File.

Design Views and Analyze Data


Double-click to zoom

In prior releases, when you double-clicked on a view that used continuous measures for both the X and Y axis (also known as quantitative/quantitative views, for example scatter plots) and the View toolbar was turned off, Tableau would automatically zoom in.

This resulted in a confusing user experience. Now for these quantitative/quantitative non-map view types, Tableau no longer zooms in by default when you double-click on the view. This change applies to new workbooks and upgraded workbooks. The double-click to zoom functionality is also turned off by default for table and cross-tab chart types.

Tooltip selection

This feature enables you to select similar marks in a view from the tooltip by category. Any discrete dimension or measure that is included in the tooltip becomes an active link that you can click on to select other marks in the view that have the same value.

This feature works on Tableau Desktop, Tableau Server and Tableau Mobile. It is turned on by default for new worksheets and turned off by default for upgraded worksheets. To turn the feature off or on, at the worksheet level click Tooltip on the marks card to open the Edit Tooltip dialog box, and then clear or select the Allow selection by category check box.

For more information, see Tooltips.

Latest date presets for discrete date filters

Discrete date filters can be set to filter to the latest date value in the data source. You can use this setting to ensure that the most recent date in the data source is selected in the filter. For details, see Latest Date Preset for "Filter Discrete Dates" under "Filter Dates" (Desktop) in Filter Data from Your Views.

On Tableau Server and Tableau Online, presets are applied when the view first loads in the browser, but not when the browser or data is refreshed.

Apply table calculation filters to totals

When you show totals and you want a table calculation filter to apply to the totals, you can now select Apply to totals in the drop-down menu for that filter (on the Filters shelf). This option lets you decide when a table calculation filter should be applied to totals. For details, see "Filter table calculations" in Filter Data from Your Views.

Map data updates and additions

The following data has been updated for Tableau version 10.3:

  • French region names were updated to the final 2016 naming scheme.

  • NUTS (Nomenclature of Territorial Units for Statistics) codes and Airport codes no longer require country as a parent to geocode on a map.

  • Netherlands landen and provincies were updated.

  • Australian LGAs were updated with 2016 data.

Additionally, Rwanda districts (uturere) are now supported by Tableau, and can be geocoded using the County geographic role. Polygons for New Zealand postcodes were also added. For more information about additional map data supported by Tableau, see What data does Tableau support for building map views.

Evenly distribute a layout container's items

After you add a layout container to a dashboard, you can make the items it contains evenly spaced using the Distribute Evenly command (on the desktop and in web authoring). For details, see Size and Lay Out Your Dashboard.

Easy access to story actions

The new story toolbar appears when you mouse-over the story navigation area. Use it to revert story changes, apply updates to a story point, delete a story point, or create a new story point out of the current, customized one.

Use numbers for story navigation

The story Layout tab includes a new navigation option: Numbers. Use this option to make the story navigator display a sequence of numbers instead of caption boxes or dots. For details, see Create a Story.

New to Web Authoring


Web authoring topics for Tableau Server and Tableau Online are now located in Tableau Help, starting with version 10.3. To see web authoring features from past releases, see What's New in Tableau Server.

Edit quantitative color legends

You can now edit the color palette for continuous color legends in web authoring. You can open the Edit Colors dialog box from the Marks card or by clicking the drop-down arrow on the legend.

You can also set a custom color for the start and end colors by entering the Hex value.

Edit colors on separated legends

When you create separate color legends for measures in your view, you are no longer restricted to using only the default color palette or the color palette assigned to each color legend when the view was published from Tableau Desktop.

In web authoring mode, you can now select different color palettes for each legend. Click the drop-down arrow on the legend to open the Edit Colors dialog box and then select the color palette. You can also set custom start and end colors using Hex values.

Customize how people interact with your map

In web authoring mode, you can now customize how your audience interacts with your map view in the following ways using the Map Options dialog box:

  • Show a map scale
  • Hide map search
  • Hide the view toolbar
  • Turn off pan and zoom

For more information, see Customize How People Interact with your Map.

Format numbers on the web

You can now specify basic number formatting for measures in the view on Tableau Server and Tableau Online. For more information, see Format Numbers and Null Values on Tableau Server or Tableau Online.

Format lines

When you are authoring on the web, you can quickly change all the lines in your workbook. Select Format > Workbook, then expand the Lines section on the Format Workbook and make your selections. For more information, see Format at the Workbook Level.

Create stories

In web authoring, you can now create a story to tell a data narrative, provide context, demonstrate how decisions relate to outcomes, or to simply make a compelling case. See Create a Story for details.

Create and edit bins

Create bins from continuous measures and edit them in Tableau Server and Tableau Online, similar to how you do it in Tableau Desktop. For details, see Create Bins from a Continuous Measure.

Drag fields to Show Me in the view

Select and drag dimensions and measures of interest to the view area. A "Show Me" view is automatically created. You can then click other Show Me options to try different view types.

Drill up and down a continuous hierarchy in the view

In a view with a continuous hierarchy, hover near the headers on a continuous axis to display the + and - controls. Click to drill down or up.

Save data source

You now have the option to save a data source that is embedded with a published workbook, as a separate, published data source on Tableau Server and Tableau Online that other users can connect to. When you save the data source, you can choose to update the workbook to connect to the newly saved data source.

Share and Collaborate


Data-driven alerts from Tableau Server

When data reaches important thresholds for your business, data-driven alerts automatically send email notifications to key people you specify. You can set alerts on all chart types except Gantt charts and maps.

To begin, select a continuous numeric axis of a chart.

Then click Alert in the toolbar.

When the Create Alert pop-up window appears, set the data condition and threshold value that triggers alert emails. In the view, a red line shows where the threshold falls relative to current data. Simply specify the email subject line, schedule, and recipients to start alerting your organization about critical metrics.

To manage alerts you own or receive, click your name at the top right corner of a Tableau Server page, click My Content, and then click Alerts.

For more details, see Send Data-Driven Alerts from Tableau Server.

For more information about Tableau 10.3, see the new features list.